aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2018-06-11 09:44:15 +0800
committerlinimon <linimon@FreeBSD.org>2018-06-11 09:44:15 +0800
commit39e31de51fbf694ff20f162572dc22c61f7d1b9d (patch)
treed21fd4ee60da4c705d6bb2d4d0222a7e7af7ef7b /math
parent1ddd46af14a4033deba9f651fa531f8aa83ea3f7 (diff)
downloadfreebsd-ports-gnome-39e31de51fbf694ff20f162572dc22c61f7d1b9d.tar.gz
freebsd-ports-gnome-39e31de51fbf694ff20f162572dc22c61f7d1b9d.tar.zst
freebsd-ports-gnome-39e31de51fbf694ff20f162572dc22c61f7d1b9d.zip
Fix port builds for architectures which remain on gcc as the default compiler.
This will primarily help powerpc64. For archs where clang is the default compiler, these changes will have no effect, as the base compiler already has these capabilities (primarily, but not exclusively, c++-11). Tested for no-harm on amd64. While here, pet portlint. Approved by: portmgr (tier-2 blanket)
Diffstat (limited to 'math')
-rw-r--r--math/ambit/Makefile3
-rw-r--r--math/clblast/Makefile3
-rw-r--r--math/glm/Makefile3
3 files changed, 5 insertions, 4 deletions
diff --git a/math/ambit/Makefile b/math/ambit/Makefile
index 7e492e2e5ed3..061d3719e2c8 100644
--- a/math/ambit/Makefile
+++ b/math/ambit/Makefile
@@ -17,7 +17,8 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libhdf5.so:science/hdf5 \
libsz.so:science/szip
-USES= cmake:outsource
+USES= cmake:outsource compiler:c++11-lang
+USE_GCC= yes
USE_GITHUB= yes
GH_ACCOUNT= jturney
diff --git a/math/clblast/Makefile b/math/clblast/Makefile
index f4e49bd9914b..4772f70d3cf1 100644
--- a/math/clblast/Makefile
+++ b/math/clblast/Makefile
@@ -19,7 +19,8 @@ USE_GITHUB= yes
GH_ACCOUNT= CNugteren
GH_PROJECT= CLBlast
-USE_LDCONFIG= yes
USES= cmake
+USE_GCC= yes
+USE_LDCONFIG= yes
.include <bsd.port.mk>
diff --git a/math/glm/Makefile b/math/glm/Makefile
index 2ce69ac04385..c782e9cea49e 100644
--- a/math/glm/Makefile
+++ b/math/glm/Makefile
@@ -12,13 +12,12 @@ COMMENT= C++ mathematics library for software based on the OpenGL GLSL
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/copying.txt
+USES= cmake:outsource compiler:c++11-lang pkgconfig
USE_GITHUB= yes
GH_ACCOUNT= g-truc
NO_ARCH= yes
-USES= cmake:outsource pkgconfig
-
OPTIONS_DEFINE= TEST
TEST_CMAKE_BOOL= GLM_TEST_ENABLE
TEST_TEST_TARGET= test