aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authortobez <tobez@FreeBSD.org>2010-02-02 04:48:50 +0800
committertobez <tobez@FreeBSD.org>2010-02-02 04:48:50 +0800
commit3e6ff0e022b787b6b2dc89bda0ea1f2d1a2cd93a (patch)
tree3eb72e7157a5e4003420bfe35a2207be43fe47cd /math
parentcb96bb9bca9929d9655e7663bcebe3512ebd2d85 (diff)
downloadfreebsd-ports-gnome-3e6ff0e022b787b6b2dc89bda0ea1f2d1a2cd93a.tar.gz
freebsd-ports-gnome-3e6ff0e022b787b6b2dc89bda0ea1f2d1a2cd93a.tar.zst
freebsd-ports-gnome-3e6ff0e022b787b6b2dc89bda0ea1f2d1a2cd93a.zip
Add math/p5-GIS-Distance-Fast, a C (XS) implementation of GIS::Distance
formulas.
Diffstat (limited to 'math')
-rw-r--r--math/Makefile1
-rw-r--r--math/p5-GIS-Distance-Fast/Makefile28
-rw-r--r--math/p5-GIS-Distance-Fast/distinfo3
-rw-r--r--math/p5-GIS-Distance-Fast/pkg-descr5
-rw-r--r--math/p5-GIS-Distance-Fast/pkg-plist16
5 files changed, 53 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 84925aed696f..fac35f506b39 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -293,6 +293,7 @@
SUBDIR += p5-Data-Float
SUBDIR += p5-Date-Handler
SUBDIR += p5-GIS-Distance
+ SUBDIR += p5-GIS-Distance-Fast
SUBDIR += p5-Geo-Coordinates-UTM
SUBDIR += p5-Geo-Distance
SUBDIR += p5-Geo-Distance-XS
diff --git a/math/p5-GIS-Distance-Fast/Makefile b/math/p5-GIS-Distance-Fast/Makefile
new file mode 100644
index 000000000000..0847826921d9
--- /dev/null
+++ b/math/p5-GIS-Distance-Fast/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: math/p5-GIS-Distance-Fast
+# Date created: 01 February 2010
+# Whom: Anton Berezin <tobez@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= GIS-Distance-Fast
+PORTVERSION= 0.05
+CATEGORIES= math perl5
+MASTER_SITES= CPAN/../../authors/id/B/BL/BLUEFEET
+MASTER_SITE_SUBDIR= GIS
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tobez@FreeBSD.org
+COMMENT= C implementation of GIS::Distance formulas
+
+BUILD_DEPENDS= p5-GIS-Distance>=0.06:${PORTSDIR}/math/p5-GIS-Distance
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= GIS::Distance::Fast.3 \
+ GIS::Distance::Formula::Cosine::Fast.3 \
+ GIS::Distance::Formula::Haversine::Fast.3 \
+ GIS::Distance::Formula::Vincenty::Fast.3
+
+.include <bsd.port.mk>
diff --git a/math/p5-GIS-Distance-Fast/distinfo b/math/p5-GIS-Distance-Fast/distinfo
new file mode 100644
index 000000000000..56c0439de538
--- /dev/null
+++ b/math/p5-GIS-Distance-Fast/distinfo
@@ -0,0 +1,3 @@
+MD5 (GIS-Distance-Fast-0.05.tar.gz) = b970c721afd7caca1f26bde3129cd06b
+SHA256 (GIS-Distance-Fast-0.05.tar.gz) = 1b36dd67ba878050e76cc392e2da4715533d0a940c17f522249c25faf9634925
+SIZE (GIS-Distance-Fast-0.05.tar.gz) = 17859
diff --git a/math/p5-GIS-Distance-Fast/pkg-descr b/math/p5-GIS-Distance-Fast/pkg-descr
new file mode 100644
index 000000000000..a353e832538d
--- /dev/null
+++ b/math/p5-GIS-Distance-Fast/pkg-descr
@@ -0,0 +1,5 @@
+This distribution re-implements some, but not all, of the formulas that
+come with GIS::Distance in the C programming language. C code is
+generally much faster than the perl equivilent.
+
+WWW: http://search.cpan.org/dist/GIS-Distance-Fast/
diff --git a/math/p5-GIS-Distance-Fast/pkg-plist b/math/p5-GIS-Distance-Fast/pkg-plist
new file mode 100644
index 000000000000..4410c1327ed1
--- /dev/null
+++ b/math/p5-GIS-Distance-Fast/pkg-plist
@@ -0,0 +1,16 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/GIS/Distance/Fast.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/GIS/Distance/Formula/Cosine/Fast.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/GIS/Distance/Formula/Haversine/Fast.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/GIS/Distance/Formula/Vincenty/Fast.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/GIS/Distance/Fast/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/GIS/Distance/Fast/Fast.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/GIS/Distance/Fast/Fast.so
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/GIS/Distance/Formula/Haversine
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/GIS/Distance/Formula/Vincenty
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/GIS/Distance/Formula/Cosine
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/GIS/Distance/Fast
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/GIS/Distance/Formula
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/GIS/Distance
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/GIS/Distance
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/GIS
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/GIS