aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authormaho <maho@FreeBSD.org>2007-03-27 10:36:33 +0800
committermaho <maho@FreeBSD.org>2007-03-27 10:36:33 +0800
commit5c7b64454793bc4fa1c1e17c78be5b3529367a60 (patch)
tree952f48e67edee256711ee3a8d9783a1c4ba9efdf /math
parentbc2b375e9e12679d503e2cdc9fef8c8d6155ea4c (diff)
downloadfreebsd-ports-gnome-5c7b64454793bc4fa1c1e17c78be5b3529367a60.tar.gz
freebsd-ports-gnome-5c7b64454793bc4fa1c1e17c78be5b3529367a60.tar.zst
freebsd-ports-gnome-5c7b64454793bc4fa1c1e17c78be5b3529367a60.zip
math/qd, a new port:
A Double-Double and Quad-Double Arithmetic library. Double-double and quad-double numbers are unevaluated sum of two and four IEEE doubles capable of representing 106 and 212 bits of significand, respectively. The library is written in C++, taking full advantage of operator overloading. C, Fortran 77, and Fortran 90 interfaces are also provided. This work was done at Lawrence Berkeley National Laboratory, NERSC Division, Yozo Hida with Xiaoye S. Li and David H. Bailey. WWW: http://www.cs.berkeley.edu/~yozo/
Diffstat (limited to 'math')
-rw-r--r--math/Makefile1
-rw-r--r--math/qd/Makefile27
-rw-r--r--math/qd/distinfo3
-rw-r--r--math/qd/pkg-descr11
-rw-r--r--math/qd/pkg-plist20
5 files changed, 62 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 6d5dbbe7fe8f..93723dff8255 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -303,6 +303,7 @@
SUBDIR += py-probstat
SUBDIR += py-scientific
SUBDIR += qalculate
+ SUBDIR += qd
SUBDIR += qgfe
SUBDIR += qhull
SUBDIR += qscanplot
diff --git a/math/qd/Makefile b/math/qd/Makefile
new file mode 100644
index 000000000000..bd351fd53ecd
--- /dev/null
+++ b/math/qd/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: qd
+# Date created: 2007/03/28
+# Whom: Nakata Maho <maho@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= qd
+PORTVERSION= 2.2.4
+CATEGORIES= math
+MASTER_SITES= http://www.cs.berkeley.edu/~yozo/software/
+
+MAINTAINER= maho@FreeBSD.org
+COMMENT= Double-Double and Quad-Double Arithmetic
+
+GNU_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+
+WANT_FORTRAN= yes #dummy but future use
+BUILD_DEPENDS+= gfortran42:${PORTSDIR}/lang/gcc42
+FC= gfortran42
+F77= gfortran42
+CONFIGURE_ENV+= FC="${FC}" FFLAGS="${FFLAGS}"
+CONFIGURE_ARGS+= --enable-shared=yes
+
+.include <bsd.port.post.mk>
diff --git a/math/qd/distinfo b/math/qd/distinfo
new file mode 100644
index 000000000000..32ceac5e2cfc
--- /dev/null
+++ b/math/qd/distinfo
@@ -0,0 +1,3 @@
+MD5 (qd-2.2.4.tar.gz) = 05abdc3b81ca45150207541216b793d9
+SHA256 (qd-2.2.4.tar.gz) = d4c29ed9d1e28ef1c275522b106f0e431355415d8694ae49faf3e221e4765ac8
+SIZE (qd-2.2.4.tar.gz) = 553302
diff --git a/math/qd/pkg-descr b/math/qd/pkg-descr
new file mode 100644
index 000000000000..9d0a2b826192
--- /dev/null
+++ b/math/qd/pkg-descr
@@ -0,0 +1,11 @@
+A Double-Double and Quad-Double Arithmetic library.
+Double-double and quad-double numbers are unevaluated sum of
+two and four IEEE doubles capable of representing 106 and 212 bits
+of significand, respectively. The library is written in C++, taking full
+advantage of operator overloading. C, Fortran 77, and Fortran 90 interfaces
+are also provided.
+
+This work was done at Lawrence Berkeley National Laboratory,
+NERSC Division, Yozo Hida with Xiaoye S. Li and David H. Bailey.
+
+WWW: http://www.cs.berkeley.edu/~yozo/
diff --git a/math/qd/pkg-plist b/math/qd/pkg-plist
new file mode 100644
index 000000000000..e3146ed3be65
--- /dev/null
+++ b/math/qd/pkg-plist
@@ -0,0 +1,20 @@
+bin/qd-config
+include/qd/c_dd.h
+include/qd/c_qd.h
+include/qd/dd_real.h
+include/qd/dd_inline.h
+include/qd/fpu.h
+include/qd/inline.h
+include/qd/qd_real.h
+include/qd/qd_inline.h
+include/qd/bits.h
+include/qd/qd_config.h
+lib/libqd.a
+lib/libqdmod.a
+lib/qd/qdmodule.mod
+lib/qd/ddmodule.mod
+share/doc/qd/README
+share/doc/qd/qd.pdf
+@dirrm include/qd
+@dirrm lib/qd
+@dirrm share/doc/qd