aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2016-10-24 22:16:31 +0800
committermat <mat@FreeBSD.org>2016-10-24 22:16:31 +0800
commit61fa104fea008c70b3c9c6a400ececed2eb131ba (patch)
treec5b6ff39b0e37978c360f8e7226f624420ee4d38 /math
parent9f9b3f1131e4c91d837254635959c2794ee145f3 (diff)
downloadfreebsd-ports-gnome-61fa104fea008c70b3c9c6a400ececed2eb131ba.tar.gz
freebsd-ports-gnome-61fa104fea008c70b3c9c6a400ececed2eb131ba.tar.zst
freebsd-ports-gnome-61fa104fea008c70b3c9c6a400ececed2eb131ba.zip
Convert one port as an example.
Sponsored by: Absolight
Diffstat (limited to 'math')
-rw-r--r--math/mosesdecoder/Makefile8
1 files changed, 1 insertions, 7 deletions
diff --git a/math/mosesdecoder/Makefile b/math/mosesdecoder/Makefile
index aa6c1df720cc..2f2eb69389fe 100644
--- a/math/mosesdecoder/Makefile
+++ b/math/mosesdecoder/Makefile
@@ -23,16 +23,10 @@ USE_GITHUB= yes
GH_ACCOUNT= moses-smt
USES= compiler:c++11-lang shebangfix
-SHEBANG_FILES= scripts/analysis/weight-scan-summarize.sh \
- scripts/training/wrappers/adam-suffix-array/suffix-array-extract.sh \
- scripts/training/wrappers/adam-suffix-array/suffix-array-create.sh
+SHEBANG_REGEX= ./scripts/.*\.(sh|pl|perl|cgi)
MAKE_ENV+= BOOST_BUILD_PATH=${WRKSRC}/jam-files/boost-build
-post-patch:
- @${FIND} ${WRKSRC}/scripts \( -name "*.pl" -o -name "*.perl" -o -name "*.cgi" \) -exec \
- ${REINPLACE_CMD} -i '' -e '1s|/usr/bin/perl|${perl_CMD}|' {} \;
-
do-build:
cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} bjam --with-boost=${LOCALBASE} --with-irstlm=${LOCALBASE} --with-randlm=${LOCALBASE} --without-tcmalloc --notrace --toolset=${CHOSEN_COMPILER_TYPE} debug-symbols=off ${_MAKE_JOBS}