aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authormaho <maho@FreeBSD.org>2014-03-06 10:58:44 +0800
committermaho <maho@FreeBSD.org>2014-03-06 10:58:44 +0800
commit781581af6baf07e62426aec4e5839499d8426407 (patch)
tree96ab87fc5109234cb1d00b8e7fec8e2e17c90f4a /math
parent4aef66ecc8ea2d38c165604f50c8a94b6f209cdf (diff)
downloadfreebsd-ports-gnome-781581af6baf07e62426aec4e5839499d8426407.tar.gz
freebsd-ports-gnome-781581af6baf07e62426aec4e5839499d8426407.tar.zst
freebsd-ports-gnome-781581af6baf07e62426aec4e5839499d8426407.zip
fix build on FreeBSD/i386 8.x
PR: 187090 Submitted by: tijl@
Diffstat (limited to 'math')
-rw-r--r--math/blacs/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/math/blacs/Makefile b/math/blacs/Makefile
index 0225330a7ae1..fc75881da11b 100644
--- a/math/blacs/Makefile
+++ b/math/blacs/Makefile
@@ -90,7 +90,7 @@ post-build:
${MV} ${WRKSRC_SHARED}/LIB/blacsCinit_MPI-FreeBSD-${DEBUG_LEVEL}.a ${WRKSRC_SHARED}/LIB/libblacs.a
${FIND} ${WRKSRC_SHARED} -name "*\.a" -exec ${MV} {} ${WRKDIR}/tmp_shared \;
cd ${WRKDIR}/tmp_shared ; for i in `ls *.a | ${SED} 's/\.a//' `; do \
- ld -Bshareable -o $${i}.so.${SVERSION} -x -soname $${i}.so.${SVERSION} --whole-archive $${i}.a ;\
+ ${LD} -Bshareable -o $${i}.so.${SVERSION} -x -soname $${i}.so.${SVERSION} --whole-archive $${i}.a ;\
${LN} -s $${i}.so.${SVERSION} $${i}.so ;\
done