aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorglewis <glewis@FreeBSD.org>2004-06-26 00:33:57 +0800
committerglewis <glewis@FreeBSD.org>2004-06-26 00:33:57 +0800
commit819a84ca041f7e4c450c9615ae59de865a0bfc1d (patch)
tree9dc91fad2e4c87b4ff5222e653a8c8cd6df0945e /math
parent4c556505deb0b39662eaa690eb997cccc115d85f (diff)
downloadfreebsd-ports-gnome-819a84ca041f7e4c450c9615ae59de865a0bfc1d.tar.gz
freebsd-ports-gnome-819a84ca041f7e4c450c9615ae59de865a0bfc1d.tar.zst
freebsd-ports-gnome-819a84ca041f7e4c450c9615ae59de865a0bfc1d.zip
. Chase print/pdflib updates. While this change fixes compilation and is
my best guess at what needs to happen so far, PDF file generation currently appears broken.
Diffstat (limited to 'math')
-rw-r--r--math/gnuplot/Makefile2
-rw-r--r--math/gnuplot/files/patch-term-pdf.trm13
2 files changed, 14 insertions, 1 deletions
diff --git a/math/gnuplot/Makefile b/math/gnuplot/Makefile
index 90f07010b0bc..b43439a0292c 100644
--- a/math/gnuplot/Makefile
+++ b/math/gnuplot/Makefile
@@ -58,7 +58,7 @@ CONFIGURE_ARGS+= --without-png
.endif
.if defined(WITH_PDF)
-LIB_DEPENDS+= pdf.6:${PORTSDIR}/print/pdflib
+LIB_DEPENDS+= pdf.7:${PORTSDIR}/print/pdflib
CONFIGURE_ARGS+= --with-pdf=${LOCALBASE}
.else
CONFIGURE_ARGS+= --without-pdf
diff --git a/math/gnuplot/files/patch-term-pdf.trm b/math/gnuplot/files/patch-term-pdf.trm
new file mode 100644
index 000000000000..fe2bd870c475
--- /dev/null
+++ b/math/gnuplot/files/patch-term-pdf.trm
@@ -0,0 +1,13 @@
+$FreeBSD$
+
+--- term/pdf.trm.orig Fri Jun 25 10:15:46 2004
++++ term/pdf.trm Fri Jun 25 10:16:01 2004
+@@ -343,7 +343,7 @@
+ myPDF = PDF_new();
+
+ /*open new PDF file */
+- if (PDF_open_fp(myPDF, gpoutfile) == -1)
++ if (PDF_open_file(myPDF, gpoutfile) == -1)
+ int_error(NO_CARET, "Error:cannot open PDF file .\n");
+
+ #ifdef PDF_DONT_COMPRESS