aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authoryuri <yuri@FreeBSD.org>2018-06-15 12:38:18 +0800
committeryuri <yuri@FreeBSD.org>2018-06-15 12:38:18 +0800
commita4eaad6982c43a157068fc2b8dc7a61b2522b9c8 (patch)
tree345cb3e4b6dd0c9ed5210bc5a05da46ce28b36df /math
parent3522d74eaf34f62a0f75f51caf01b11a56249aed (diff)
downloadfreebsd-ports-gnome-a4eaad6982c43a157068fc2b8dc7a61b2522b9c8.tar.gz
freebsd-ports-gnome-a4eaad6982c43a157068fc2b8dc7a61b2522b9c8.tar.zst
freebsd-ports-gnome-a4eaad6982c43a157068fc2b8dc7a61b2522b9c8.zip
New port: math/py-simhash: Python implementation of simhash algorithm
Diffstat (limited to 'math')
-rw-r--r--math/Makefile1
-rw-r--r--math/py-simhash/Makefile18
-rw-r--r--math/py-simhash/distinfo3
-rw-r--r--math/py-simhash/pkg-descr4
4 files changed, 26 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 2af688b8d491..b0047ca2cdab 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -715,6 +715,7 @@
SUBDIR += py-scikit-umfpack
SUBDIR += py-seaborn
SUBDIR += py-secp256k1
+ SUBDIR += py-simhash
SUBDIR += py-statsmodels
SUBDIR += py-svgmath
SUBDIR += py-sym
diff --git a/math/py-simhash/Makefile b/math/py-simhash/Makefile
new file mode 100644
index 000000000000..d611fac135cf
--- /dev/null
+++ b/math/py-simhash/Makefile
@@ -0,0 +1,18 @@
+# $FreeBSD$
+
+PORTNAME= simhash
+DISTVERSION= 1.9.0
+CATEGORIES= math python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Python implementation of simhash algorithm
+
+LICENSE= MIT
+
+USES= python
+USE_PYTHON= distutils autoplist
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/math/py-simhash/distinfo b/math/py-simhash/distinfo
new file mode 100644
index 000000000000..f9e4db6481e2
--- /dev/null
+++ b/math/py-simhash/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1529036382
+SHA256 (simhash-1.9.0.tar.gz) = 99fe945d675700ff1cb30ea616586010c8e46abef625b4959acd2636024f6af3
+SIZE (simhash-1.9.0.tar.gz) = 3024
diff --git a/math/py-simhash/pkg-descr b/math/py-simhash/pkg-descr
new file mode 100644
index 000000000000..812af9dd1f22
--- /dev/null
+++ b/math/py-simhash/pkg-descr
@@ -0,0 +1,4 @@
+A Python implementation of the SimHash algorithm, a technique for quickly
+estimating how similar two sets are.
+
+WWW: https://leons.im/posts/a-python-implementation-of-simhash-algorithm/