aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2003-10-16 04:58:28 +0800
committermarcus <marcus@FreeBSD.org>2003-10-16 04:58:28 +0800
commita5bd0faa47bc88fd9a1a7bc35f4636d732fb3c16 (patch)
treef4f9a2be02a020eeb0fc59eb6754dccdf5649fc1 /math
parent59d959de2734cd72bca53689332b3acf8956964d (diff)
downloadfreebsd-ports-gnome-a5bd0faa47bc88fd9a1a7bc35f4636d732fb3c16.tar.gz
freebsd-ports-gnome-a5bd0faa47bc88fd9a1a7bc35f4636d732fb3c16.tar.zst
freebsd-ports-gnome-a5bd0faa47bc88fd9a1a7bc35f4636d732fb3c16.zip
Fix Python detection for Python <= 2.2.
"When a user has PYTHON_VERSION= set in make.conf and no other python installed.Gnumeric2 configure can't find the python. This is because only the lang/python port installes python next to python2.3." PR: 58082 Submitted by: Koop Mast <einekoai@chello.nl>
Diffstat (limited to 'math')
-rw-r--r--math/gnumeric2/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/math/gnumeric2/Makefile b/math/gnumeric2/Makefile
index 3882d9e78557..afeb5d6f0b72 100644
--- a/math/gnumeric2/Makefile
+++ b/math/gnumeric2/Makefile
@@ -30,7 +30,8 @@ USE_LIBTOOL= yes
CONFIGURE_ARGS= --without-guile --with-bonobo --with-gnome-db
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
LIBS="-L${LOCALBASE}/lib -liconv ${PTHREAD_LIBS}" \
- DEFS="-I${X11BASE}/include/gal-2.0"
+ DEFS="-I${X11BASE}/include/gal-2.0" \
+ python_prog=${PYTHON_VERSION}
PLIST_SUB= VERSION=${PORTVERSION}-bonobo