aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2010-10-18 18:00:24 +0800
committermakc <makc@FreeBSD.org>2010-10-18 18:00:24 +0800
commita644a8a0fe2edc9bd4b45f76e35a8714314bd3ab (patch)
treed12eb769b2450c8a97adf6c4cfc04dffb38c6c39 /math
parent0cfcff2c3edb77ebc9045b1c1fefd2f583f22373 (diff)
downloadfreebsd-ports-gnome-a644a8a0fe2edc9bd4b45f76e35a8714314bd3ab.tar.gz
freebsd-ports-gnome-a644a8a0fe2edc9bd4b45f76e35a8714314bd3ab.tar.zst
freebsd-ports-gnome-a644a8a0fe2edc9bd4b45f76e35a8714314bd3ab.zip
Fix build when WITHOUT_GUI is chosen.
PR: ports/151518 Approved by: Rob Farmer (maintainer)
Diffstat (limited to 'math')
-rw-r--r--math/scilab/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/math/scilab/Makefile b/math/scilab/Makefile
index 89f718ed2b2e..ef8a2f426d8c 100644
--- a/math/scilab/Makefile
+++ b/math/scilab/Makefile
@@ -216,8 +216,10 @@ post-patch:
${REINPLACE_CMD} -e 's|$$jardir/fop.jar|${LOCALBASE}/share/java/fop/build/fop.jar|' ${WRKSRC}/configure
${REINPLACE_CMD} -e 's|$$jardir/jeuclid-core*.jar|${LOCALBASE}/share/java/jeuclid/repo/jeuclid-core*.jar|' ${WRKSRC}/configure
${MKDIR} ${WRKSRC}/thirdparty
+.if !defined(WITHOUT_GUI)
${CP} ${DISTDIR}/${JGRAPHX_JAR} ${WRKSRC}/thirdparty/jgraphx.jar
${REINPLACE_CMD} -e 's|@JGRAPHX@|${DATADIR}/modules/jgraphx.jar|g' ${WRKSRC}/etc/classpath.xml.in
+.endif
# Build fixes
${REINPLACE_CMD} -e 's|$$(CFLAGS:-O%=)|-I${LOCALBASE}/include -L${LOCALBASE}/lib|' ${WRKSRC}/modules/elementary_functions/Makefile.in
${REINPLACE_CMD} -e 's|freebsd|__FreeBSD__|g' ${WRKSRC}/modules/sparse/includes/spConfig.h
@@ -245,6 +247,8 @@ pre-install:
@${FIND} ${WRKSRC} -name \*.orig -delete
@${FIND} ${WRKSRC} -name \*.bak -delete
@${FIND} ${WRKSRC} -name .cvsignore -delete
+.if !defined(WITHOUT_GUI)
@${MKDIR} ${DATADIR}/modules && ${INSTALL_DATA} ${DISTDIR}/${JGRAPHX_JAR} ${DATADIR}/modules/jgraphx.jar
+.endif
.include <bsd.port.mk>