aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2007-02-11 19:49:16 +0800
committermiwi <miwi@FreeBSD.org>2007-02-11 19:49:16 +0800
commitae06c018f3ea4beb7ff5565d22d877aa3c6f58a1 (patch)
treed76b7e1630a8113674bcfb0df67dd40a8bec747d /math
parente8b72fa7dca0d23f2dc027977912102e6a15bd32 (diff)
downloadfreebsd-ports-gnome-ae06c018f3ea4beb7ff5565d22d877aa3c6f58a1.tar.gz
freebsd-ports-gnome-ae06c018f3ea4beb7ff5565d22d877aa3c6f58a1.tar.zst
freebsd-ports-gnome-ae06c018f3ea4beb7ff5565d22d877aa3c6f58a1.zip
- Update to 0.8.9
PR: 109030 Submitted by: Max Brazhnikov<makc@issp.ac.ru> (maintainer)
Diffstat (limited to 'math')
-rw-r--r--math/qtiplot/Makefile57
-rw-r--r--math/qtiplot/distinfo6
2 files changed, 28 insertions, 35 deletions
diff --git a/math/qtiplot/Makefile b/math/qtiplot/Makefile
index b06460445af0..94f924336255 100644
--- a/math/qtiplot/Makefile
+++ b/math/qtiplot/Makefile
@@ -6,16 +6,16 @@
#
PORTNAME= qtiplot
-PORTVERSION= 0.8.9.r2
+PORTVERSION= 0.8.9
CATEGORIES= math science
MASTER_SITES= http://soft.proindependent.com/src/
-DISTNAME= ${PORTNAME}-0.8.9-rc2
MAINTAINER= makc@issp.ac.ru
COMMENT= An Origin clone for data analysis and scientific plotting
BUILD_DEPENDS= qmake:${PORTSDIR}/devel/qmake
LIB_DEPENDS= gsl.9:${PORTSDIR}/math/gsl \
+ muparser.0:${PORTSDIR}/math/muparser \
origin.0:${PORTSDIR}/math/liborigin \
qwtplot3d:${PORTSDIR}/math/qwtplot3d \
qwt.5:${PORTSDIR}/x11-toolkits/qwt-devel
@@ -26,7 +26,7 @@ USE_QT_VER= 3
MAKE_ENV= QTDIR=${QT_PREFIX}
DESKTOP_ENTRIES="QtiPlot" "Data analysis and plotting" \
- "${DOCSDIR}/common/qtiplot_logo.png" \
+ "${DATADIR}/manual/common/qtiplot_logo.png" \
"qtiplot" "" false
OPTIONS= DOCS "Install the QtiPlot Handbook" on \
@@ -34,12 +34,8 @@ OPTIONS= DOCS "Install the QtiPlot Handbook" on \
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500000
-IGNORE= does not compile on FreeBSD 4.x
-.endif
-
.if defined(WITH_PYTHON)
-USE_PYTHON= 2.4
+USE_PYTHON= yes
# manually include this, because USE_PYTHON is defined
# after including bsd.port.pre.mk
.include "${PORTSDIR}/Mk/bsd.python.mk"
@@ -47,6 +43,8 @@ BUILD_DEPENDS+= sip:${PORTSDIR}/devel/py-sip \
${PYTHON_SITELIBDIR}/qt.so:${PORTSDIR}/x11-toolkits/py-qt
RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/qt.so:${PORTSDIR}/x11-toolkits/py-qt
PLIST_SUB+= PYTHON=""
+MAKE_ENV+= PYTHON_INCLUDEDIR=${PYTHON_INCLUDEDIR} \
+ PYTHON_VERSION=${PYTHON_VERSION}
.else
PLIST_SUB+= PYTHON="@comment "
.endif
@@ -70,34 +68,29 @@ QPRO_DIRS= . \
fitPlugins/fitRational1 \
qtiplot
+pre-patch:
+ @${RM} -r ${WRKSRC}/3rdparty/muParser
+ @${RM} -r ${WRKSRC}/3rdparty/qwt
+ @${CP} ${FILESDIR}/${PORTNAME}.pro ${WRKSRC}/${PORTNAME}/${PORTNAME}.pro
+
post-patch:
.if defined(WITH_PYTHON)
- @${REINPLACE_CMD} \
- -e "s:/usr/include/python2.4:${PYTHON_INCLUDEDIR}:" \
- -e "s:/usr/share/sip:${LOCALBASE}/share/py-sip/:" \
- ${WRKSRC}/qtiplot/qtiplot.pro
@${REINPLACE_CMD} -e \
's|loadInitFile("qtiplotrc")|loadInitFile("${DATADIR}/qtiplotrc")|' \
- ${WRKSRC}/qtiplot/src/PythonScripting.cpp
+ ${WRKSRC}/${PORTNAME}/src/PythonScripting.cpp
.else
@${REINPLACE_CMD} \
-e "s/unix:SCRIPTING_LANGS += Python//" \
- ${WRKSRC}/qtiplot/qtiplot.pro
+ ${WRKSRC}/${PORTNAME}/qtiplot.pro
.endif
-
-.for d in ${QPRO_DIRS}
- @${REINPLACE_CMD} \
- -e "s/#system/system/g" \
- -e "s:../3rdparty/liborigin:${LOCALBASE}/include:" \
- -e "s:../3rdparty/qwt/include:${LOCALBASE}/include/qwt:" \
- -e "s:/usr/include/qwtplot3d:${X11BASE}/include:" \
- -e "/^unix:LIBS/s:-L /usr/lib:-L${LOCALBASE}/lib:" \
- -e "/^unix:documentation.path/s:/usr/share/doc/qtiplot:${DATADIR}/manual:" \
- ${WRKSRC}/${d}/*.pro
-.endfor
- @${REINPLACE_CMD} -e "s:3rdparty/qwt::" ${WRKSRC}/qtiplot.pro
- @${REINPLACE_CMD} -e 's:"/usr/share/doc/qtiplot:"${DOCSDIR}:' \
- ${WRKSRC}/qtiplot/src/application.cpp
+ @${REINPLACE_CMD} -e "s:3rdparty/qwt::" ${WRKSRC}/${PORTNAME}.pro
+ @${REINPLACE_CMD} -e 's:"/usr/share/doc/qtiplot:"${DATADIR}/manual:' \
+ -e 's:QDir( "./" ).absPath():"":g' \
+ ${WRKSRC}/${PORTNAME}/src/application.cpp
+ @${REINPLACE_CMD} -e 's:"../3rdparty/muParser/muParser.h":<muParser.h>:' \
+ ${WRKSRC}/${PORTNAME}/src/parser.h
+ @${REINPLACE_CMD} -e 's:"../3rdparty/muParser/muParser.h":<muParser.h>:' \
+ ${WRKSRC}/${PORTNAME}/src/muParserScripting.h
do-configure:
.for d in ${QPRO_DIRS}
@@ -110,10 +103,10 @@ post-configure:
@${REINPLACE_CMD} -e \
's|^CC .*|CC=${CC}|; \
s|^CXX .*|CXX=${CXX}|; \
+ s|^LINK .*|LINK=${CXX}|; \
s|-pipe||; \
s|^\(CFLAGS .*= \)|\1${CFLAGS}|; \
- s|^\(CXXFLAGS = \)|\1${CXXFLAGS}|; \
- s|../3rdparty/qwt/lib/libqwt.a|-lqwt|' \
+ s|^\(CXXFLAGS = \)|\1${CXXFLAGS}|' \
${WRKSRC}/${d}/Makefile
.endfor
@@ -127,9 +120,9 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/fitPlugins/libfitRational1.so.1.0.0 \
${DATADIR}/fitPlugins/libfitRational1.so
.if defined(WITH_PYTHON)
- ${INSTALL_DATA} ${WRKSRC}/qtiplot/qtiplotrc.py ${DATADIR}/qtiplotrc.py
+ ${INSTALL_DATA} ${WRKSRC}/${PORTNAME}/qtiplotrc.py ${DATADIR}/qtiplotrc.py
@cd ${WRKSRC}/qtiplot && ${PYTHON_CMD} -c "import py_compile; py_compile.compile('qtiplotrc.py')"
- ${INSTALL_DATA} ${WRKSRC}/qtiplot/qtiplotrc.pyc ${DATADIR}/qtiplotrc.pyc
+ ${INSTALL_DATA} ${WRKSRC}/${PORTNAME}/qtiplotrc.pyc ${DATADIR}/qtiplotrc.pyc
.endif
.if !defined(WITHOUT_NLS)
.for i in ${QTI_LANG}
diff --git a/math/qtiplot/distinfo b/math/qtiplot/distinfo
index 2ae0d31bebf4..ece5aa506552 100644
--- a/math/qtiplot/distinfo
+++ b/math/qtiplot/distinfo
@@ -1,3 +1,3 @@
-MD5 (qtiplot-0.8.9-rc2.tar.bz2) = fdf3996b4361c83c7e86ae4d8176bc04
-SHA256 (qtiplot-0.8.9-rc2.tar.bz2) = efc9090413e4d446b8eed2182f9fe956406d24e92e82a51396a400eee8ba8765
-SIZE (qtiplot-0.8.9-rc2.tar.bz2) = 598479
+MD5 (qtiplot-0.8.9.tar.bz2) = d4477a3d7d5a61d6f6da1af48424220f
+SHA256 (qtiplot-0.8.9.tar.bz2) = c1472192cb04a56a7b75155d2520add2e6571bc8ede40341b8720291aafea870
+SIZE (qtiplot-0.8.9.tar.bz2) = 848083