aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authordanilo <danilo@FreeBSD.org>2013-10-17 07:10:15 +0800
committerdanilo <danilo@FreeBSD.org>2013-10-17 07:10:15 +0800
commitd71bd1c4ee0691c6bf9541e204eab0f8b21caeb3 (patch)
treea4b39558964c56ab65ba40ed13ad735ba1848bec /math
parent7e6fc482b8bf2c93c3c054d324b60eed61e6b260 (diff)
downloadfreebsd-ports-gnome-d71bd1c4ee0691c6bf9541e204eab0f8b21caeb3.tar.gz
freebsd-ports-gnome-d71bd1c4ee0691c6bf9541e204eab0f8b21caeb3.tar.zst
freebsd-ports-gnome-d71bd1c4ee0691c6bf9541e204eab0f8b21caeb3.zip
- Update from 1.7.0 to 1.7.1 [1]
- Add stage support - Force build with gcc - Convert LIB_DEPENDS to new syntax PR: ports/182886 Submitted by: Pedro Giffuni <giffunip@tutopia.com> [1] Approved by: wg/culot (mentors, implicit)
Diffstat (limited to 'math')
-rw-r--r--math/coinmp/Makefile23
-rw-r--r--math/coinmp/distinfo4
-rw-r--r--math/coinmp/pkg-plist3
3 files changed, 16 insertions, 14 deletions
diff --git a/math/coinmp/Makefile b/math/coinmp/Makefile
index 690221141840..1914dc7e6c29 100644
--- a/math/coinmp/Makefile
+++ b/math/coinmp/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= CoinMP
-PORTVERSION= 1.7.0
+PORTVERSION= 1.7.1
CATEGORIES= math
MASTER_SITES= http://www.coin-or.org/download/source/CoinMP/
EXTRACT_SUFX= .tgz
@@ -17,21 +17,23 @@ LICENSE_PERMS= auto-accept
CONFLICTS= clp-[0-9]*
+USES= pkgconfig
USE_AUTOTOOLS= libtool
USE_LDCONFIG= yes
+USE_GCC= any
+CONFIGURE_ARGS+= PKG_CONFIG_PATH=${STAGEDIR}${PREFIX}/libdata/pkgconfig
OPTIONS_DEFINE= DEBUG DOCS
PORTDOCS= *
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MGLPK}
BROKEN = the GLPK option requires math/glpk headers that are not currently installed by that port
CONFIGURE_ARGS+= --with-gmpl-incdir=${LOCALBASE}/include \
--with-gmpl-lib="-L${LOCALBASE}/lib -lglpk"
-LIB_DEPENDS+= glpk:${PORTSDIR}/math/glpk
+LIB_DEPENDS+= libglpk.so:${PORTSDIR}/math/glpk
.else
CONFIGURE_ARGS+= --disable-glpk-libcheck
.endif
@@ -42,11 +44,14 @@ CXXFLAGS+= -fomit-frame-pointer
.endif
post-patch::
- @${REINPLACE_CMD} -E -e \
- 's:\$$\(libdir\)/pkgconfig:${PREFIX}/libdata/pkgconfig:' \
+ @${REINPLACE_CMD} -e \
+ 's|$$(libdir)/pkgconfig|${PREFIX}/libdata/pkgconfig|' \
${WRKSRC}/Clp/Makefile.in ${WRKSRC}/Osi/Makefile.in \
${WRKSRC}/Cbc/Makefile.in ${WRKSRC}/Cgl/Makefile.in \
- ${WRKSRC}/CoinUtils/Makefile.in ${WRKSRC}/CoinMP/Makefile.in
+ ${WRKSRC}/CoinUtils/Makefile.in ${WRKSRC}/CoinMP/Makefile.in \
+ ${WRKSRC}/Data/Sample/Makefile.in
+ @${REINPLACE_CMD} -e 's|$$(DESTDIR)$$(addlibsdir)|$$(addlibsdir)|g' \
+ ${WRKSRC}/CoinMP/Makefile.in
pre-build:
.for dir in Cbc Cgl Clp CoinMP CoinUtils Osi
@@ -54,10 +59,8 @@ pre-build:
.endfor
post-install:
-.if ${PORT_OPTIONS:MDOCS}
- ${MV} ${PREFIX}/share/coin/doc ${DOCSDIR}
-.endif
- ${RM} -rf ${PREFIX}/share/coin
+ ${MV} ${STAGEDIR}${PREFIX}/share/coin/doc ${STAGEDIR}${DOCSDIR}
+ ${RM} -rf ${STAGEDIR}${PREFIX}/share/coin
check regression-test test: build
@(cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${MAKE} ${_MAKE_JOBS} \
diff --git a/math/coinmp/distinfo b/math/coinmp/distinfo
index 8ed901e8aa97..614e5f24d3ae 100644
--- a/math/coinmp/distinfo
+++ b/math/coinmp/distinfo
@@ -1,2 +1,2 @@
-SHA256 (CoinMP-1.7.0.tgz) = 48bb3e89ed9ebbad1ea71ece575419b3bff81ab2c6257d353cf4c948010d5adb
-SIZE (CoinMP-1.7.0.tgz) = 9647250
+SHA256 (CoinMP-1.7.1.tgz) = 47d09494384f1f40ae60b2a21d0c006042d00b1ebfcde7dc68a4f18c9b464ee8
+SIZE (CoinMP-1.7.1.tgz) = 9646573
diff --git a/math/coinmp/pkg-plist b/math/coinmp/pkg-plist
index 6039e3a2a516..6562b3576e84 100644
--- a/math/coinmp/pkg-plist
+++ b/math/coinmp/pkg-plist
@@ -245,7 +245,7 @@ lib/libOsiClp.so.12
lib/libOsiCommonTests.la
lib/libOsiCommonTests.so
lib/libOsiCommonTests.so.11
-lib/pkgconfig/coindatasample.pc
+libdata/pkgconfig/coindatasample.pc
libdata/pkgconfig/clp.pc
libdata/pkgconfig/osi-clp.pc
libdata/pkgconfig/cbc.pc
@@ -256,4 +256,3 @@ libdata/pkgconfig/coinmp.pc
libdata/pkgconfig/osi-cbc.pc
libdata/pkgconfig/osi-unittests.pc
@dirrm include/coin
-@dirrmtry lib/pkgconfig