aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2018-05-16 04:43:10 +0800
committerjbeich <jbeich@FreeBSD.org>2018-05-16 04:43:10 +0800
commitddd443c3a0b63a710741369dc52fc3804df53452 (patch)
tree633beb88b256cf26869553a57dd9fe4c766a1d06 /math
parent8445c1021e4d01d305ddde3e617db6a41c560312 (diff)
downloadfreebsd-ports-gnome-ddd443c3a0b63a710741369dc52fc3804df53452.tar.gz
freebsd-ports-gnome-ddd443c3a0b63a710741369dc52fc3804df53452.tar.zst
freebsd-ports-gnome-ddd443c3a0b63a710741369dc52fc3804df53452.zip
math/ceres-solver: unbreak ATLAS=on after r465553
When math/suitesparse has OPENBLAS=on: -- Found BLAS: /usr/local/lib/libopenblas.so -- Found LAPACK library: alapack [...] 0x0000000000000001 NEEDED Shared library: [libalapack.so.2] 0x0000000000000001 NEEDED Shared library: [libopenblas.so.0] When math/suitesparse has ATLAS=on: -- Found BLAS: /usr/local/lib/libf77blas.so;/usr/local/lib/libatlas.so -- Found LAPACK library: alapack [...] //usr/local/lib/libalapack.so.2: undefined reference to `cblas_izamax' //usr/local/lib/libalapack.so.2: undefined reference to `cblas_sswap' c++: error: linker command failed with exit code 1 (use -v to see invocation) Pointy hat to: jbeich
Diffstat (limited to 'math')
-rw-r--r--math/ceres-solver/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/math/ceres-solver/Makefile b/math/ceres-solver/Makefile
index 08776596ece9..34b3d6517ff5 100644
--- a/math/ceres-solver/Makefile
+++ b/math/ceres-solver/Makefile
@@ -2,7 +2,7 @@
PORTNAME= ceres-solver
DISTVERSION= 1.14.0
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= math
MAINTAINER= jbeich@FreeBSD.org
@@ -76,7 +76,8 @@ LAPACK_CMAKE_ON= -DCMAKE_POLICY_DEFAULT_CMP0056:STRING=NEW # USES=fortran
# https://github.com/xianyi/OpenBLAS/wiki/faq#multi-threaded
ATLAS_USES= blaslapack:atlas
ATLAS_CMAKE_ON= -DBLA_VENDOR:STRING="ATLAS" \
- -DLAPACK_LIBRARIES:STRING=alapack
+ -DBLAS_LIBRARIES:FILEPATH="${LOCALBASE}/lib/libcblas.so" \
+ -DLAPACK_LIBRARIES:FILEPATH="${LOCALBASE}/lib/libalapack.so"
ATLAS_IMPLIES= LAPACK
GOTOBLAS_DESC= Goto blas implementation
GOTOBLAS_USES= blaslapack:gotoblas