aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorgahr <gahr@FreeBSD.org>2018-03-14 00:19:22 +0800
committergahr <gahr@FreeBSD.org>2018-03-14 00:19:22 +0800
commitf462b353038dfd02cb4841342ff9ae120c6ed318 (patch)
tree5e02bff893f436446510e3fcd66391f36fddfd63 /math
parent855c0d8baf5c999ae76337724180fbef99db3d24 (diff)
downloadfreebsd-ports-gnome-f462b353038dfd02cb4841342ff9ae120c6ed318.tar.gz
freebsd-ports-gnome-f462b353038dfd02cb4841342ff9ae120c6ed318.tar.zst
freebsd-ports-gnome-f462b353038dfd02cb4841342ff9ae120c6ed318.zip
math/abacus: unbreak, undeprecate, bump
PR: 199772
Diffstat (limited to 'math')
-rw-r--r--math/abacus/Makefile6
-rw-r--r--math/abacus/files/patch-Makefile12
2 files changed, 9 insertions, 9 deletions
diff --git a/math/abacus/Makefile b/math/abacus/Makefile
index 2c95c253e2da..f07755861633 100644
--- a/math/abacus/Makefile
+++ b/math/abacus/Makefile
@@ -3,7 +3,7 @@
PORTNAME= abacus
DISTVERSION= 3.2betaU1
-PORTREVISION= 8
+PORTREVISION= 9
CATEGORIES= math
MASTER_SITES= http://www.informatik.uni-koeln.de/abacus/
@@ -12,9 +12,6 @@ COMMENT= Branch-And-CUt System
LICENSE= LGPL21+
-DEPRECATED= Unmaintained and has a broken shared library
-EXPIRATION_DATE= 2018-03-31
-
LIB_DEPENDS= libClp.so:math/coinmp
NO_WRKSUBDIR= yes
@@ -23,6 +20,7 @@ USES= gmake perl5
USE_PERL5= build
USE_LDCONFIG= yes
ALL_TARGET= abacus
+CXXFLAGS+= -fPIC
MAKE_ARGS= CCC="${CXX}" PERL="${PERL}" STRIP="${STRIP_CMD} -x" \
ARCHIVE="${AR} ${ARFLAGS}" CCFLAG_DEBOPT="${CXXFLAGS}" \
OSI_INCLUDE="${LOCALBASE}/include/coin"
diff --git a/math/abacus/files/patch-Makefile b/math/abacus/files/patch-Makefile
index 0354c57b9018..de0ea40901e7 100644
--- a/math/abacus/files/patch-Makefile
+++ b/math/abacus/files/patch-Makefile
@@ -1,5 +1,5 @@
---- Makefile.orig 2012-01-06 14:29:04.000000000 +0100
-+++ Makefile 2013-09-05 14:35:52.000000000 +0200
+--- Makefile.orig 2012-01-06 13:29:04 UTC
++++ Makefile
@@ -177,6 +177,11 @@ $(OBJDIR)/%.o: $(SRCDIR)/%.cc
$(CCC) $(CCFLAGS) $(ADDFLAGS) -c $< -o $@
$(STRIP) $@
@@ -12,7 +12,7 @@
#######################################################################
#
-@@ -523,15 +524,20 @@
+@@ -523,15 +528,22 @@ $(LIBDIR)/stuff/interface-osi.a: $(OSI_O
$(ARCHIVE) $@ $(OSI_O)
# The basic ABACUS library
@@ -27,7 +27,9 @@
+$(LIBDIR)/stuff/abacus-base.so.1: $(ABACUS_O:%.o=%.So)
+ rm -f $@
-+ $(CCC) $(LDFLAGS) -shared -o $@ $(ABACUS_O:%.o=%.So)
++ $(CCC) $(LDFLAGS) -shared -o $@ $(ABACUS_O:%.o=%.So) \
++ `find $(LIBDIR)/temp -name \*.o | xargs -n1` \
++ `find $(LIBDIR)/stuff -name \*.o | xargs -n1` \
+
# Build the library distribution directory (lib and lib/stuff)
-lib-all: subdirs abacus-base lpif interface $(ADDITIONAL_LIB_ALL)
@@ -35,7 +37,7 @@
# Create a tar file containing all necessary stuff to compile ABACUS on
# a remote system.
-@@ -571,6 +577,7 @@
+@@ -571,6 +583,7 @@ have_lib = $(wildcard $(LIBDIR)/libabacu
abacus: lib-all
cp $(LIBDIR)/stuff/abacus-base.a $(LIBDIR)/libabacus-osi.a