aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2009-01-06 05:05:49 +0800
committerpav <pav@FreeBSD.org>2009-01-06 05:05:49 +0800
commitfb4c1b2e93bf0f4106c6b1895f7dd96af9db0bcb (patch)
tree1f6b633bd7844aa504f407e530e6892e38d0b9c5 /math
parent54aa386a510858774daf943c9ab8069883f977c7 (diff)
downloadfreebsd-ports-gnome-fb4c1b2e93bf0f4106c6b1895f7dd96af9db0bcb.tar.gz
freebsd-ports-gnome-fb4c1b2e93bf0f4106c6b1895f7dd96af9db0bcb.tar.zst
freebsd-ports-gnome-fb4c1b2e93bf0f4106c6b1895f7dd96af9db0bcb.zip
- Remove conditional checks for FreeBSD 5.x and older
Diffstat (limited to 'math')
-rw-r--r--math/algae/Makefile4
-rw-r--r--math/cxsc/Makefile7
-rw-r--r--math/digitizer/Makefile8
-rw-r--r--math/gretl/Makefile8
-rw-r--r--math/ndiff/Makefile2
-rw-r--r--math/octave-devel/Makefile5
-rw-r--r--math/octave/Makefile5
-rw-r--r--math/ump/Makefile8
8 files changed, 6 insertions, 41 deletions
diff --git a/math/algae/Makefile b/math/algae/Makefile
index 39a785aaa61a..2008b4a81965 100644
--- a/math/algae/Makefile
+++ b/math/algae/Makefile
@@ -42,8 +42,8 @@ pre-configure:
.include <bsd.port.pre.mk>
-.if ( ${ARCH} == "alpha" && ${OSVERSION} > 502102 ) || ${ARCH} == "sparc64"
-BROKEN= Configure fails on alpha 5.x and sparc64
+.if ${ARCH} == "alpha" || ${ARCH} == "sparc64"
+BROKEN= Configure fails on alpha and sparc64
.endif
.include <bsd.port.post.mk>
diff --git a/math/cxsc/Makefile b/math/cxsc/Makefile
index d29db569f11d..c684456a4375 100644
--- a/math/cxsc/Makefile
+++ b/math/cxsc/Makefile
@@ -18,11 +18,6 @@ COMMENT= C++ class library for eXtended Scientific Computing
WRKSRC= ${WRKDIR}/${PORTNAME}
USE_GMAKE= yes
-
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 502126
USE_GCC= 3.3
-.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/math/digitizer/Makefile b/math/digitizer/Makefile
index c1094b60fd8f..9b0bb326b47f 100644
--- a/math/digitizer/Makefile
+++ b/math/digitizer/Makefile
@@ -37,12 +37,6 @@ DESKTOP_ENTRIES= "Engauge Digitizer" \
DOCS= README
.endif
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500035
-BROKEN= Does not compile with gcc-2.95
-.endif
-
pre-configure:
.if !defined(WITH_DEBUG)
${REINPLACE_CMD} -e '/^CONFIG/s/debug/release/' ${WRKSRC}/digitizer.pro
@@ -70,4 +64,4 @@ do-install:
@${ECHO_MSG} "===> Examples installed in ${EXAMPLESDIR}."
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/math/gretl/Makefile b/math/gretl/Makefile
index fd863f2ff857..600864e54641 100644
--- a/math/gretl/Makefile
+++ b/math/gretl/Makefile
@@ -66,14 +66,8 @@ BLAS= -lblas
LAPACK= -llapack
.endif
-.if ${OSVERSION} > 502010
-GNU_REGEX_H= gnu/regex.h
-.else
-GNU_REGEX_H= gnuregex.h
-.endif
-
post-patch:
- @${REINPLACE_CMD} -e 's|<regex.h>|<${GNU_REGEX_H}>|g' \
+ @${REINPLACE_CMD} -e 's|<regex.h>|<gnu/regex.h>|g' \
${WRKSRC}/gui2/gtksourceview/gtksourceregex.c
pre-configure:
diff --git a/math/ndiff/Makefile b/math/ndiff/Makefile
index 0194d62e7dff..d3827dd719d8 100644
--- a/math/ndiff/Makefile
+++ b/math/ndiff/Makefile
@@ -18,11 +18,9 @@ COMMENT= Compare putatively similar files, ignoring small numeric differences
.include <bsd.port.pre.mk>
.if !defined(WITHOUT_GMP)
-.if ${OSVERSION} > 500023
LIB_DEPENDS= gmp.7:${PORTSDIR}/math/libgmp4
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-.endif
CONFIGURE_ARGS= --with-gmp
CONFIGURE_ENV= CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
.else
diff --git a/math/octave-devel/Makefile b/math/octave-devel/Makefile
index 98ad731c9ad9..bb334dfa5264 100644
--- a/math/octave-devel/Makefile
+++ b/math/octave-devel/Makefile
@@ -42,11 +42,6 @@ MAN1= octave.1 octave-bug.1 mkoctfile.1 octave-config.1
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 600000
-BUILD_DEPENDS+= info:${PORTSDIR}/print/texinfo
-BROKEN= Fails to install
-.endif
-
USE_BLAS?= reference
.if exists(${LOCALBASE}/lib/libgoto.so)
diff --git a/math/octave/Makefile b/math/octave/Makefile
index ff875975c3db..f5edb7725ff8 100644
--- a/math/octave/Makefile
+++ b/math/octave/Makefile
@@ -39,11 +39,6 @@ MAN1= octave.1 octave-bug.1 mkoctfile.1 octave-config.1
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 600000
-BUILD_DEPENDS+= info:${PORTSDIR}/print/texinfo
-BROKEN= Fails to install
-.endif
-
USE_BLAS?= reference
.if exists(${LOCALBASE}/lib/libgoto.so)
diff --git a/math/ump/Makefile b/math/ump/Makefile
index b15457a2a586..dfba576c3852 100644
--- a/math/ump/Makefile
+++ b/math/ump/Makefile
@@ -30,12 +30,6 @@ MAKE_ENV+= DATADIR="${DATADIR}"
FIND_DIRS= -type d
FIND_DATA= -type f
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 503000
-IGNORE= requires trunc(3) and round(3)
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|' ${WRKSRC}/src/main.cpp
@@ -45,4 +39,4 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/ump.conf ${PREFIX}/etc
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>