aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2015-09-14 20:19:48 +0800
committermat <mat@FreeBSD.org>2015-09-14 20:19:48 +0800
commitfce96910d8fa5a4eed7867a15f95ee514b0fdc2e (patch)
treeb5c267ca5490c7e06b5fe235a5d442d93eac880d /math
parent292a8fe8b9a022107dd57df327cd4f998fff539a (diff)
downloadfreebsd-ports-gnome-fce96910d8fa5a4eed7867a15f95ee514b0fdc2e.tar.gz
freebsd-ports-gnome-fce96910d8fa5a4eed7867a15f95ee514b0fdc2e.tar.zst
freebsd-ports-gnome-fce96910d8fa5a4eed7867a15f95ee514b0fdc2e.zip
Make it so that the default Perl is always called perl5.
- Move Perl's man1 files along with its man3 files. - Move where Perl installs its modules man1 pages. - Convert the ports installing man1 pages. - Make different Perl versions installable at the same time. Though you should note that only the default version can be used to install Perl modules, and the non default Perl versions cannot use the modules installed via ports if they contain .so as they are installed in a version specific directory. Reviewed by: bapt (the Mk bits) Exp-run by: antoine Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D3542
Diffstat (limited to 'math')
-rw-r--r--math/PDL/Makefile9
-rw-r--r--math/p5-Math-Cephes/pkg-plist2
-rw-r--r--math/p5-Math-Evol/pkg-plist2
-rw-r--r--math/p5-Math-GSL/pkg-plist2
-rw-r--r--math/p5-NetCDF/Makefile6
-rw-r--r--math/p5-NetCDF/pkg-plist2
6 files changed, 12 insertions, 11 deletions
diff --git a/math/PDL/Makefile b/math/PDL/Makefile
index cd067b7adba5..22457ef48033 100644
--- a/math/PDL/Makefile
+++ b/math/PDL/Makefile
@@ -82,14 +82,15 @@ post-patch:
post-install:
@(cd ${WRKSRC}; ${PERL} -Iblib/lib -Iblib/arch Doc/scantree.pl)
@(cd ${WRKSRC}/blib/man3 ; \
- ${FIND} *.3 | ${SED} "s,^,${MAN3PREFIX:S,^${PREFIX}/,,}/man/man3/,;s/3$$/3.gz/" \
+ ${FIND} *.3 | ${SED} "s,^,${MAN3PREFIX}/man/man3/,;s/3$$/3.gz/" \
>> ${TMPPLIST} ; \
cd ${WRKSRC}/blib/man1 ; \
- ${FIND} *.1 | ${SED} "s,^,man/man1/,;s/1$$/1.gz/" >> ${TMPPLIST})
+ ${FIND} *.1 | ${SED} "s,^,${MAN1PREFIX}/man/man1/,;s/1$$/1.gz/" \
+ >> ${TMPPLIST})
@(${FIND} ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/PDL* -type f | \
${SED} "s,^${STAGEDIR}${PREFIX}/,," >> ${TMPPLIST} ; \
${FIND} ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/PDL -type f \
- -name "[A-Z]*" | ${SED} "s,^${STAGEDIR}${PREFIX}/,," \
- >> ${TMPPLIST})
+ -name "[A-Z]*" | ${SED} "s,^${STAGEDIR}${PREFIX}/,," \
+ >> ${TMPPLIST})
.include <bsd.port.mk>
diff --git a/math/p5-Math-Cephes/pkg-plist b/math/p5-Math-Cephes/pkg-plist
index dfcd58c540df..90bd67dffa93 100644
--- a/math/p5-Math-Cephes/pkg-plist
+++ b/math/p5-Math-Cephes/pkg-plist
@@ -12,4 +12,4 @@ bin/pmath
%%PERL5_MAN3%%/Math::Cephes::Fraction.3.gz
%%PERL5_MAN3%%/Math::Cephes::Matrix.3.gz
%%PERL5_MAN3%%/Math::Cephes::Polynomial.3.gz
-man/man1/pmath.1.gz
+%%PERL5_MAN1%%/pmath.1.gz
diff --git a/math/p5-Math-Evol/pkg-plist b/math/p5-Math-Evol/pkg-plist
index 84befdf32c71..3a5d205ed11e 100644
--- a/math/p5-Math-Evol/pkg-plist
+++ b/math/p5-Math-Evol/pkg-plist
@@ -1,4 +1,4 @@
bin/ps_evol
%%PERL5_MAN3%%/Math::Evol.3.gz
%%SITE_PERL%%/Math/Evol.pm
-man/man1/ps_evol.1.gz
+%%PERL5_MAN1%%/ps_evol.1.gz
diff --git a/math/p5-Math-GSL/pkg-plist b/math/p5-Math-GSL/pkg-plist
index 998038fc6ab9..43d49e659b9b 100644
--- a/math/p5-Math-GSL/pkg-plist
+++ b/math/p5-Math-GSL/pkg-plist
@@ -157,4 +157,4 @@ bin/smolder_smoke_signal
%%PERL5_MAN3%%/Math::GSL::VectorComplex.3.gz
%%PERL5_MAN3%%/Math::GSL::Wavelet.3.gz
%%PERL5_MAN3%%/Math::GSL::Wavelet2D.3.gz
-man/man1/smolder_smoke_signal.1.gz
+%%PERL5_MAN1%%/smolder_smoke_signal.1.gz
diff --git a/math/p5-NetCDF/Makefile b/math/p5-NetCDF/Makefile
index 2b2a55ee29d6..c9d8f7d2459d 100644
--- a/math/p5-NetCDF/Makefile
+++ b/math/p5-NetCDF/Makefile
@@ -14,12 +14,12 @@ COMMENT= Perl5 module to read and write netCDF files
LIB_DEPENDS= libnetcdf.so:${PORTSDIR}/science/netcdf
-USES= perl5
+USES= perl5 fakeroot
-WRKSRC= ${WRKDIR}/${DISTNAME}/src
+WRKSRC_SUBDIR= src
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPP_NETCDF=-I${LOCALBASE}/include LD_NETCDF=-lnetcdf \
- PERL_MANDIR=${STAGEDIR}${MAN1PREFIX}/man PERL=${PERL5}
+ PERL_MANDIR=${STAGEDIR}${SITE_PERL}/man PERL=${PERL5}
pre-install:
@${PERL5} -pi -e 's/ doc_(perl|site|\$$\(INSTALLDIRS\))_install$$//' ${WRKSRC}/perl/Makefile
diff --git a/math/p5-NetCDF/pkg-plist b/math/p5-NetCDF/pkg-plist
index 12eaff22b654..c95f7723f977 100644
--- a/math/p5-NetCDF/pkg-plist
+++ b/math/p5-NetCDF/pkg-plist
@@ -1,4 +1,4 @@
-man/man1/netCDFPerl.1.gz
+%%PERL5_MAN1%%/netCDFPerl.1.gz
%%SITE_ARCH%%/NetCDF.pm
%%SITE_ARCH%%/auto/NetCDF/NetCDF.so
%%SITE_ARCH%%/auto/NetCDF/autosplit.ix