aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authortobez <tobez@FreeBSD.org>2007-02-16 04:44:56 +0800
committertobez <tobez@FreeBSD.org>2007-02-16 04:44:56 +0800
commit13618cf974655c43a3abbff1c2731c40eeccc70d (patch)
tree54a9932934b113e5b41ec353fcb86aa9d38a6b6e /math
parent4ed6530b77ab74594e320434c6df8b33cac03852 (diff)
downloadfreebsd-ports-gnome-13618cf974655c43a3abbff1c2731c40eeccc70d.tar.gz
freebsd-ports-gnome-13618cf974655c43a3abbff1c2731c40eeccc70d.tar.zst
freebsd-ports-gnome-13618cf974655c43a3abbff1c2731c40eeccc70d.zip
Add math/p5-Set-IntSpan-Fast 0.0.5, a Perl module for fast handling of
sets containing integer spans.
Diffstat (limited to 'math')
-rw-r--r--math/Makefile1
-rw-r--r--math/p5-Set-IntSpan-Fast/Makefile34
-rw-r--r--math/p5-Set-IntSpan-Fast/distinfo3
-rw-r--r--math/p5-Set-IntSpan-Fast/pkg-descr9
-rw-r--r--math/p5-Set-IntSpan-Fast/pkg-plist7
5 files changed, 54 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 85d4c931ea46..ed2006fd920d 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -250,6 +250,7 @@
SUBDIR += p5-Number-WithError-LaTeX
SUBDIR += p5-Roman
SUBDIR += p5-Set-IntSpan
+ SUBDIR += p5-Set-IntSpan-Fast
SUBDIR += p5-Set-Partition
SUBDIR += p5-Set-Window
SUBDIR += p5-Statistics-ChiSquare
diff --git a/math/p5-Set-IntSpan-Fast/Makefile b/math/p5-Set-IntSpan-Fast/Makefile
new file mode 100644
index 000000000000..dc051c80dbab
--- /dev/null
+++ b/math/p5-Set-IntSpan-Fast/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: math/p5-Set-IntSpan-Fast
+# Date created: 15 February 2007
+# Whom: Anton Berezin <tobez@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Set-IntSpan-Fast
+PORTVERSION= 0.0.5
+DISTVERSIONPREFIX= v
+CATEGORIES= math perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Set
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tobez@FreeBSD.org
+COMMENT= Fast handling of sets containing integer spans
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/version.pm:${PORTSDIR}/devel/p5-version \
+ ${SITE_PERL}/Data/Types.pm:${PORTSDIR}/devel/p5-Data-Types \
+ ${SITE_PERL}/Class/Std.pm:${PORTSDIR}/devel/p5-Class-Std
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Set::IntSpan::Fast.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+IGNORE= requires perl 5.8.0 or later. Install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/math/p5-Set-IntSpan-Fast/distinfo b/math/p5-Set-IntSpan-Fast/distinfo
new file mode 100644
index 000000000000..7cc37002b1dc
--- /dev/null
+++ b/math/p5-Set-IntSpan-Fast/distinfo
@@ -0,0 +1,3 @@
+MD5 (Set-IntSpan-Fast-v0.0.5.tar.gz) = eb87513d96d60962c290f5b394cb8aba
+SHA256 (Set-IntSpan-Fast-v0.0.5.tar.gz) = 606678c05ff6d79d5906b81e6abd8b40fa8043aa5d2845ab6e547fc6bac27e77
+SIZE (Set-IntSpan-Fast-v0.0.5.tar.gz) = 9924
diff --git a/math/p5-Set-IntSpan-Fast/pkg-descr b/math/p5-Set-IntSpan-Fast/pkg-descr
new file mode 100644
index 000000000000..7828f2762da2
--- /dev/null
+++ b/math/p5-Set-IntSpan-Fast/pkg-descr
@@ -0,0 +1,9 @@
+The Set::IntSpan module represents sets of integers as a number of
+inclusive ranges, for example '1-10,19-23,45-48'. Because many of its
+operations involve linear searches of the list of ranges its overall
+performance tends to be proportional to the number of distinct ranges.
+This is fine for small sets but suffers compared to other possible set
+representations (bit vectors, hash keys) when the number of ranges grows
+large. Set::IntSpan::Fast tries to fix that.
+
+WWW: http://search.cpan.org/dist/Set-IntSpan-Fast/
diff --git a/math/p5-Set-IntSpan-Fast/pkg-plist b/math/p5-Set-IntSpan-Fast/pkg-plist
new file mode 100644
index 000000000000..ff8def1207f0
--- /dev/null
+++ b/math/p5-Set-IntSpan-Fast/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/Set/IntSpan/Fast.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Set/IntSpan/Fast/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Set/IntSpan/Fast
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Set/IntSpan
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Set
+@dirrmtry %%SITE_PERL%%/Set/IntSpan
+@dirrmtry %%SITE_PERL%%/Set