aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorbf <bf@FreeBSD.org>2012-06-07 11:05:48 +0800
committerbf <bf@FreeBSD.org>2012-06-07 11:05:48 +0800
commit1550108b4b315baa381ccfba192146ea0c5fe814 (patch)
treea9849020cc30d57cc697b5f07292a7f473eed215 /math
parent6acb2d668a19cd5b23e70176b6b7b9ea7859ae6d (diff)
downloadfreebsd-ports-gnome-1550108b4b315baa381ccfba192146ea0c5fe814.tar.gz
freebsd-ports-gnome-1550108b4b315baa381ccfba192146ea0c5fe814.tar.zst
freebsd-ports-gnome-1550108b4b315baa381ccfba192146ea0c5fe814.zip
update to 3.3.2 and convert options to the new style
Diffstat (limited to 'math')
-rw-r--r--math/fftw3/Makefile21
-rw-r--r--math/fftw3/distinfo4
2 files changed, 14 insertions, 11 deletions
diff --git a/math/fftw3/Makefile b/math/fftw3/Makefile
index 49fd67bd9a5c..66992e12fb74 100644
--- a/math/fftw3/Makefile
+++ b/math/fftw3/Makefile
@@ -6,7 +6,7 @@
# $MCom: ports-experimental/math/fftw3/Makefile,v 1.1 2006/03/28 00:08:57 ahze Exp $
PORTNAME= fftw3
-PORTVERSION= 3.3.1
+PORTVERSION= 3.3.2
PORTREVISION?= 0
CATEGORIES= math
MASTER_SITES= ftp://ftp.fftw.org/pub/fftw/ \
@@ -40,13 +40,16 @@ MAN1= fftw${FFTW3_SUFX}-wisdom.1
INSTALL_TARGET= install-pkgconfigDATA install-libLTLIBRARIES install-exec
.endif
-OPTIONS= G77_WRAPPERS "Alter Fortran wrappers for use with g77" off \
- OPENMP "Build OpenMP multithreaded libraries" off \
- OPTIMIZED_CFLAGS "Enable optimized CFLAGS" on
+OPTIONS_DEFINE = G77_WRAPPERS OPENMP OPTIMIZED_CFLAGS
+
+G77_WRAPPERS_DESC= Alter Fortran wrappers for use with g77
+OPENMP_DESC= Build OpenMP multithreaded libraries
+
+OPTIONS_DEFAULT= OPTIMIZED_CFLAGS
.include <bsd.port.pre.mk>
-.if defined(WITH_OPENMP)
+.if ${PORT_OPTIONS:MOPENMP}
CONFIGURE_ARGS+= --enable-openmp
PLIST_SUB+= OPENMP=""
.else
@@ -54,7 +57,7 @@ CONFIGURE_ARGS+= --disable-openmp
PLIST_SUB+= OPENMP="@comment "
.endif
-.if defined(WITH_OPTIMIZED_CFLAGS)
+.if ${PORT_OPTIONS:MOPTIMIZED_CFLAGS}
CFLAGS+= -O3 -ffast-math -fstrict-aliasing
. if !defined(WITH_DEBUG)
CFLAGS+= -fomit-frame-pointer
@@ -63,7 +66,7 @@ CFLAGS+= -fomit-frame-pointer
CFLAGS+= -malign-double
. endif
WITHOUT_NO_STRICT_ALIASING= yes
-.endif # end WITH_OPTIMIZED_CFLAGS
+.endif # end OPTIMIZED_CFLAGS
#Users must add altivec and avx to MACHINE_CPU when desired:
#this is not currently done in bsd.cpu.mk
@@ -87,7 +90,7 @@ CONFIGURE_ARGS+=--enable-altivec
.elif ${FFTW3_FLAVOR} == "long"
. if ${OSVERSION} < 800000
ONLY_FOR_ARCHS = i386 sparc64
-LIB_DEPENDS+= ml.0:${PORTSDIR}/math/ldouble
+LIB_DEPENDS+= ml:${PORTSDIR}/math/ldouble
. endif
FFTW3_SUFX= l
FFTW3_PKGNAMESUFFIX= -long
@@ -141,7 +144,7 @@ post-configure:
@${ECHO_CMD} "#define F77_FUNC(name,NAME) name ## _" >> ${WRKSRC}/config.h
@${ECHO_CMD} "#define F77_FUNC_(name,NAME) name ## _" >> ${WRKSRC}/config.h
@${ECHO_CMD} "#define F77_FUNC_EQUIV 1" >> ${WRKSRC}/config.h
-.if defined(WITH_G77_WRAPPERS)
+.if ${PORT_OPTIONS:MG77_WRAPPERS}
@${ECHO_CMD} "#define WITH_G77_WRAPPERS 1" >> ${WRKSRC}/config.h
.endif
diff --git a/math/fftw3/distinfo b/math/fftw3/distinfo
index b95c136fb6ee..acb3a2b347ee 100644
--- a/math/fftw3/distinfo
+++ b/math/fftw3/distinfo
@@ -1,2 +1,2 @@
-SHA256 (fftw-3.3.1.tar.gz) = c77fc5cda6ce868857aa565cb9b0df0d7a4fcf388ce5c6d482acd80e2452b739
-SIZE (fftw-3.3.1.tar.gz) = 4039988
+SHA256 (fftw-3.3.2.tar.gz) = b1236a780ca6e66fc5f8eda6ef0665d680e8253d9f01d7bf211b714a50032d01
+SIZE (fftw-3.3.2.tar.gz) = 3908279