aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authormaho <maho@FreeBSD.org>2003-06-11 08:17:39 +0800
committermaho <maho@FreeBSD.org>2003-06-11 08:17:39 +0800
commit197de7de93f56c315265696260bf9a9042a28a35 (patch)
tree4dc1053e0911623237ff07aa401228d360ab017e /math
parent9a1dab6598c12b6dd307b0e0e2ea47e6eb203769 (diff)
downloadfreebsd-ports-gnome-197de7de93f56c315265696260bf9a9042a28a35.tar.gz
freebsd-ports-gnome-197de7de93f56c315265696260bf9a9042a28a35.tar.zst
freebsd-ports-gnome-197de7de93f56c315265696260bf9a9042a28a35.zip
Update to 2.5.2
Diffstat (limited to 'math')
-rw-r--r--math/atlas/Makefile2
-rw-r--r--math/atlas/distinfo2
-rw-r--r--math/atlas/files/patch-config.c13
3 files changed, 11 insertions, 6 deletions
diff --git a/math/atlas/Makefile b/math/atlas/Makefile
index e78b547ae741..67507c2ccc2f 100644
--- a/math/atlas/Makefile
+++ b/math/atlas/Makefile
@@ -9,7 +9,7 @@
# Program and compiler flags are finetuned to gcc 2.95/3.1.
PORTNAME= atlas
-PORTVERSION= 3.5.1
+PORTVERSION= 3.5.2
CATEGORIES= math
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= math-atlas
diff --git a/math/atlas/distinfo b/math/atlas/distinfo
index a535e2c3fd68..ead55521ea8d 100644
--- a/math/atlas/distinfo
+++ b/math/atlas/distinfo
@@ -1 +1 @@
-MD5 (atlas3.5.1.tar.bz2) = e0b4c0b9c30863492c90a20c04e199e7
+MD5 (atlas3.5.2.tar.bz2) = 364f166e4ca73d58bcce08559f413ac5
diff --git a/math/atlas/files/patch-config.c b/math/atlas/files/patch-config.c
index 08d9cdfdac15..653fbcc95ee0 100644
--- a/math/atlas/files/patch-config.c
+++ b/math/atlas/files/patch-config.c
@@ -1,5 +1,5 @@
---- config.c.orig Fri Apr 25 03:10:17 2003
-+++ config.c Sat May 10 07:43:36 2003
+--- config.c.orig Sun May 4 06:09:23 2003
++++ config.c Tue Jun 10 13:12:30 2003
@@ -697,7 +697,7 @@
else if (mach == IA64Itan || MachIsUS(mach) ||
mach == Dec21164 || mach == Dec21264)
@@ -31,14 +31,19 @@
}
break;
case LAIA64: /* don't know */
-@@ -2113,14 +2118,17 @@
+@@ -2113,14 +2118,22 @@
if (!CmndOneLine(targ, "sysctl hw.model", ln))
{
if (strstr(ln, "Pentium Pro")) mach = IntPPRO;
++ else if (strstr(ln, "Pentium(R) Pro")) mach = IntPPRO;
+ else if (strstr(ln, "Pentium 4")) mach = IntP4;
++ else if (strstr(ln, "Pentium(R) 4")) mach = IntP4;
else if (strstr(ln, "Pentium III")) mach = IntPIII;
++ else if (strstr(ln, "Pentium(R) III")) mach = IntPIII;
else if (strstr(ln, "Pentium II ")) mach = IntPII;
++ else if (strstr(ln, "Pentium(R) II ")) mach = IntPII;
+ else if (strstr(ln, "Celeron")) mach = IntPII;
++ else if (strstr(ln, "Celeron(R)")) mach = IntPII;
else if (strstr(ln, "Athlon")) mach = AmdAthlon;
else if (strstr(ln, "AMD-K7")) mach = AmdAthlon;
else if (strstr(ln, "32 bit Hammer")) mach = AmdHammer32;
@@ -49,7 +54,7 @@
}
break;
default:;
-@@ -3124,6 +3132,9 @@
+@@ -3124,6 +3137,9 @@
}
if (USEWINF77) strcpy(F77, "$(BINdir)/winf77.exe");