aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorvs <vs@FreeBSD.org>2004-05-04 21:56:39 +0800
committervs <vs@FreeBSD.org>2004-05-04 21:56:39 +0800
commit1a12a395a5738f437d5c2e678c9f7e6911e9e80a (patch)
tree8368319da2f3a8410b8ff9e4bdcef60cd5c07a2e /math
parent1d38f876d2c8407304922bd5fe5ead996c4cff05 (diff)
downloadfreebsd-ports-gnome-1a12a395a5738f437d5c2e678c9f7e6911e9e80a.tar.gz
freebsd-ports-gnome-1a12a395a5738f437d5c2e678c9f7e6911e9e80a.tar.zst
freebsd-ports-gnome-1a12a395a5738f437d5c2e678c9f7e6911e9e80a.zip
Unbreak on -STABLE.
Having -pipe in CFLAGS would break the build: http://docs.freebsd.org/cgi/mid.cgi?20040503181426.GB12673 Approved by: linimon (mentor)
Diffstat (limited to 'math')
-rw-r--r--math/taucs/Makefile5
-rw-r--r--math/taucs/files/extra-patch-build-FreeBSD-makefile11
2 files changed, 13 insertions, 3 deletions
diff --git a/math/taucs/Makefile b/math/taucs/Makefile
index d7fcb4fe7a00..99652af7774b 100644
--- a/math/taucs/Makefile
+++ b/math/taucs/Makefile
@@ -26,9 +26,8 @@ ALL_TARGET=
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500000
-BROKEN= "Does not compile"
-.endif
+post-configure:
+ cd ${WRKSRC}; ${PATCH} <${FILESDIR}/extra-patch-build-FreeBSD-makefile
do-install:
@${INSTALL_DATA} ${WRKSRC}/lib/FreeBSD/libtaucs.a ${PREFIX}/lib
diff --git a/math/taucs/files/extra-patch-build-FreeBSD-makefile b/math/taucs/files/extra-patch-build-FreeBSD-makefile
new file mode 100644
index 000000000000..8fa385f9ceda
--- /dev/null
+++ b/math/taucs/files/extra-patch-build-FreeBSD-makefile
@@ -0,0 +1,11 @@
+--- build/FreeBSD/makefile.orig Mon May 3 20:08:53 2004
++++ build/FreeBSD/makefile Mon May 3 20:09:20 2004
+@@ -42,7 +42,7 @@
+ - $(DIROBJ)taucs_c99_complex_test$(EXEEXT) build/FreeBSD/taucs_config_tests.h
+ - $(CILKC) -c $(CILKFLAGS) $(STDDEFS) $(STDINCS) \
+ $(DIRPROGS)taucs_cilk_test.c \
+- $(CILKOUTFLG)$(DIROBJ)taucs_cilk_test$(OBJEXT)
++ $(CILKOUTFLG)$(DIROBJ)taucs_cilk_test$(OBJEXT) || rm $(DIROBJ)taucs_cilk_test$(OBJEXT)
+ - $(LD) $(LDFLAGS) \
+ $(LOUTFLG)$(DIROBJ)taucs_cilk_test$(EXEEXT) \
+ $(DIROBJ)taucs_cilk_test$(OBJEXT) $(LIBS)