aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorstephen <stephen@FreeBSD.org>2011-07-11 22:31:40 +0800
committerstephen <stephen@FreeBSD.org>2011-07-11 22:31:40 +0800
commit267cdb6b9da8d80b75990b375102b56c41eddb33 (patch)
tree070eaa85d61989e8c9fe6fb24e85a3dc54fe51cd /math
parentccb3258f3e98b501362147fee30f145ece857b8c (diff)
downloadfreebsd-ports-gnome-267cdb6b9da8d80b75990b375102b56c41eddb33.tar.gz
freebsd-ports-gnome-267cdb6b9da8d80b75990b375102b56c41eddb33.tar.zst
freebsd-ports-gnome-267cdb6b9da8d80b75990b375102b56c41eddb33.zip
- Add missing items in pkg-plist.
- Portlint. - Bump portrevision. Approved by: maho (mentor) and maho (maintainer)
Diffstat (limited to 'math')
-rw-r--r--math/octave/Makefile8
-rw-r--r--math/octave/pkg-plist3
2 files changed, 7 insertions, 4 deletions
diff --git a/math/octave/Makefile b/math/octave/Makefile
index 22b69dd84665..9bd676991221 100644
--- a/math/octave/Makefile
+++ b/math/octave/Makefile
@@ -7,6 +7,7 @@
PORTNAME= octave
PORTVERSION= 3.4.2
+PORTREVISION= 1
CATEGORIES= math
MASTER_SITES= ftp://ftp.gnu.org/gnu/octave/ \
ftp://ftp.u-aizu.ac.jp/pub/SciEng/numanal/Octave/bleeding-edge/
@@ -18,10 +19,10 @@ BUILD_DEPENDS+= gnuplot:${PORTSDIR}/math/gnuplot \
${LOCALBASE}/bin/gperf:${PORTSDIR}/devel/gperf \
gsed:${PORTSDIR}/textproc/gsed \
dvips:${PORTSDIR}/print/dvipsk-tetex \
- ${PREFIX}/bin/makeinfo:${PORTSDIR}/print/texinfo
+ ${LOCALBASE}/bin/makeinfo:${PORTSDIR}/print/texinfo
RUN_DEPENDS= gnuplot:${PORTSDIR}/math/gnuplot \
gsed:${PORTSDIR}/textproc/gsed \
- ${PREFIX}/bin/makeinfo:${PORTSDIR}/print/texinfo
+ ${LOCALBASE}/bin/makeinfo:${PORTSDIR}/print/texinfo
LIB_DEPENDS= GraphicsMagick.1:${PORTSDIR}/graphics/GraphicsMagick \
arpack:${PORTSDIR}/math/arpack \
curl:${PORTSDIR}/ftp/curl \
@@ -120,14 +121,13 @@ post-install:
@${FIND} -s $d -not -type d | \
${SED} -e 's#^${PREFIX}/##' >> ${WRKDIR}/PLIST
@${FIND} -s $d -type d -empty | \
- ${SED} -e 's,^${PREFIX}/,@exec mkdir -p %D/,' \
+ ${SED} -e 's,^${PREFIX}/,@exec ${MKDIR} %D/,' \
-e 's,$$, 2>/dev/null || true,' >> ${WRKDIR}/PLIST
@${FIND} -s $d -type d -depth | \
${SED} -e 's,^${PREFIX}/,@dirrm ,' >> ${WRKDIR}/PLIST
.endfor
cd ${WRKDIR} ; ${SED} -i -e "/PLIST/ r PLIST" ${TMPPLIST}
-
check:
(cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_ARGS} check)
diff --git a/math/octave/pkg-plist b/math/octave/pkg-plist
index 027b33e1ccc5..41e2ea51c279 100644
--- a/math/octave/pkg-plist
+++ b/math/octave/pkg-plist
@@ -1,7 +1,9 @@
bin/mkoctfile
+bin/mkoctfile-%%OCTAVE_VERSION%%
bin/octave
bin/octave-%%OCTAVE_VERSION%%
bin/octave-config
+bin/octave-config-%%OCTAVE_VERSION%%
share/applications/www.octave.org-octave.desktop
%%PORTDOCS%%%%DOCSDIR%%/OctaveFAQ.ps
%%PORTDOCS%%%%DOCSDIR%%/liboctave.ps
@@ -12,3 +14,4 @@ share/applications/www.octave.org-octave.desktop
%%PORTDOCS%%@dirrm %%DOCSDIR%%
@comment Insert PLIST here
@dirrmtry share/applications
+@dirrm lib/octave