aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authormaho <maho@FreeBSD.org>2007-01-12 21:00:06 +0800
committermaho <maho@FreeBSD.org>2007-01-12 21:00:06 +0800
commit326e1e036715fd1d68fe73c242772874b2480a24 (patch)
tree57609dcc8b9370c8463378c1a4856015875c0612 /math
parent972041768efe882d8a54177058cc64c64259f511 (diff)
downloadfreebsd-ports-gnome-326e1e036715fd1d68fe73c242772874b2480a24.tar.gz
freebsd-ports-gnome-326e1e036715fd1d68fe73c242772874b2480a24.tar.zst
freebsd-ports-gnome-326e1e036715fd1d68fe73c242772874b2480a24.zip
* Migrate to gfortran.
* Bump port revision.
Diffstat (limited to 'math')
-rw-r--r--math/femlab/Makefile7
-rw-r--r--math/femlab/files/patch-fsource_makepoisson2
2 files changed, 8 insertions, 1 deletions
diff --git a/math/femlab/Makefile b/math/femlab/Makefile
index b7e3efe57b8f..309990042976 100644
--- a/math/femlab/Makefile
+++ b/math/femlab/Makefile
@@ -7,6 +7,7 @@
PORTNAME= femlab
PORTVERSION= 1.1
+PORTREVISION= 1
CATEGORIES= math science
# mastersite disappeared in April 2000
MASTER_SITES= # ftp://ftp.md.chalmers.se/pub/Femlab/
@@ -18,6 +19,12 @@ COMMENT= Interactive program for solving partial differential equations in 2D
BUILD_DEPENDS= ${X11BASE}/lib/libsx.a:${PORTSDIR}/x11/libsx \
xmkmf:${X_IMAKE_PORT}
+WANT_FORTRAN= yes #dummy but future use
+BUILD_DEPENDS+= gfortran42:${PORTSDIR}/lang/gcc42
+FC= gfortran42
+F77= gfortran42
+MAKE_ENV+= FC="${FC}" F77="${F77}" FFLAGS="${FFLAGS}"
+
USE_X_PREFIX= yes
FEMLAB_HOME= ${PREFIX}/lib/X11/femlab
diff --git a/math/femlab/files/patch-fsource_makepoisson b/math/femlab/files/patch-fsource_makepoisson
index 2544f6e764ca..e3ab16ae0335 100644
--- a/math/femlab/files/patch-fsource_makepoisson
+++ b/math/femlab/files/patch-fsource_makepoisson
@@ -5,7 +5,7 @@ $FreeBSD$
+++ fsource/makepoisson Wed Jul 24 00:06:17 2002
@@ -1,4 +1,4 @@
-FFLAGS= -O
-+FFLAGS= -O -fno-globals
++FFLAGS= -O2
FFILES= dwm1.f startpo.f preproc.f rhslhs.f poisson.f output.f