aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2017-08-04 01:22:18 +0800
committerKoop Mast <kwm@rainbow-runner.nl>2018-02-04 05:17:50 +0800
commit34941cfe78559b1c0f086385a375e477a47fc8bb (patch)
tree3c891c3bc953b873b73fb9331d540ceb9fafa28a /math
parent84cec9f859c5b5f881570798c964e5c4f7ab8f94 (diff)
downloadfreebsd-ports-gnome-34941cfe78559b1c0f086385a375e477a47fc8bb.tar.gz
freebsd-ports-gnome-34941cfe78559b1c0f086385a375e477a47fc8bb.tar.zst
freebsd-ports-gnome-34941cfe78559b1c0f086385a375e477a47fc8bb.zip
- Add test target
- While here, switch to options helpers PR: 220425 Submitted by: yuri@rawbw.com Approved by: maintainer timeout (phd_kimberlite@yahoo.co.jp, 1 month)
Diffstat (limited to 'math')
-rw-r--r--math/openblas/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/math/openblas/Makefile b/math/openblas/Makefile
index f8191668cbec..97d54d36ecea 100644
--- a/math/openblas/Makefile
+++ b/math/openblas/Makefile
@@ -32,6 +32,7 @@ OPENBLAS_LIBS= libopenblas libopenblasp
OPENBLAS_SVER= 0
OPENBLAS_FILES= ${OPENBLAS_LIBS:S|$|.so|} ${OPENBLAS_LIBS:S|$|.so.${OPENBLAS_SVER}|} ${OPENBLAS_LIBS:S|$|.a|}
PLIST_FILES= ${OPENBLAS_FILES:S|^|lib/|}
+TEST_TARGET= tests
OPTIONS_DEFINE= INTERFACE64 OPENMP
OPTIONS_DEFINE_i386= DYNAMIC_ARCH AVX AVX2
@@ -125,11 +126,11 @@ post-patch:
-e 's+$${CROSS_SUFFIX}+${LOCALBASE}/bin/+' \
-e '/Clang.*OpenMP/g' \
${WRKSRC}/Makefile.system
-.if ${PORT_OPTIONS:MOPENMP}
+
+post-patch-OPENMP-on:
${REINPLACE_CMD} -e "s+OPENBLAS_NUM_THREADS+OMP_NUM_THREADS+g" \
${WRKSRC}/test/Makefile \
${WRKSRC}/ctest/Makefile
-.endif
do-build:
cd ${WRKSRC} ; ${SETENV} ${BUILDFLAGS} NUM_THREADS=1 USE_THREAD=0 \