aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorperky <perky@FreeBSD.org>2004-12-05 11:38:19 +0800
committerperky <perky@FreeBSD.org>2004-12-05 11:38:19 +0800
commit3c88a5d591f701eaefffaec434110ce8d8e38f9c (patch)
tree1dc5ba0644dcc6f1bc595634eb2bb863c4097b9c /math
parente1bd786513d217efa96e0e5fe95f188d973a85a5 (diff)
downloadfreebsd-ports-gnome-3c88a5d591f701eaefffaec434110ce8d8e38f9c.tar.gz
freebsd-ports-gnome-3c88a5d591f701eaefffaec434110ce8d8e38f9c.tar.zst
freebsd-ports-gnome-3c88a5d591f701eaefffaec434110ce8d8e38f9c.zip
Fix build on Python 2.4.
Diffstat (limited to 'math')
-rw-r--r--math/gracetmpl/files/patch-pygracetmpl.cc20
-rw-r--r--math/gracetmpl/pkg-plist4
2 files changed, 19 insertions, 5 deletions
diff --git a/math/gracetmpl/files/patch-pygracetmpl.cc b/math/gracetmpl/files/patch-pygracetmpl.cc
index 9ba3f2d0cad8..74dcc3abfd7c 100644
--- a/math/gracetmpl/files/patch-pygracetmpl.cc
+++ b/math/gracetmpl/files/patch-pygracetmpl.cc
@@ -1,6 +1,20 @@
---- python/src/pygracetmpl.cc.orig Mon Aug 16 18:25:45 2004
-+++ python/src/pygracetmpl.cc Mon Aug 16 18:31:35 2004
-@@ -179,7 +179,7 @@
+--- python/src/pygracetmpl.cc.orig Sat Oct 12 05:12:57 2002
++++ python/src/pygracetmpl.cc Sun Dec 5 12:35:53 2004
+@@ -1,11 +1,10 @@
+ #include <gracetmpl.h>
+
+-#include <Python.h>
+-#include <Numeric/arrayobject.h> /* numerical python header */
+-
+ #include <string.h>
+ #include <complex>
+ #include <set>
++#include <Python.h>
++#include <Numeric/arrayobject.h> /* numerical python header */
+
+ /********************************************************/
+ /******************* graceTMPL.data type ***************/
+@@ -179,7 +178,7 @@
int rows = dataArray->dimensions[1];
if(cols > 4)
cols = 4;
diff --git a/math/gracetmpl/pkg-plist b/math/gracetmpl/pkg-plist
index 7a4b961e6434..17646c9a5638 100644
--- a/math/gracetmpl/pkg-plist
+++ b/math/gracetmpl/pkg-plist
@@ -2,8 +2,8 @@ bin/gracetmpl-config
bin/gracetmpldemo
include/gracetmpl.h
lib/libgracetmpl.a
-include/python2.3/graceTMPL/gracetmpl.h
-@dirrm include/python2.3/graceTMPL
+%%PYTHON_INCLUDEDIR%%/graceTMPL/gracetmpl.h
+@dirrm %%PYTHON_INCLUDEDIR%%/graceTMPL
%%PYTHON_SITELIBDIR%%/graceTMPL/graceTMPL.so
%%PYTHON_SITELIBDIR%%/graceTMPL.pth
@dirrm %%PYTHON_SITELIBDIR%%/graceTMPL