aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authoraaron <aaron@FreeBSD.org>2006-05-15 23:02:14 +0800
committeraaron <aaron@FreeBSD.org>2006-05-15 23:02:14 +0800
commit4a1bbe92c07ce820445794b6cf37c8d2c848f6c3 (patch)
tree8e2eb49539aa1606ba17528f8c531158ad416196 /math
parentc88dfb86dacbdc10893773cb2e63c16af4f5fef1 (diff)
downloadfreebsd-ports-gnome-4a1bbe92c07ce820445794b6cf37c8d2c848f6c3.tar.gz
freebsd-ports-gnome-4a1bbe92c07ce820445794b6cf37c8d2c848f6c3.tar.zst
freebsd-ports-gnome-4a1bbe92c07ce820445794b6cf37c8d2c848f6c3.zip
Adding port math/p5-Math-SymbolicX-Complex, Complex number support for the Math::Symbolic parser
Approved by: tobez (implicit)
Diffstat (limited to 'math')
-rw-r--r--math/Makefile1
-rw-r--r--math/p5-Math-SymbolicX-Complex/Makefile32
-rw-r--r--math/p5-Math-SymbolicX-Complex/distinfo3
-rw-r--r--math/p5-Math-SymbolicX-Complex/pkg-descr8
-rw-r--r--math/p5-Math-SymbolicX-Complex/pkg-plist7
5 files changed, 51 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index acdb596d758c..c1ceac7b557d 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -193,6 +193,7 @@
SUBDIR += p5-Math-Symbolic-Custom-CCompiler
SUBDIR += p5-Math-Symbolic-Custom-Contains
SUBDIR += p5-Math-SymbolicX-BigNum
+ SUBDIR += p5-Math-SymbolicX-Complex
SUBDIR += p5-Math-SymbolicX-Inline
SUBDIR += p5-Math-SymbolicX-ParserExtensionFactory
SUBDIR += p5-Math-TrulyRandom
diff --git a/math/p5-Math-SymbolicX-Complex/Makefile b/math/p5-Math-SymbolicX-Complex/Makefile
new file mode 100644
index 000000000000..3fbe5c371b66
--- /dev/null
+++ b/math/p5-Math-SymbolicX-Complex/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: Math-SymbolicX-Complex
+# Date created: 15 May 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Math-SymbolicX-Complex
+PORTVERSION= 0.01
+CATEGORIES= math perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Math
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= Complex number support for the Math::Symbolic parser
+
+BUILD_DEPENDS= ${SITE_PERL}/Math/Symbolic.pm:${PORTSDIR}/math/p5-Math-Symbolic \
+ ${SITE_PERL}/Math/SymbolicX/ParserExtensionFactory.pm:${PORTSDIR}/math/p5-Math-SymbolicX-ParserExtensionFactory
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+MAN3= Math::SymbolicX::Complex.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires at least Perl 5.6 due to dependencies. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/math/p5-Math-SymbolicX-Complex/distinfo b/math/p5-Math-SymbolicX-Complex/distinfo
new file mode 100644
index 000000000000..c66001eddccf
--- /dev/null
+++ b/math/p5-Math-SymbolicX-Complex/distinfo
@@ -0,0 +1,3 @@
+MD5 (Math-SymbolicX-Complex-0.01.tar.gz) = 509cc4092ade46de3762bf3d5f63a914
+SHA256 (Math-SymbolicX-Complex-0.01.tar.gz) = 559947d3d40937108c5b9814dc8b6b6c4ae69c684f84e07f9d7008b6d1ae93b6
+SIZE (Math-SymbolicX-Complex-0.01.tar.gz) = 4057
diff --git a/math/p5-Math-SymbolicX-Complex/pkg-descr b/math/p5-Math-SymbolicX-Complex/pkg-descr
new file mode 100644
index 000000000000..00626db86978
--- /dev/null
+++ b/math/p5-Math-SymbolicX-Complex/pkg-descr
@@ -0,0 +1,8 @@
+This module adds complex number support to Math::Symbolic. It does so by
+extending the parser of the Math::Symbolic module (that is, the one stored
+in $Math::Symbolic::Parser) with certain special functions that create
+complex constants. (Math::Symbolic::Variable objects have been able to
+contain complex number objects since the very beginning.)
+
+WWW: http://search.cpan.org/dist/Math-SymbolicX-Complex
+Author: Steffen Mueller <symbolic-module@steffen-mueller.net>
diff --git a/math/p5-Math-SymbolicX-Complex/pkg-plist b/math/p5-Math-SymbolicX-Complex/pkg-plist
new file mode 100644
index 000000000000..43b5ee8c7596
--- /dev/null
+++ b/math/p5-Math-SymbolicX-Complex/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/Math/SymbolicX/Complex.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/SymbolicX/Complex/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/SymbolicX/Complex
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/SymbolicX
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Math
+@dirrmtry %%SITE_PERL%%/Math/SymbolicX
+@dirrmtry %%SITE_PERL%%/Math