aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2015-05-16 19:23:06 +0800
committermakc <makc@FreeBSD.org>2015-05-16 19:23:06 +0800
commit50f2451524967f72aeeb740ab0eddbd683b9cf32 (patch)
tree4e7e649aef9c67293b14fb974fbe448f62a0e3c4 /math
parent9eeb4ced0f21a181be91c73897a30f637b7451dc (diff)
downloadfreebsd-ports-gnome-50f2451524967f72aeeb740ab0eddbd683b9cf32.tar.gz
freebsd-ports-gnome-50f2451524967f72aeeb740ab0eddbd683b9cf32.tar.zst
freebsd-ports-gnome-50f2451524967f72aeeb740ab0eddbd683b9cf32.zip
math/scilab:
- Clean up blas/lapack usage Based on patch, provided by maho@ via email.
Diffstat (limited to 'math')
-rw-r--r--math/scilab/Makefile24
1 files changed, 9 insertions, 15 deletions
diff --git a/math/scilab/Makefile b/math/scilab/Makefile
index 9c9a5b754005..f8833b048974 100644
--- a/math/scilab/Makefile
+++ b/math/scilab/Makefile
@@ -32,16 +32,21 @@ LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS= --with-gfortran \
--without-emf \
-disable-static-system-lib
-CONFIGURE_ENV= BLAS_LIBS="${BLAS_LIBS}" LAPACK_LIBS="${LAPACK_LIBS}"
+CONFIGURE_ENV= BLAS_LIBS="${BLASLIB}" LAPACK_LIBS="${LAPACKLIB}"
MAKE_ENV= LANG=en_US.UTF-8 \
LC_ALL=en_US.UTF-8
INSTALL_TARGET= install-strip
-OPTIONS_DEFINE= ATLAS GUI OCAML TK
-OPTIONS_DEFAULT= GUI OCAML TK
+OPTIONS_DEFINE= GUI OCAML TK
+OPTIONS_RADIO= BLAS
+OPTIONS_RADIO_BLAS= ATLAS NETLIB OPENBLAS
+OPTIONS_DEFAULT= GUI NETLIB OCAML TK
OPTIONS_SUB= yes
-ATLAS_DESC= Use Atlas instead of Blas
+ATLAS_USES= blaslapack:atlas
+NETLIB_USES= blaslapack:netlib
+OPENBLAS_USES= blaslapack:openblas
+
GUI_DESC= Graphical User Interface (Java)
OCAML_DESC= Scicos - dynamical system simulator (requires GUI)
@@ -107,17 +112,6 @@ TK_USE= XORG=x11
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MATLAS}
-LIB_DEPENDS+= libatlas.so:${PORTSDIR}/math/atlas
-BLAS_LIBS= -lf77blas
-LAPACK_LIBS= -lalapack -lcblas
-.else
-LIB_DEPENDS+= liblapack.so:${PORTSDIR}/math/lapack \
- libblas.so:${PORTSDIR}/math/blas
-BLAS_LIBS= -lblas
-LAPACK_LIBS= -llapack
-.endif
-
.if ${PORT_OPTIONS:MGUI}
USE_JAVA= yes
# bsdjava (ie java/jdk16) doesn't have some "extra" classes that aren't in