aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2004-07-10 01:43:11 +0800
committermarcus <marcus@FreeBSD.org>2004-07-10 01:43:11 +0800
commit5cc9328814fb9b8e64ff3588af7e6031c1d3514b (patch)
treedf0b6bb8e4e84920da9881d421090dc67f70c629 /math
parente058c31decaf84a24b7ab7306f65221b33ada080 (diff)
downloadfreebsd-ports-gnome-5cc9328814fb9b8e64ff3588af7e6031c1d3514b.tar.gz
freebsd-ports-gnome-5cc9328814fb9b8e64ff3588af7e6031c1d3514b.tar.zst
freebsd-ports-gnome-5cc9328814fb9b8e64ff3588af7e6031c1d3514b.zip
Apply a big libtool patch to allow porters to use the libtool installed by
the libtoolX ports instead of the one included with each port. Ports that set USE_LIBTOOL_VER=X will now use the ports version of libtool instead of the included version. To restore previous behavior, use the new macro, USE_INC_LIBTOOL_VER. Both macros accept the same argument: a libtool version. For example, to use the ports version of libtool-1.5, add the following to your Makefile: USE_LIBTOOL_VER= 15 To use the included version of libtool with extra hacks provided by libtool-1.5, add the following to your Makefile: USE_INC_LIBTOOL_VER= 15 With this change, ports that had to add additional libtool hacks to prevent .la files from being installed or to fix certain threading issues can now delete those hacks (after appropriate testing, of course). PR: 63944 Based on work by:eik and marcus Approved by: ade (autotools maintainer) Tested by: kris on pointyhat Bound to be hidden problems: You bet
Diffstat (limited to 'math')
-rw-r--r--math/cln/Makefile2
-rw-r--r--math/fftw/Makefile2
-rw-r--r--math/fftw3/Makefile2
-rw-r--r--math/fung-calc/Makefile2
-rw-r--r--math/gmp/Makefile2
-rw-r--r--math/gsl/Makefile2
-rw-r--r--math/koctave/Makefile2
-rw-r--r--math/libgmp4/Makefile2
-rw-r--r--math/libmath++/Makefile2
-rw-r--r--math/libneural/Makefile2
-rw-r--r--math/qhull/Makefile2
-rw-r--r--math/qhull5/Makefile2
-rw-r--r--math/spar/Makefile2
13 files changed, 13 insertions, 13 deletions
diff --git a/math/cln/Makefile b/math/cln/Makefile
index 61680cdb35aa..2f70f3dbf76f 100644
--- a/math/cln/Makefile
+++ b/math/cln/Makefile
@@ -22,7 +22,7 @@ LIB_DEPENDS= gmp.6:${PORTSDIR}/math/libgmp4
USE_BZIP2= yes
USE_GMAKE= yes
USE_GNOME= gnomehack
-USE_LIBTOOL_VER=13
+USE_INC_LIBTOOL_VER=13
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --infodir=${PREFIX}/info --mandir=${PREFIX}/man \
diff --git a/math/fftw/Makefile b/math/fftw/Makefile
index b0932029fea0..270748588fd5 100644
--- a/math/fftw/Makefile
+++ b/math/fftw/Makefile
@@ -18,7 +18,7 @@ MAINTAINER= Lars.Koeller@Uni-Bielefeld.DE
COMMENT= Fast C routines to compute the Discrete Fourier Transform
USE_GMAKE= yes
-USE_LIBTOOL_VER=13
+USE_INC_LIBTOOL_VER=13
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= MAKEINFO="makeinfo --no-split"
CONFIGURE_ARGS= --enable-shared
diff --git a/math/fftw3/Makefile b/math/fftw3/Makefile
index 6abbccc087f4..2740d725dc01 100644
--- a/math/fftw3/Makefile
+++ b/math/fftw3/Makefile
@@ -19,7 +19,7 @@ MAINTAINER= ahze@ahze.net
COMMENT= Fast C routines to compute the Discrete Fourier Transform
USE_GMAKE= yes
-USE_LIBTOOL_VER=13
+USE_INC_LIBTOOL_VER=13
USE_GNOME= gnomehack gnomeprefix gnometarget lthack pkgconfig
USE_REINPLACE= yes
INSTALLS_SHLIB= yes
diff --git a/math/fung-calc/Makefile b/math/fung-calc/Makefile
index 80b87cd6848a..f15a24799f80 100644
--- a/math/fung-calc/Makefile
+++ b/math/fung-calc/Makefile
@@ -17,7 +17,7 @@ COMMENT= Advanced graphic calculator
USE_KDELIBS_VER= 3
USE_GL= yes
USE_GMAKE= yes
-USE_LIBTOOL_VER=13
+USE_INC_LIBTOOL_VER=13
USE_REINPLACE= yes
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
diff --git a/math/gmp/Makefile b/math/gmp/Makefile
index 06713f61c160..dee6f21df5bc 100644
--- a/math/gmp/Makefile
+++ b/math/gmp/Makefile
@@ -19,7 +19,7 @@ COMMENT= A free library for arbitrary precision arithmetic
CONFLICTS= libgmp-2*
USE_REINPLACE= yes
USE_GNOME= lthack
-USE_LIBTOOL_VER=13
+USE_INC_LIBTOOL_VER=13
CONFIGURE_ENV= MAKEINFO="makeinfo --no-split"
CONFIGURE_ARGS= --enable-cxx --enable-mpfr
INSTALLS_SHLIB= yes
diff --git a/math/gsl/Makefile b/math/gsl/Makefile
index 028ff365cff7..7065e7f02dd9 100644
--- a/math/gsl/Makefile
+++ b/math/gsl/Makefile
@@ -19,7 +19,7 @@ MAINTAINER= jon.drews@gmail.com
COMMENT= The GNU Scientific Library - mathematical libs
INSTALLS_SHLIB= yes
-USE_LIBTOOL_VER=13
+USE_INC_LIBTOOL_VER=13
GNU_CONFIGURE= yes
CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV+= MAKEINFO='makeinfo --no-split'
diff --git a/math/koctave/Makefile b/math/koctave/Makefile
index 53705dd0630e..9ee7e295e3c9 100644
--- a/math/koctave/Makefile
+++ b/math/koctave/Makefile
@@ -17,7 +17,7 @@ COMMENT= KDEGUI for octave
RUN_DEPENDS= octave:${PORTSDIR}/math/octave
USE_BZIP2= yes
-USE_LIBTOOL_VER=13
+USE_INC_LIBTOOL_VER=13
USE_QT_VER= 3
USE_KDELIBS_VER=3
USE_GMAKE= yes
diff --git a/math/libgmp4/Makefile b/math/libgmp4/Makefile
index 06713f61c160..dee6f21df5bc 100644
--- a/math/libgmp4/Makefile
+++ b/math/libgmp4/Makefile
@@ -19,7 +19,7 @@ COMMENT= A free library for arbitrary precision arithmetic
CONFLICTS= libgmp-2*
USE_REINPLACE= yes
USE_GNOME= lthack
-USE_LIBTOOL_VER=13
+USE_INC_LIBTOOL_VER=13
CONFIGURE_ENV= MAKEINFO="makeinfo --no-split"
CONFIGURE_ARGS= --enable-cxx --enable-mpfr
INSTALLS_SHLIB= yes
diff --git a/math/libmath++/Makefile b/math/libmath++/Makefile
index 420893a956a8..b7a986f03b01 100644
--- a/math/libmath++/Makefile
+++ b/math/libmath++/Makefile
@@ -14,7 +14,7 @@ MAINTAINER= jhb@FreeBSD.org
COMMENT= C++ Library for Symbolic and Numeric Calculus Applications
USE_GMAKE= yes
-USE_LIBTOOL_VER=13
+USE_INC_LIBTOOL_VER=13
INSTALLS_SHLIB= yes
.include <bsd.port.mk>
diff --git a/math/libneural/Makefile b/math/libneural/Makefile
index 9c37368e32e5..13a688f9586b 100644
--- a/math/libneural/Makefile
+++ b/math/libneural/Makefile
@@ -13,7 +13,7 @@ MASTER_SITES= http://ieee.uow.edu.au/documents/contrib/
MAINTAINER= ports@FreeBSD.org
COMMENT= C++ implementation of the classic 3-layer perceptron in library form
-USE_LIBTOOL_VER=13
+USE_INC_LIBTOOL_VER=13
INSTALLS_SHLIB= yes
.include <bsd.port.mk>
diff --git a/math/qhull/Makefile b/math/qhull/Makefile
index ebcabbe843a6..b369c957dbb2 100644
--- a/math/qhull/Makefile
+++ b/math/qhull/Makefile
@@ -16,7 +16,7 @@ COMMENT= Qhull computes convex hulls, Delaunay triangulations and halfspaces
USE_REINPLACE= yes
USE_GMAKE= yes
INSTALLS_SHLIB= yes
-USE_LIBTOOL_VER= 13
+USE_INC_LIBTOOL_VER= 13
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
.if !defined(NOPORTDOCS)
diff --git a/math/qhull5/Makefile b/math/qhull5/Makefile
index ebcabbe843a6..b369c957dbb2 100644
--- a/math/qhull5/Makefile
+++ b/math/qhull5/Makefile
@@ -16,7 +16,7 @@ COMMENT= Qhull computes convex hulls, Delaunay triangulations and halfspaces
USE_REINPLACE= yes
USE_GMAKE= yes
INSTALLS_SHLIB= yes
-USE_LIBTOOL_VER= 13
+USE_INC_LIBTOOL_VER= 13
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
.if !defined(NOPORTDOCS)
diff --git a/math/spar/Makefile b/math/spar/Makefile
index e7fe94a63b61..84fd25edb93b 100644
--- a/math/spar/Makefile
+++ b/math/spar/Makefile
@@ -17,7 +17,7 @@ COMMENT= A modular math parser
USE_GETOPT_LONG= yes
USE_REINPLACE= yes
-USE_LIBTOOL_VER=13
+USE_INC_LIBTOOL_VER=13
INSTALLS_SHLIB= yes
MAN1= spar.1