aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2010-03-10 06:29:17 +0800
committermiwi <miwi@FreeBSD.org>2010-03-10 06:29:17 +0800
commit8b9d88fc9a84e634e4c4d69af1a3b5dc39a45306 (patch)
treec05918b56e50adb4b350e2a16be7f29b5e09c5e1 /math
parent9a53eddfe6c6264ecb7404a25feef55744e96807 (diff)
downloadfreebsd-ports-gnome-8b9d88fc9a84e634e4c4d69af1a3b5dc39a45306.tar.gz
freebsd-ports-gnome-8b9d88fc9a84e634e4c4d69af1a3b5dc39a45306.tar.zst
freebsd-ports-gnome-8b9d88fc9a84e634e4c4d69af1a3b5dc39a45306.zip
PRNG is a collection of portable, high-performance ANSI-C implementations of
pseudorandom number generators such as linear congruential, inversive congruential, and explicit inversive congruential random number generators (LCG, ICG and EICG, respectively) created by Otmar Lendl and and Josef Leydold. WWW: http://statistik.wu-wien.ac.at/software/prng/index.html PR: ports/144031 Submitted by: bf <bf1783 at gmail.com>
Diffstat (limited to 'math')
-rw-r--r--math/Makefile1
-rw-r--r--math/prng/Makefile39
-rw-r--r--math/prng/distinfo3
-rw-r--r--math/prng/pkg-descr6
4 files changed, 49 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 435e38e70bec..2c9564ab0e9d 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -418,6 +418,7 @@
SUBDIR += plplot
SUBDIR += polymake
SUBDIR += primegen
+ SUBDIR += prng
SUBDIR += proofgeneral
SUBDIR += pspp
SUBDIR += py-basemap
diff --git a/math/prng/Makefile b/math/prng/Makefile
new file mode 100644
index 000000000000..5102db1732d4
--- /dev/null
+++ b/math/prng/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: prng
+# Date created: 16 Feb. 2010
+# Whom: bf <bf1783@gmail.com>
+# $FreeBSD$
+
+PORTNAME= prng
+DISTVERSION= 3.0.2
+CATEGORIES= math
+MASTER_SITES= http://statistik.wu-wien.ac.at/software/prng/
+
+MAINTAINER= bf1783@gmail.com
+COMMENT= Portable, high-performance ANSI-C pseudorandom number generators
+
+GNU_CONFIGURE= yes
+CONFIGURE_ENV+= LDFLAGS="${LDFLAGS}"
+INFO= prng
+PLIST_FILES= include/prng.h lib/libprng.a
+PORTDOCS= prng.dvi prng.pdf prng.ps prng.txt
+PORTEXAMPLES= Makefile pairs.c tuples.c
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for _d in ${PORTDOCS}
+ ${INSTALL_MAN} ${WRKSRC}/doc/${_d} ${DOCSDIR}
+.endfor
+.endif
+.if !defined(NOPORTEXAMPLES)
+ ${MKDIR} ${EXAMPLESDIR}
+.for _e in ${PORTEXAMPLES}
+ ${INSTALL_DATA} ${WRKSRC}/examples/${_e} ${EXAMPLESDIR}
+.endfor
+.endif
+
+test: build
+ @(cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${MAKE} \
+ ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} check)
+
+.include <bsd.port.mk>
diff --git a/math/prng/distinfo b/math/prng/distinfo
new file mode 100644
index 000000000000..cd195bca190d
--- /dev/null
+++ b/math/prng/distinfo
@@ -0,0 +1,3 @@
+MD5 (prng-3.0.2.tar.gz) = 80cb0870f2d18618bd2772f9e1dc1a70
+SHA256 (prng-3.0.2.tar.gz) = 8299182b97c24b7891d74590a8a8438641a6c681ce34d6c3f7bc98a0649da48b
+SIZE (prng-3.0.2.tar.gz) = 497047
diff --git a/math/prng/pkg-descr b/math/prng/pkg-descr
new file mode 100644
index 000000000000..9c5ca3315057
--- /dev/null
+++ b/math/prng/pkg-descr
@@ -0,0 +1,6 @@
+PRNG is a collection of portable, high-performance ANSI-C implementations of
+pseudorandom number generators such as linear congruential, inversive
+congruential, and explicit inversive congruential random number generators (LCG,
+ICG and EICG, respectively) created by Otmar Lendl and and Josef Leydold.
+
+WWW: http://statistik.wu-wien.ac.at/software/prng/index.html