aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2012-01-27 04:18:32 +0800
committerpav <pav@FreeBSD.org>2012-01-27 04:18:32 +0800
commit91fb36a495befc14c051a13821b6c601227465c4 (patch)
tree4ddae3d045f566c8029e850106dfaa4bdef04ad5 /math
parent2a4113ba8b9262532fc429bdbeb912438381bbf9 (diff)
downloadfreebsd-ports-gnome-91fb36a495befc14c051a13821b6c601227465c4.tar.gz
freebsd-ports-gnome-91fb36a495befc14c051a13821b6c601227465c4.tar.zst
freebsd-ports-gnome-91fb36a495befc14c051a13821b6c601227465c4.zip
- Add a couple of pure extensions:
devel/pure-readline: A readline interface for the Pure language devel/pure-stldict: Pure interface to C++ STL map/unordered_map devel/pure-stlvec: Pure interface to C++ STL vector math/pure-mpfr: Multiprecision floats for Pure x11-toolkits/pure-tk: A basic interface between Pure and Tcl/Tk PR: ports/161799 Submitted by: Zhihao Yuan <lichray@gmail.com>
Diffstat (limited to 'math')
-rw-r--r--math/Makefile1
-rw-r--r--math/pure-mpfr/Makefile24
-rw-r--r--math/pure-mpfr/distinfo2
-rw-r--r--math/pure-mpfr/pkg-descr5
4 files changed, 32 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 032f476826f6..c1f6b877a0d6 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -489,6 +489,7 @@
SUBDIR += prng
SUBDIR += proofgeneral
SUBDIR += pspp
+ SUBDIR += pure-mpfr
SUBDIR += pure-rational
SUBDIR += py-apgl
SUBDIR += py-basemap
diff --git a/math/pure-mpfr/Makefile b/math/pure-mpfr/Makefile
new file mode 100644
index 000000000000..a2979b844843
--- /dev/null
+++ b/math/pure-mpfr/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: pure-mpfr
+# Date created: 2011-10-19
+# Whom: Zhihao Yuan <lichray@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pure-mpfr
+PORTVERSION= 0.4
+CATEGORIES= math
+
+MAINTAINER= lichray@gmail.com
+COMMENT= Multiprecision floats for Pure
+
+USE_PURE= yes
+
+PLIST_FILES= lib/pure/mpfr.pure \
+ lib/pure/mpfr.so
+
+MAKE_ARGS+= libdir="${PREFIX}/lib"
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/lang/pure/bsd.pure.mk"
+.include <bsd.port.post.mk>
diff --git a/math/pure-mpfr/distinfo b/math/pure-mpfr/distinfo
new file mode 100644
index 000000000000..cb3f0d1be592
--- /dev/null
+++ b/math/pure-mpfr/distinfo
@@ -0,0 +1,2 @@
+SHA256 (pure/pure-mpfr-0.4.tar.gz) = 23797d9996d4395aa08eadcb6ce3313267a24e9bc3bf7faa6012dcce339b65d6
+SIZE (pure/pure-mpfr-0.4.tar.gz) = 24401
diff --git a/math/pure-mpfr/pkg-descr b/math/pure-mpfr/pkg-descr
new file mode 100644
index 000000000000..ba226da0803b
--- /dev/null
+++ b/math/pure-mpfr/pkg-descr
@@ -0,0 +1,5 @@
+pure-mpfr makes the MPFR multiprecision floats (henceforth referred to as
+mpfr numbers or values) available in Pure, so that they work with the other
+types of Pure numbers in an almost seamless fashion.
+
+WWW: http://docs.pure-lang.googlecode.com/hg/pure-mpfr.html