aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2010-03-29 19:47:03 +0800
committerdinoex <dinoex@FreeBSD.org>2010-03-29 19:47:03 +0800
commit945ac244d887adae975493c13a1cdf09d38d4beb (patch)
tree4589d8587b709ab5733d03039ad078371488734b /math
parent1654e6dfcea80014125adf0054490f0908956c47 (diff)
downloadfreebsd-ports-gnome-945ac244d887adae975493c13a1cdf09d38d4beb.tar.gz
freebsd-ports-gnome-945ac244d887adae975493c13a1cdf09d38d4beb.tar.zst
freebsd-ports-gnome-945ac244d887adae975493c13a1cdf09d38d4beb.zip
- fix build for png-1.4.1
Diffstat (limited to 'math')
-rw-r--r--math/vtk/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/math/vtk/Makefile b/math/vtk/Makefile
index b1132fbe0df9..0236c1a7c433 100644
--- a/math/vtk/Makefile
+++ b/math/vtk/Makefile
@@ -133,6 +133,8 @@ do-configure:
patch-common:
@${FIND} ${VTKSRCDIR} -name "*.cxx" | ${XARGS} ${REINPLACE_CMD} -e \
's|malloc.h|stdlib.h|g'
+ @${REINPLACE_CMD} -e 's|png_set_gray_1_2_4_to_8|png_set_expand_gray_1_2_4_to_8|' \
+ ${VTKSRCDIR}/IO/vtkPNGReader.cxx
@${REINPLACE_CMD} -E 's|lib/vtk\)|lib\)|g' \
${VTKSRCDIR}/vtkGenerateVTKConfig.cmake
.if defined(WRAP)