aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorkevlo <kevlo@FreeBSD.org>2002-02-15 14:47:13 +0800
committerkevlo <kevlo@FreeBSD.org>2002-02-15 14:47:13 +0800
commit9d695eb61258c4d75f0e67355f4a206e201aa36e (patch)
tree0e73faec74d0b9b250e396ad60ebbfa074ff3c8a /math
parent24fb367e5411857201c08b059b770ac24fce324a (diff)
downloadfreebsd-ports-gnome-9d695eb61258c4d75f0e67355f4a206e201aa36e.tar.gz
freebsd-ports-gnome-9d695eb61258c4d75f0e67355f4a206e201aa36e.tar.zst
freebsd-ports-gnome-9d695eb61258c4d75f0e67355f4a206e201aa36e.zip
Initial import of Py-gsl 0.0.4
Py-gsl is the Python interface to GNU Scientific Library. PR: 34927 Submitted by: Hye-Shik Chang <perky@fallin.lv>
Diffstat (limited to 'math')
-rw-r--r--math/Makefile1
-rw-r--r--math/py-gsl/Makefile30
-rw-r--r--math/py-gsl/distinfo1
-rw-r--r--math/py-gsl/pkg-comment1
-rw-r--r--math/py-gsl/pkg-descr3
-rw-r--r--math/py-gsl/pkg-plist13
6 files changed, 49 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index d5924ef22458..77df205244ad 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -102,6 +102,7 @@
SUBDIR += pspp
SUBDIR += py-gato
SUBDIR += py-gnuplot
+ SUBDIR += py-gsl
SUBDIR += py-mpz
SUBDIR += py-numeric
SUBDIR += py-numeric17
diff --git a/math/py-gsl/Makefile b/math/py-gsl/Makefile
new file mode 100644
index 000000000000..97918dfed971
--- /dev/null
+++ b/math/py-gsl/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: py-gsl
+# Date created: 14 February 2002
+# Whom: Hye-Shik Chang <perky@fallin.lv>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gsl
+PORTVERSION= 0.0.4
+CATEGORIES= math python
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= pygsl
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= pygsl-${PORTVERSION}
+DIST_SUBDIR= python
+
+MAINTAINER= perky@fallin.lv
+
+LIB_DEPENDS= gsl.0:${PORTSDIR}/math/gsl
+
+PLIST_SUB= PYTHON_SITELIBDIR=${PYTHON_SITELIBDIR:S,^${LOCALBASE}/,,g}
+USE_PYTHON= yes
+
+do-build:
+ @cd ${WRKSRC} && ${PYTHON_CMD} setup.py build
+
+do-install:
+ @cd ${WRKSRC} && ${PYTHON_CMD} setup.py install
+
+.include <bsd.port.mk>
diff --git a/math/py-gsl/distinfo b/math/py-gsl/distinfo
new file mode 100644
index 000000000000..02dfab846a2e
--- /dev/null
+++ b/math/py-gsl/distinfo
@@ -0,0 +1 @@
+MD5 (python/pygsl-0.0.4.tar.gz) = 486c5bc4c0d2cd56ff84b41421d9f928
diff --git a/math/py-gsl/pkg-comment b/math/py-gsl/pkg-comment
new file mode 100644
index 000000000000..afe43f68bc30
--- /dev/null
+++ b/math/py-gsl/pkg-comment
@@ -0,0 +1 @@
+Python interface to GNU Scientific Library
diff --git a/math/py-gsl/pkg-descr b/math/py-gsl/pkg-descr
new file mode 100644
index 000000000000..1e7d7d6c9222
--- /dev/null
+++ b/math/py-gsl/pkg-descr
@@ -0,0 +1,3 @@
+Python interface to GNU Scientific Library
+
+WWW: http://sourceforge.net/projects/pygsl/
diff --git a/math/py-gsl/pkg-plist b/math/py-gsl/pkg-plist
new file mode 100644
index 000000000000..b6522327aa0d
--- /dev/null
+++ b/math/py-gsl/pkg-plist
@@ -0,0 +1,13 @@
+@cwd %%LOCALBASE%%
+%%PYTHON_SITELIBDIR%%/pygsl/__init__.py
+%%PYTHON_SITELIBDIR%%/pygsl/__init__.pyc
+%%PYTHON_SITELIBDIR%%/pygsl/_rng.so
+%%PYTHON_SITELIBDIR%%/pygsl/const.so
+%%PYTHON_SITELIBDIR%%/pygsl/errors.py
+%%PYTHON_SITELIBDIR%%/pygsl/errors.pyc
+%%PYTHON_SITELIBDIR%%/pygsl/ieee.so
+%%PYTHON_SITELIBDIR%%/pygsl/init.so
+%%PYTHON_SITELIBDIR%%/pygsl/rng.py
+%%PYTHON_SITELIBDIR%%/pygsl/rng.pyc
+%%PYTHON_SITELIBDIR%%/pygsl/sf.so
+@dirrm %%PYTHON_SITELIBDIR%%/pygsl