aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2016-07-10 01:11:52 +0800
committerjbeich <jbeich@FreeBSD.org>2016-07-10 01:11:52 +0800
commita6829aa73ebb935418d1e1d5fc67c568b77d7ae2 (patch)
treeba2b29deafcc8c1115a2fbe6d2bcde4e36e8eac3 /math
parent1747685a86494fea3d19bacc59a5ac76ea491200 (diff)
downloadfreebsd-ports-gnome-a6829aa73ebb935418d1e1d5fc67c568b77d7ae2.tar.gz
freebsd-ports-gnome-a6829aa73ebb935418d1e1d5fc67c568b77d7ae2.tar.zst
freebsd-ports-gnome-a6829aa73ebb935418d1e1d5fc67c568b77d7ae2.zip
math/py-pysparse: add new port
PR: 210595 Submitted by: yuri@rawbw.com PySparse extends the Python interpreter by a set of sparse matrix types holding double precision values. PySparse also includes modules that implement: - iterative methods for solving linear systems of equations - a set of standard preconditioners - an interface to a direct solver for sparse linear systems of equations (SuperLU) - a Jacobi-Davidson eigenvalue solver for the symmetric, generalised matrix eigenvalue problem (JDSYM) https://github.com/PythonOptimizers/pysparse
Diffstat (limited to 'math')
-rw-r--r--math/Makefile1
-rw-r--r--math/py-pysparse/Makefile32
-rw-r--r--math/py-pysparse/distinfo3
-rw-r--r--math/py-pysparse/files/patch-setup.py19
-rw-r--r--math/py-pysparse/pkg-descr12
5 files changed, 67 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index ba17796c97d3..14fc753fe2e1 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -620,6 +620,7 @@
SUBDIR += py-pyfst
SUBDIR += py-pyhull
SUBDIR += py-pymc
+ SUBDIR += py-pysparse
SUBDIR += py-pyvtk
SUBDIR += py-roman
SUBDIR += py-scientific
diff --git a/math/py-pysparse/Makefile b/math/py-pysparse/Makefile
new file mode 100644
index 000000000000..c2e3490ff34d
--- /dev/null
+++ b/math/py-pysparse/Makefile
@@ -0,0 +1,32 @@
+# Created by: Yuri Victorovich <yuri@rawbw.com>
+# $FreeBSD$
+
+PORTNAME= pysparse
+PORTVERSION= 1.3
+CATEGORIES= math python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= ${PORTNAME}-${PORTVERSION}-dev
+
+MAINTAINER= yuri@rawbw.com
+COMMENT= Fast sparse matrix library for Python
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}numpy>=1.2:math/py-numpy
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}numpy>=1.2:math/py-numpy
+LIB_DEPENDS= liblapack.so:math/lapack \
+ libblas.so:math/blas \
+ libopenblas.so:math/openblas \
+ libcblas.so:math/cblas
+
+USE_GITHUB= yes
+GH_ACCOUNT= PythonOptimizers
+GH_TAGNAME= f8430bd
+
+LDFLAGS+= -shared # Workaround for an obscure bug in py-numpy, see https://github.com/numpy/numpy/issues/7779
+
+USES= fortran python # fortran is needed for the correct build flags passed to py-numpy extension build process
+USE_PYTHON= distutils autoplist
+
+.include <bsd.port.mk>
diff --git a/math/py-pysparse/distinfo b/math/py-pysparse/distinfo
new file mode 100644
index 000000000000..c8aa1b6b5ff9
--- /dev/null
+++ b/math/py-pysparse/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1466932869
+SHA256 (pysparse-1.3-dev_GH0.tar.gz) = 4c4ad1e02a97ea257365331f677205c76e572d22eafbe818f39c4eb462987848
+SIZE (pysparse-1.3-dev_GH0.tar.gz) = 1301990
diff --git a/math/py-pysparse/files/patch-setup.py b/math/py-pysparse/files/patch-setup.py
new file mode 100644
index 000000000000..e81541a29f02
--- /dev/null
+++ b/math/py-pysparse/files/patch-setup.py
@@ -0,0 +1,19 @@
+--- setup.py.orig 2016-06-10 21:29:48 UTC
++++ setup.py
+@@ -109,7 +109,7 @@ def get_version():
+ version = '1.3'
+ release = False
+ if not release:
+- version += '-dev' + svn_version()
++ version += '-dev'
+ return version
+
+ def write_version_py(filename=os.path.join('pysparse', 'version.py')):
+@@ -142,7 +142,6 @@ def setup_package():
+ author_email = "{hamsel,d-orban,wd15}@sf.net,",
+ maintainer = "PySparse Developers",
+ maintainer_email = "{hamsel,d-orban,wd15}@sf.net,",
+- summary = "Fast sparse matrix library for Python",
+ description = "Fast sparse matrix library for Python",
+ long_description = "\n".join(DOCLINES[2:]),
+ url = "pysparse.sf.net",
diff --git a/math/py-pysparse/pkg-descr b/math/py-pysparse/pkg-descr
new file mode 100644
index 000000000000..fa2ca1aa38eb
--- /dev/null
+++ b/math/py-pysparse/pkg-descr
@@ -0,0 +1,12 @@
+PySparse extends the Python interpreter by a set of sparse matrix
+types holding double precision values. PySparse also includes modules
+that implement:
+
+- iterative methods for solving linear systems of equations
+- a set of standard preconditioners
+- an interface to a direct solver for sparse linear systems of
+ equations (SuperLU)
+- a Jacobi-Davidson eigenvalue solver for the symmetric, generalised
+ matrix eigenvalue problem (JDSYM)
+
+WWW: https://github.com/PythonOptimizers/pysparse