aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authortota <tota@FreeBSD.org>2015-08-12 03:50:39 +0800
committertota <tota@FreeBSD.org>2015-08-12 03:50:39 +0800
commita7934864b033cf2ac3ee96f49d7a16b4c34e10b7 (patch)
tree836b0fa684ff28a757cc8989a993a095c9869c79 /math
parent480e61142bea85f2fa24d0f81dd4829fa000f620 (diff)
downloadfreebsd-ports-gnome-a7934864b033cf2ac3ee96f49d7a16b4c34e10b7.tar.gz
freebsd-ports-gnome-a7934864b033cf2ac3ee96f49d7a16b4c34e10b7.tar.zst
freebsd-ports-gnome-a7934864b033cf2ac3ee96f49d7a16b4c34e10b7.zip
- Add new port: math/R-cran-NMF
Provides a framework to perform Non-negative Matrix Factorization (NMF). The package implements a set of already published algorithms and seeding methods, and provides a framework to test, develop and plug new/custom algorithms. Most of the built-in algorithms have been optimized in C++, and the main interface function provides an easy way of performing parallel computations on multicore machines. WWW: https://cran.r-project.org/web/packages/NMF/
Diffstat (limited to 'math')
-rw-r--r--math/Makefile1
-rw-r--r--math/R-cran-NMF/Makefile30
-rw-r--r--math/R-cran-NMF/distinfo2
-rw-r--r--math/R-cran-NMF/pkg-descr8
4 files changed, 41 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 86c935719191..643b9672ff3f 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -11,6 +11,7 @@
SUBDIR += R-cran-KFAS
SUBDIR += R-cran-LearnBayes
SUBDIR += R-cran-MCMCpack
+ SUBDIR += R-cran-NMF
SUBDIR += R-cran-RHmm
SUBDIR += R-cran-RSvgDevice
SUBDIR += R-cran-RcppArmadillo
diff --git a/math/R-cran-NMF/Makefile b/math/R-cran-NMF/Makefile
new file mode 100644
index 000000000000..8e50e759593e
--- /dev/null
+++ b/math/R-cran-NMF/Makefile
@@ -0,0 +1,30 @@
+# Created by: TAKATSU Tomonari <tota@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= NMF
+PORTVERSION= 0.20.6
+CATEGORIES= math
+DISTNAME= ${PORTNAME}_${PORTVERSION}
+
+MAINTAINER= tota@FreeBSD.org
+COMMENT= Algorithms and Framework for Nonnegative Matrix Factorization
+
+LICENSE= GPLv2 GPLv3
+LICENSE_COMB= dual
+
+RUN_DEPENDS= R-cran-pkgmaker>=0.20:${PORTSDIR}/devel/R-cran-pkgmaker \
+ R-cran-registry>0:${PORTSDIR}/devel/R-cran-registry \
+ R-cran-rngtools>=1.2.3:${PORTSDIR}/devel/R-cran-rngtools \
+ R-cran-stringr>=1.0.0:${PORTSDIR}/textproc/R-cran-stringr \
+ R-cran-digest>0:${PORTSDIR}/security/R-cran-digest \
+ R-cran-gridBase>0:${PORTSDIR}/graphics/R-cran-gridBase \
+ R-cran-colorspace>0:${PORTSDIR}/graphics/R-cran-colorspace \
+ R-cran-RColorBrewer>0:${PORTSDIR}/graphics/R-cran-RColorBrewer \
+ R-cran-foreach>0:${PORTSDIR}/devel/R-cran-foreach \
+ R-cran-doParallel>0:${PORTSDIR}/devel/R-cran-doParallel \
+ R-cran-ggplot2>0:${PORTSDIR}/graphics/R-cran-ggplot2 \
+ R-cran-reshape2>0:${PORTSDIR}/devel/R-cran-reshape2
+
+USES= cran:auto-plist
+
+.include <bsd.port.mk>
diff --git a/math/R-cran-NMF/distinfo b/math/R-cran-NMF/distinfo
new file mode 100644
index 000000000000..f1dcad51d95c
--- /dev/null
+++ b/math/R-cran-NMF/distinfo
@@ -0,0 +1,2 @@
+SHA256 (NMF_0.20.6.tar.gz) = dfccd4b4d6ec90cd7628fd128d2456d792f406cee4d32b13448dcb0ffe4ab056
+SIZE (NMF_0.20.6.tar.gz) = 1764466
diff --git a/math/R-cran-NMF/pkg-descr b/math/R-cran-NMF/pkg-descr
new file mode 100644
index 000000000000..f1f0e0911d4e
--- /dev/null
+++ b/math/R-cran-NMF/pkg-descr
@@ -0,0 +1,8 @@
+Provides a framework to perform Non-negative Matrix Factorization
+(NMF). The package implements a set of already published algorithms
+and seeding methods, and provides a framework to test, develop and
+plug new/custom algorithms. Most of the built-in algorithms have
+been optimized in C++, and the main interface function provides an
+easy way of performing parallel computations on multicore machines.
+
+WWW: https://cran.r-project.org/web/packages/NMF/