aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorclsung <clsung@FreeBSD.org>2007-04-07 11:02:00 +0800
committerclsung <clsung@FreeBSD.org>2007-04-07 11:02:00 +0800
commitb2f3564c5f95a2b849a73ca6edd1d3ea0405b555 (patch)
tree5f236b2bb28d604334ac17affc645a8961939163 /math
parent02e50df62e58b5a1edceb17bfb1bad44a519375b (diff)
downloadfreebsd-ports-gnome-b2f3564c5f95a2b849a73ca6edd1d3ea0405b555.tar.gz
freebsd-ports-gnome-b2f3564c5f95a2b849a73ca6edd1d3ea0405b555.tar.zst
freebsd-ports-gnome-b2f3564c5f95a2b849a73ca6edd1d3ea0405b555.zip
Regression.pm is a multivariate linear regression package.
That is, it estimates the c coefficients for a line-fit of the type y= c(0)*x(0) + c(1)*x1 + c(2)*x2 + ... + c(k)*xk given a data set of N observations, each with k independent x variables and one y variable. Naturally, N must be greater than k---and preferably considerably greater. Any reasonable undergraduate statistics book will explain what a regression is. Most of the time, the user will provide a constant ('1') as x(0) for each observation in order to allow the regression package to fit an intercept. WWW: http://search.cpan.org/dist/Statistics-Regression/
Diffstat (limited to 'math')
-rw-r--r--math/Makefile1
-rw-r--r--math/p5-Statistics-Regression/Makefile22
-rw-r--r--math/p5-Statistics-Regression/distinfo3
-rw-r--r--math/p5-Statistics-Regression/pkg-descr13
-rw-r--r--math/p5-Statistics-Regression/pkg-plist5
5 files changed, 44 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 93723dff8255..e2ab6bf294e7 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -266,6 +266,7 @@
SUBDIR += p5-Statistics-LineFit
SUBDIR += p5-Statistics-Lite
SUBDIR += p5-Statistics-OLS
+ SUBDIR += p5-Statistics-Regression
SUBDIR += p5-Task-Math-Symbolic
SUBDIR += pari
SUBDIR += parmetis
diff --git a/math/p5-Statistics-Regression/Makefile b/math/p5-Statistics-Regression/Makefile
new file mode 100644
index 000000000000..22cbcc77b4b9
--- /dev/null
+++ b/math/p5-Statistics-Regression/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: math/p5-Statistics-Regression
+# Date created: Apr 7, 2007
+# Whom: Cheng-Lung Sung <clsung@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Statistics-Regression
+PORTVERSION= 0.50
+CATEGORIES= math perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Statistics
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= clsung@FreeBSD.org
+COMMENT= Perl module to perform weighted linear regression
+
+PERL_CONFIGURE= yes
+
+MAN3= Statistics::Regression.3
+
+.include <bsd.port.mk>
diff --git a/math/p5-Statistics-Regression/distinfo b/math/p5-Statistics-Regression/distinfo
new file mode 100644
index 000000000000..cd64e17d9b34
--- /dev/null
+++ b/math/p5-Statistics-Regression/distinfo
@@ -0,0 +1,3 @@
+MD5 (Statistics-Regression-0.50.tar.gz) = 4930f08a214ec91243b6846d9ddbe5fe
+SHA256 (Statistics-Regression-0.50.tar.gz) = 2bbf3310ad95ac942a7b7f666c1e1dbc8a8286b542ce727ba35d69daad56a7e3
+SIZE (Statistics-Regression-0.50.tar.gz) = 22268
diff --git a/math/p5-Statistics-Regression/pkg-descr b/math/p5-Statistics-Regression/pkg-descr
new file mode 100644
index 000000000000..e7b40725d355
--- /dev/null
+++ b/math/p5-Statistics-Regression/pkg-descr
@@ -0,0 +1,13 @@
+Regression.pm is a multivariate linear regression package.
+That is, it estimates the c coefficients for a line-fit of the type
+
+ y= c(0)*x(0) + c(1)*x1 + c(2)*x2 + ... + c(k)*xk
+
+given a data set of N observations, each with k independent x variables
+and one y variable. Naturally, N must be greater than k---and preferably
+considerably greater. Any reasonable undergraduate statistics book will
+explain what a regression is. Most of the time, the user will provide a
+constant ('1') as x(0) for each observation in order to allow the
+regression package to fit an intercept.
+
+WWW: http://search.cpan.org/dist/Statistics-Regression/
diff --git a/math/p5-Statistics-Regression/pkg-plist b/math/p5-Statistics-Regression/pkg-plist
new file mode 100644
index 000000000000..3998a1c4fc0e
--- /dev/null
+++ b/math/p5-Statistics-Regression/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Statistics/Regression/.packlist
+%%SITE_PERL%%/Statistics/Regression.pm
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Statistics/Regression
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Statistics
+@dirrmtry %%SITE_PERL%%/Statistics