aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authormaho <maho@FreeBSD.org>2006-08-07 09:40:52 +0800
committermaho <maho@FreeBSD.org>2006-08-07 09:40:52 +0800
commitb8e5abf06a35c36816f04fad01fa4044a0fbc91e (patch)
treeae61bc907c9e06176e81f8a25eaba39347b8b722 /math
parent277ee9377c4414477eac83f70aa1f872c889eb1e (diff)
downloadfreebsd-ports-gnome-b8e5abf06a35c36816f04fad01fa4044a0fbc91e.tar.gz
freebsd-ports-gnome-b8e5abf06a35c36816f04fad01fa4044a0fbc91e.tar.zst
freebsd-ports-gnome-b8e5abf06a35c36816f04fad01fa4044a0fbc91e.zip
Fix error when WITH_OPTIMIZED_FLAGS is specified.
PR: 100991 Submitted by: Masayuki Takemura <ICG04984@nifty.com>
Diffstat (limited to 'math')
-rw-r--r--math/atlas-devel/Makefile4
-rw-r--r--math/atlas/Makefile4
2 files changed, 8 insertions, 0 deletions
diff --git a/math/atlas-devel/Makefile b/math/atlas-devel/Makefile
index ac69c0ad1e53..8f584c50fbdc 100644
--- a/math/atlas-devel/Makefile
+++ b/math/atlas-devel/Makefile
@@ -35,7 +35,11 @@ USE_GCC=3.4
# only affects for lapack sub project
.if defined(WITH_OPTIMIZED_FLAGS)
+.if defined(CPUTYPE)
FFLAGS+= -mtune=${CPUTYPE} -pipe -O2 -ffast-math -fomit-frame-pointer
+.else
+FFLAGS+= -pipe -O2 -ffast-math -fomit-frame-pointer
+.endif
.endif
post-patch:
diff --git a/math/atlas/Makefile b/math/atlas/Makefile
index c63854e4b599..5625f37aea05 100644
--- a/math/atlas/Makefile
+++ b/math/atlas/Makefile
@@ -35,7 +35,11 @@ USE_GCC=3.4
# only affects for lapack sub project
.if defined(WITH_OPTIMIZED_FLAGS)
+.if defined(CPUTYPE)
FFLAGS+= -mtune=${CPUTYPE} -pipe -O2 -ffast-math -fomit-frame-pointer
+.else
+FFLAGS+= -pipe -O2 -ffast-math -fomit-frame-pointer
+.endif
.endif
post-patch: