aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorkoobs <koobs@FreeBSD.org>2013-12-14 14:44:38 +0800
committerkoobs <koobs@FreeBSD.org>2013-12-14 14:44:38 +0800
commitb95bd249f3ab218448561a48fb48ae6aabcb62b8 (patch)
tree3862c9b85888a83c095703d869f3dd5da6352463 /math
parente2904f20e95ead765d489a1126ae0e7a4e25450c (diff)
downloadfreebsd-ports-gnome-b95bd249f3ab218448561a48fb48ae6aabcb62b8.tar.gz
freebsd-ports-gnome-b95bd249f3ab218448561a48fb48ae6aabcb62b8.tar.zst
freebsd-ports-gnome-b95bd249f3ab218448561a48fb48ae6aabcb62b8.zip
math/py-numpy: Fix static library check that assumes atlas is installed
- Use BUILD_DEPENDS to check for the atlas static library at pre-build time instead of checking if the file exists (False if atlas is not installed) - Replace IGNORE with a message to the user notifying them that an atlas install WITH_STATIC is needed, and provide clues as possible actions without being too prescriptive. As discussed with eadler@, a correct resolution to "ports depending on other ports with specific OPTIONS" is either an atlas slave port (ie: atlas-static), or to modify atlas to install both shared and static libraries. This change is a net gain on the existing broken behaviour, by fixing the check, while retaining the user notification. PR: ports/178094 Reviewed by: jhibbits, eadler Approved by: maintainer timeout (7+ months)
Diffstat (limited to 'math')
-rw-r--r--math/py-numpy/Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/math/py-numpy/Makefile b/math/py-numpy/Makefile
index 6b5706697d22..0b72aaf4e2c3 100644
--- a/math/py-numpy/Makefile
+++ b/math/py-numpy/Makefile
@@ -56,9 +56,14 @@ DISTFILES+= ${FP_ARCH}/fenv.c?p=203441:fp ${FP_ARCH}/fenv.h?p=203441:fp
.if ${PORT_OPTIONS:MATLAS}
LIB_DEPENDS+= atlas.2:${PORTSDIR}/math/atlas
-.if !exists(${LOCALBASE}/lib/libalapack.a)
-IGNORE= atlas needs to be built with WITH_STATIC for numpy to function properly
-.endif
+BUILD_DEPENDS+= ${LOCALBASE}/lib/libalapack.a
+@${ECHO_MSG}
+@${ECHO_MSG} "Atlas *must* be built with the WITH_STATIC option"
+@${ECHO_MSG} "for numpy to function correctly. Ensure it is"
+@${ECHO_MSG} "selected in the configuration dialog when prompted, or"
+@${ECHO_MSG} "Ctrl-C now and reinstall the atlas port with the option"
+@${ECHO_MSG} "enabled.
+sleep 5
.else
LIB_DEPENDS+= lapack.4:${PORTSDIR}/math/lapack \
blas.2:${PORTSDIR}/math/blas