aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorak <ak@FreeBSD.org>2013-04-25 02:10:30 +0800
committerak <ak@FreeBSD.org>2013-04-25 02:10:30 +0800
commitbd9e313d10d3c51dbd0716acbbf2cbcd4b33000e (patch)
tree5883afe298a5f232e854b104fc944ca19c4f7e7f /math
parent2e4755fb165fc85b66abbd26d0129a688b4273da (diff)
downloadfreebsd-ports-gnome-bd9e313d10d3c51dbd0716acbbf2cbcd4b33000e.tar.gz
freebsd-ports-gnome-bd9e313d10d3c51dbd0716acbbf2cbcd4b33000e.tar.zst
freebsd-ports-gnome-bd9e313d10d3c51dbd0716acbbf2cbcd4b33000e.zip
- Convert USE_GETTEXT to USES (part 3)
Approved by: portmgr (bapt)
Diffstat (limited to 'math')
-rw-r--r--math/R/Makefile2
-rw-r--r--math/drgeo/Makefile2
-rw-r--r--math/fricas/Makefile2
-rw-r--r--math/giacxcas/Makefile2
-rw-r--r--math/open-axiom/Makefile2
-rw-r--r--math/pspp/Makefile2
-rw-r--r--math/qalculate/Makefile2
-rw-r--r--math/rkward/Makefile2
-rw-r--r--math/scilab/Makefile2
-rw-r--r--math/tablix/Makefile2
-rw-r--r--math/wxMaxima/Makefile2
11 files changed, 11 insertions, 11 deletions
diff --git a/math/R/Makefile b/math/R/Makefile
index 95722c298aab..0ee0b6c88a7b 100644
--- a/math/R/Makefile
+++ b/math/R/Makefile
@@ -146,7 +146,7 @@ CONFIGURE_ARGS+= --without-ICU
.endif
.if ${PORT_OPTIONS:MNLS}
-USE_GETTEXT= yes
+USES+= gettext
PLIST_SUB+= NLS=""
.else
CONFIGURE_ARGS+= --disable-nls
diff --git a/math/drgeo/Makefile b/math/drgeo/Makefile
index 7d777559e877..3578b12f8d02 100644
--- a/math/drgeo/Makefile
+++ b/math/drgeo/Makefile
@@ -16,7 +16,7 @@ COMMENT= GTK interactive geometry software
LIB_DEPENDS= guile.21:${PORTSDIR}/lang/guile
-USE_GETTEXT= yes
+USES= gettext
USE_GNOME= gnomehack gnomeprefix intlhack libglade2
USE_GMAKE= yes
GNU_CONFIGURE= yes
diff --git a/math/fricas/Makefile b/math/fricas/Makefile
index 43e28e8cac08..da2bc50edb0f 100644
--- a/math/fricas/Makefile
+++ b/math/fricas/Makefile
@@ -21,7 +21,7 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
USE_BZIP2= yes
USE_XORG= x11 ice sm xpm
USE_ICONV= yes
-USE_GETTEXT= yes
+USES= gettext
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-lisp=sbcl
diff --git a/math/giacxcas/Makefile b/math/giacxcas/Makefile
index f717545d9601..4326b9e8da8f 100644
--- a/math/giacxcas/Makefile
+++ b/math/giacxcas/Makefile
@@ -31,7 +31,7 @@ USE_GMAKE= yes
USE_GL= gl
USE_XORG= xcursor xft xi
USE_LDCONFIG= yes
-USE_GETTEXT= yes
+USES= gettext
MAKE_JOBS_SAFE= yes
DOCSDIR= ${PREFIX}/share/doc/giac
diff --git a/math/open-axiom/Makefile b/math/open-axiom/Makefile
index f1f2172d2d2b..ff0638ed3528 100644
--- a/math/open-axiom/Makefile
+++ b/math/open-axiom/Makefile
@@ -18,7 +18,7 @@ CONFIGURE_ARGS= --with-lisp=sbcl
USE_GMAKE= yes
USE_XORG= x11 ice sm xpm
USE_ICONV= yes
-USE_GETTEXT= yes
+USES= gettext
MAKE_JOBS_UNSAFE=yes
CFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib
diff --git a/math/pspp/Makefile b/math/pspp/Makefile
index 39e64483ada8..60b2b41dd5f7 100644
--- a/math/pspp/Makefile
+++ b/math/pspp/Makefile
@@ -30,7 +30,7 @@ LDFLAGS+= -L${LOCALBASE}/lib
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MNLS}
-USE_GETTEXT= yes
+USES+= gettext
PLIST_SUB+= NLS=""
.else
CONFIGURE_ARGS+= --disable-nls
diff --git a/math/qalculate/Makefile b/math/qalculate/Makefile
index 3443a4e466c2..a224deb94e70 100644
--- a/math/qalculate/Makefile
+++ b/math/qalculate/Makefile
@@ -20,7 +20,7 @@ RUN_DEPENDS= gnuplot:${PORTSDIR}/math/gnuplot \
wget:${PORTSDIR}/ftp/wget
USE_GNOME= gnomehack gnomeprefix intlhack libglade2 libgnome
-USE_GETTEXT= yes
+USES= gettext
USE_GMAKE= yes
GNU_CONFIGURE= yes
INSTALLS_OMF= yes
diff --git a/math/rkward/Makefile b/math/rkward/Makefile
index 015e162e9f58..15a97e0a52f9 100644
--- a/math/rkward/Makefile
+++ b/math/rkward/Makefile
@@ -19,7 +19,7 @@ CONFLICTS= rkward-kde4-0.5.*
USE_KDELIBS_VER=3
USE_PHP= yes
WANT_PHP_CLI= yes
-USE_GETTEXT= yes
+USES= gettext
USE_AUTOTOOLS= libtool
CONFIGURE_ENV= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
PTHREAD_LIBS="${PTHREAD_LIBS}"
diff --git a/math/scilab/Makefile b/math/scilab/Makefile
index a9bc92d820b8..b748e03e4d7b 100644
--- a/math/scilab/Makefile
+++ b/math/scilab/Makefile
@@ -24,7 +24,7 @@ LIB_DEPENDS= xml2.5:${PORTSDIR}/textproc/libxml2 \
MAKE_JOBS_SAFE= yes
USE_FORTRAN= yes
-USE_GETTEXT= yes
+USES= gettext
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_LDCONFIG= yes
diff --git a/math/tablix/Makefile b/math/tablix/Makefile
index 869a3a9995b3..29d9af49a66e 100644
--- a/math/tablix/Makefile
+++ b/math/tablix/Makefile
@@ -23,7 +23,7 @@ PVM_ROOT= ${PREFIX}/lib/pvm
USE_GMAKE= yes
USE_GNOME= libxml2
GNU_CONFIGURE= yes
-USE_GETTEXT= yes
+USES= gettext
CONFIGURE_ENV= LIBS=-L${PREFIX}/lib \
PVM_ROOT=${PVM_ROOT} PVM_LIB=${PREFIX}/lib
diff --git a/math/wxMaxima/Makefile b/math/wxMaxima/Makefile
index 3cd5d241954c..98eda8a21351 100644
--- a/math/wxMaxima/Makefile
+++ b/math/wxMaxima/Makefile
@@ -16,7 +16,7 @@ LICENSE= GPLv2
RUN_DEPENDS= maxima:${PORTSDIR}/math/maxima
-USE_GETTEXT= yes
+USES= gettext
USE_GNOME= desktopfileutils libxml2
USE_WX= 2.8
WX_COMPS= wx