aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2013-03-22 22:18:02 +0800
committermakc <makc@FreeBSD.org>2013-03-22 22:18:02 +0800
commitcdb81da9cb2b58e688594b552337d1c9bfc47e96 (patch)
treeda82a32e8ce2ded995ae7ba320231491c35220ac /math
parent904fc890d1dc712abfaeaddde7864519df50915c (diff)
downloadfreebsd-ports-gnome-cdb81da9cb2b58e688594b552337d1c9bfc47e96.tar.gz
freebsd-ports-gnome-cdb81da9cb2b58e688594b552337d1c9bfc47e96.tar.zst
freebsd-ports-gnome-cdb81da9cb2b58e688594b552337d1c9bfc47e96.zip
Mk/bsd.kde4.mk:
- Don't set CMAKE_BUILD_TYPE for debug builds (cmake.mk already handles it) - Don't set WITH_DEBUG for unstable branch (KDE4_BRANCH) - Remove now useless KDE4_BUILDENV KDE SC ports: - Chase KDE4_BUILDENV removal: replace 'KDE4_BUILDENV= yes' with 'USES= cmake:outsource' and add USE_LDCONFIG if needed
Diffstat (limited to 'math')
-rw-r--r--math/analitza/Makefile3
-rw-r--r--math/cantor/Makefile3
-rw-r--r--math/kalgebra/Makefile2
-rw-r--r--math/kbruch/Makefile2
-rw-r--r--math/kcalc/Makefile2
-rw-r--r--math/kig/Makefile2
-rw-r--r--math/kmplot/Makefile2
-rw-r--r--math/rocs/Makefile3
8 files changed, 11 insertions, 8 deletions
diff --git a/math/analitza/Makefile b/math/analitza/Makefile
index 5d7de535c386..aa42f6fd44c2 100644
--- a/math/analitza/Makefile
+++ b/math/analitza/Makefile
@@ -14,8 +14,9 @@ CONFLICTS_INSTALL= kalgebra-4.7.* kdeedu-4.[0-6].*
USE_XZ= yes
USE_KDE4= kdehier kdelibs kdeprefix automoc4
-KDE4_BUILDENV= yes
+USES= cmake:outsource
USE_QT4= moc_build qmake_build rcc_build uic_build
+USE_LDCONFIG= yes
MAKE_JOBS_SAFE= yes
.include <bsd.port.mk>
diff --git a/math/cantor/Makefile b/math/cantor/Makefile
index 6d043105082f..de0448b1ca9e 100644
--- a/math/cantor/Makefile
+++ b/math/cantor/Makefile
@@ -17,10 +17,11 @@ LIB_DEPENDS= spectre.1:${PORTSDIR}/print/libspectre \
CONFLICTS= kdeedu-4.[0-6].*
USE_KDE4= kdehier kdelibs kdeprefix automoc4
-KDE4_BUILDENV= yes
+USES= cmake:outsource
USE_QT4= qtestlib_build xmlpatterns \
moc_build qmake_build rcc_build uic_build
USE_XZ= yes
+USE_LDCONFIG= yes
MAKE_JOBS_SAFE= yes
OPTIONS_DEFINE= MAXIMA OCTAVE R
diff --git a/math/kalgebra/Makefile b/math/kalgebra/Makefile
index f05cbb68e4b3..94b34a4b5dfc 100644
--- a/math/kalgebra/Makefile
+++ b/math/kalgebra/Makefile
@@ -17,7 +17,7 @@ CONFLICTS= kdeedu-4.[0-6].*
CMAKE_ARGS= -DBUILD_mobile:BOOL=FALSE
USE_GL= glu
USE_KDE4= kdehier kdelibs kdeprefix libkdeedu automoc4
-KDE4_BUILDENV= yes
+USES= cmake:outsource
USE_QT4= gui opengl script scripttools xml \
moc_build qmake_build rcc_build uic_build
USE_XZ= yes
diff --git a/math/kbruch/Makefile b/math/kbruch/Makefile
index 04c662c1e65c..ff5660cf9e61 100644
--- a/math/kbruch/Makefile
+++ b/math/kbruch/Makefile
@@ -13,7 +13,7 @@ COMMENT= KDE 4 application to exercise fractions
CONFLICTS= kdeedu-4.[0-6].*
USE_KDE4= kdehier kdelibs kdeprefix automoc4
-KDE4_BUILDENV= yes
+USES= cmake:outsource
USE_QT4= corelib moc_build qmake_build rcc_build uic_build
USE_XZ= yes
MAKE_JOBS_SAFE= yes
diff --git a/math/kcalc/Makefile b/math/kcalc/Makefile
index 048c93a47848..e1a732a26bb7 100644
--- a/math/kcalc/Makefile
+++ b/math/kcalc/Makefile
@@ -17,7 +17,7 @@ CONFLICTS_INSTALL= kdeutils-4.[0-7].*
USE_XZ= yes
USE_KDE4= kdeprefix kdehier automoc4 kdelibs
-KDE4_BUILDENV= yes
+USES= cmake:outsource
USE_QT4= qmake_build moc_build rcc_build uic_build
MAKE_JOBS_SAFE= yes
diff --git a/math/kig/Makefile b/math/kig/Makefile
index 96ee3ca37511..c84dd6686ed7 100644
--- a/math/kig/Makefile
+++ b/math/kig/Makefile
@@ -13,7 +13,7 @@ COMMENT= KDE 4 interactive geometry application
CONFLICTS= kdeedu-4.[0-6].*
USE_KDE4= kdehier kdelibs kdeprefix automoc4
-KDE4_BUILDENV= yes
+USES= cmake:outsource
USE_QT4= dbus moc_build qmake_build rcc_build uic_build
USE_XZ= yes
MAKE_JOBS_SAFE= yes
diff --git a/math/kmplot/Makefile b/math/kmplot/Makefile
index 4a9457d58751..fd35e75487f4 100644
--- a/math/kmplot/Makefile
+++ b/math/kmplot/Makefile
@@ -13,7 +13,7 @@ COMMENT= Mathematical function plotter for KDE 4
CONFLICTS= kdeedu-4.[0-6].*
USE_KDE4= kdehier kdelibs kdeprefix automoc4
-KDE4_BUILDENV= yes
+USES= cmake:outsource
USE_QT4= xml moc_build qmake_build rcc_build uic_build
USE_XZ= yes
MAKE_JOBS_SAFE= yes
diff --git a/math/rocs/Makefile b/math/rocs/Makefile
index d4d622d71e72..b8de638150b6 100644
--- a/math/rocs/Makefile
+++ b/math/rocs/Makefile
@@ -15,10 +15,11 @@ LIB_DEPENDS= boost_thread:${PORTSDIR}/devel/boost-libs
CONFLICTS= kdeedu-4.[0-6].*
USE_KDE4= kdehier kdelibs kdeprefix automoc4
-KDE4_BUILDENV= yes
+USES= cmake:outsource
USE_QT4= script scripttools \
moc_build qmake_build rcc_build uic_build
USE_XZ= yes
+USE_LDCONFIG= yes
MAKE_JOBS_SAFE= yes
.include <bsd.port.mk>