aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorthierry <thierry@FreeBSD.org>2006-05-16 04:57:41 +0800
committerthierry <thierry@FreeBSD.org>2006-05-16 04:57:41 +0800
commitd7895a666c554f2093923bf1ab7e49154efc3091 (patch)
treeb85cea738e9aaedb85748911a53b4432771bc495 /math
parent9cdaa7f8a432824a334d319d1846ce47ed7df729 (diff)
downloadfreebsd-ports-gnome-d7895a666c554f2093923bf1ab7e49154efc3091.tar.gz
freebsd-ports-gnome-d7895a666c554f2093923bf1ab7e49154efc3091.tar.zst
freebsd-ports-gnome-d7895a666c554f2093923bf1ab7e49154efc3091.zip
Upgrade to 2.7-1.
Diffstat (limited to 'math')
-rw-r--r--math/freefem++/Makefile8
-rw-r--r--math/freefem++/distinfo6
-rw-r--r--math/freefem++/files/patch-src_Makefile.in16
3 files changed, 15 insertions, 15 deletions
diff --git a/math/freefem++/Makefile b/math/freefem++/Makefile
index 1fab4fe9b783..4a517277c61a 100644
--- a/math/freefem++/Makefile
+++ b/math/freefem++/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= freefem++
-PORTVERSION= 2.7
-PORTREVISION= 2
+DISTVERSION= 2.7-1
CATEGORIES= math science
MASTER_SITES= http://www.freefem.org/ff++/ftp/
@@ -42,7 +41,7 @@ CONFIGURE_ARGS= --disable-download \
--with-umfpack="-lumfpack" \
--with-arpack="${LIBARPACK}"
CONFIGURE_ENV= CPPFLAGS="${MPICFLAGS} -I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
- LDFLAGS="${MPILDFLAGS} -L${LOCALBASE}/lib ${PTHREAD_LIBS}"
+ LDFLAGS="${MPILDFLAGS} -L${LOCALBASE}/lib -L${X11BASE}/lib ${PTHREAD_LIBS}"
LIBBLAS= -lf2c -lf77blas -latlas -lgslcblas
LIBARPACK= -larpack -lalapack ${LIBBLAS}
@@ -70,6 +69,7 @@ RUN_DEPENDS+= ${LOCALBASE}/mpich/bin/mpiCC:${PORTSDIR}/net/mpich
MPICFLAGS= -I${LOCALBASE}/mpich/include
MPILDFLAGS= -L${LOCALBASE}/mpich/lib
CONFIGURE_ENV+= PATH="$$PATH:${LOCALBASE}/mpich/bin"
+CONFIGURE_ARGS+= --with-mpi=yes
PLIST_SUB+= MPI=""
.else
PLIST_SUB+= MPI="@comment "
@@ -77,7 +77,7 @@ PLIST_SUB+= MPI="@comment "
pre-configure:
@${REINPLACE_CMD} -e "s|-lpthread|${PTHREAD_LIBS}|g" \
- -e "s|mpiCC.|${LOCALBASE}/mpich/bin/mpiCC|" \
+ -e "s|=mpiCC|=${LOCALBASE}/mpich/bin/mpiCC|" \
-e "s|/usr/X11R6|${X11BASE}|g" \
${WRKSRC}/${CONFIGURE_SCRIPT}
@${REINPLACE_CMD} -e "s|mpiCC|${LOCALBASE}/mpich/bin/mpiCC|" \
diff --git a/math/freefem++/distinfo b/math/freefem++/distinfo
index 7036aada4a74..8879c3bcefb2 100644
--- a/math/freefem++/distinfo
+++ b/math/freefem++/distinfo
@@ -1,3 +1,3 @@
-MD5 (freefem++-2.7.tar.gz) = 56a32247ae73165b3fd8be5fd3754bc5
-SHA256 (freefem++-2.7.tar.gz) = 3b6f257f856d7471b2957149bbc02ce4ab033467ea4a44ec0186e0408fe0f060
-SIZE (freefem++-2.7.tar.gz) = 10596982
+MD5 (freefem++-2.7-1.tar.gz) = 0ee89b009e8c53c24f2c044b0f77cbd5
+SHA256 (freefem++-2.7-1.tar.gz) = 9af01881489bb0eaaa7e59f45171df3c643a62490ce8aba50429d57f3672efc7
+SIZE (freefem++-2.7-1.tar.gz) = 10569329
diff --git a/math/freefem++/files/patch-src_Makefile.in b/math/freefem++/files/patch-src_Makefile.in
index 880e4401f78a..5e154e3ba5f1 100644
--- a/math/freefem++/files/patch-src_Makefile.in
+++ b/math/freefem++/files/patch-src_Makefile.in
@@ -1,13 +1,13 @@
---- src/Makefile.in.orig Tue Apr 11 23:08:53 2006
-+++ src/Makefile.in Tue Apr 11 23:58:23 2006
-@@ -208,8 +208,9 @@
- sharedstatedir = @sharedstatedir@
- sysconfdir = @sysconfdir@
- target_alias = @target_alias@
+--- src/Makefile.in.orig Mon May 15 19:03:38 2006
++++ src/Makefile.in Mon May 15 21:13:28 2006
+@@ -150,8 +150,9 @@
+ ff_wget = @ff_wget@
+ install_sh = @install_sh@
+
+# FreeBSD patch: don't install bamg, which is available as math/bamg
SUBDIRS = bamglib femlib iml Graphics Algo umfpack lglib fflib std x11 \
-nw mpi agl glx ide bamg bin-win32
-+nw mpi agl glx ide bin-win32
++nw mpi agl glx ide bin-win32
EXTRA_DIST = FreeFem++-CoCoa Carbon.r
- all: all-recursive
+ subdir = src