aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2005-02-10 05:51:33 +0800
committerpav <pav@FreeBSD.org>2005-02-10 05:51:33 +0800
commite562a502480267a2efacdc49975f11d6cf4fb437 (patch)
tree6178891dc7a52b8edc61acd3c863355f907179b2 /math
parent581fe010d878f33866cb16dd061845f1eac9ea0c (diff)
downloadfreebsd-ports-gnome-e562a502480267a2efacdc49975f11d6cf4fb437.tar.gz
freebsd-ports-gnome-e562a502480267a2efacdc49975f11d6cf4fb437.tar.zst
freebsd-ports-gnome-e562a502480267a2efacdc49975f11d6cf4fb437.zip
Worldforge math library. The primary focus of WFMath is geometric objects.
Thus, it includes several shapes (boxes, balls, lines), in addition to the basic math objects that are used to build these shapes (points, vectors, matricies). PR: ports/77046 Submitted by: jannisan@t-online.de (Jan Rochel)
Diffstat (limited to 'math')
-rw-r--r--math/Makefile1
-rw-r--r--math/wfmath/Makefile30
-rw-r--r--math/wfmath/distinfo2
-rw-r--r--math/wfmath/files/patch-Makefile.in19
-rw-r--r--math/wfmath/pkg-descr9
-rw-r--r--math/wfmath/pkg-plist40
6 files changed, 101 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 871d291a4c1c..bf1e4d419f9c 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -254,6 +254,7 @@
SUBDIR += vtk-java
SUBDIR += vtk-python
SUBDIR += vtk-tcl
+ SUBDIR += wfmath
SUBDIR += wingz
SUBDIR += wingz3
SUBDIR += wmcalc
diff --git a/math/wfmath/Makefile b/math/wfmath/Makefile
new file mode 100644
index 000000000000..363eb3e6b20a
--- /dev/null
+++ b/math/wfmath/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: wfmath
+# Date created: 3 February 2005
+# Whom: Janni
+#
+# $FreeBSD$
+#
+
+PORTNAME= wfmath
+PORTVERSION= 0.3.3
+CATEGORIES= math
+MASTER_SITES= ftp://ftp.worldforge.org/pub/worldforge/libs/${PORTNAME}/ \
+ http://purple.worldforge.org/downloads/libs/${PORTNAME}/ \
+ ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= worldforge
+
+MAINTAINER= jannisan@t-online.de
+COMMENT= Worldforge math library
+
+USE_GMAKE= yes
+USE_GNOME= pkgconfig
+INSTALLS_SHLIB= yes
+USE_LIBTOOL_VER=15
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= Does not compile
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/math/wfmath/distinfo b/math/wfmath/distinfo
new file mode 100644
index 000000000000..f0a756455e41
--- /dev/null
+++ b/math/wfmath/distinfo
@@ -0,0 +1,2 @@
+MD5 (wfmath-0.3.3.tar.gz) = 33e7bc1468183e3a35f3f29e7d29d4d8
+SIZE (wfmath-0.3.3.tar.gz) = 393387
diff --git a/math/wfmath/files/patch-Makefile.in b/math/wfmath/files/patch-Makefile.in
new file mode 100644
index 000000000000..69eb90a0e774
--- /dev/null
+++ b/math/wfmath/files/patch-Makefile.in
@@ -0,0 +1,19 @@
+*** Makefile.in.orig Thu Feb 3 10:13:51 2005
+--- Makefile.in Thu Feb 3 10:16:12 2005
+***************
+*** 100,106 ****
+ WFMATH_VERSION_INFO = @WFMATH_VERSION_INFO@
+ WFMATH_VERSION_NO = @WFMATH_VERSION_NO@
+
+! pkgconfigdir = $(libdir)/pkgconfig
+ pkgconfig_DATA = wfmath-0.3.pc
+
+ EXTRA_DIST = TODO autogen.sh wfmath.pbproj/project.pbxproj wfmath.spec
+--- 100,106 ----
+ WFMATH_VERSION_INFO = @WFMATH_VERSION_INFO@
+ WFMATH_VERSION_NO = @WFMATH_VERSION_NO@
+
+! pkgconfigdir = $(prefix)/libdata/pkgconfig
+ pkgconfig_DATA = wfmath-0.3.pc
+
+ EXTRA_DIST = TODO autogen.sh wfmath.pbproj/project.pbxproj wfmath.spec
diff --git a/math/wfmath/pkg-descr b/math/wfmath/pkg-descr
new file mode 100644
index 000000000000..84a58d3c3bd9
--- /dev/null
+++ b/math/wfmath/pkg-descr
@@ -0,0 +1,9 @@
+This is the Worldforge math library. The primary focus of WFMath is geometric
+objects. Thus, it includes several shapes (boxes, balls, lines), in addition
+to the basic math objects that are used to build these shapes (points,
+vectors, matricies).
+
+WWW: http://www.worldforge.org/
+
+- Janni
+jannisan@t-online.de
diff --git a/math/wfmath/pkg-plist b/math/wfmath/pkg-plist
new file mode 100644
index 000000000000..7c559ba7722e
--- /dev/null
+++ b/math/wfmath/pkg-plist
@@ -0,0 +1,40 @@
+lib/libwfmath-0.3.a
+lib/libwfmath-0.3.so
+lib/libwfmath-0.3.so.3
+include/wfmath-0.3/wfmath/error.h
+include/wfmath-0.3/wfmath/const.h
+include/wfmath-0.3/wfmath/int_to_string.h
+include/wfmath-0.3/wfmath/probability.h
+include/wfmath-0.3/wfmath/timestamp.h
+include/wfmath-0.3/wfmath/MersenneTwister.h
+include/wfmath-0.3/wfmath/randgen.h
+include/wfmath-0.3/wfmath/shuffle.h
+include/wfmath-0.3/wfmath/vector.h
+include/wfmath-0.3/wfmath/vector_funcs.h
+include/wfmath-0.3/wfmath/rotmatrix.h
+include/wfmath-0.3/wfmath/rotmatrix_funcs.h
+include/wfmath-0.3/wfmath/point.h
+include/wfmath-0.3/wfmath/point_funcs.h
+include/wfmath-0.3/wfmath/quaternion.h
+include/wfmath-0.3/wfmath/axisbox.h
+include/wfmath-0.3/wfmath/axisbox_funcs.h
+include/wfmath-0.3/wfmath/ball.h
+include/wfmath-0.3/wfmath/ball_funcs.h
+include/wfmath-0.3/wfmath/wrapped_array.h
+include/wfmath-0.3/wfmath/miniball.h
+include/wfmath-0.3/wfmath/miniball_funcs.h
+include/wfmath-0.3/wfmath/segment.h
+include/wfmath-0.3/wfmath/segment_funcs.h
+include/wfmath-0.3/wfmath/rotbox.h
+include/wfmath-0.3/wfmath/rotbox_funcs.h
+include/wfmath-0.3/wfmath/polygon.h
+include/wfmath-0.3/wfmath/polygon_funcs.h
+include/wfmath-0.3/wfmath/polygon_intersect.h
+include/wfmath-0.3/wfmath/intersect_decls.h
+include/wfmath-0.3/wfmath/intersect.h
+include/wfmath-0.3/wfmath/wfmath.h
+include/wfmath-0.3/wfmath/stream.h
+include/wfmath-0.3/wfmath/atlasconv.h
+@dirrm include/wfmath-0.3/wfmath
+@dirrm include/wfmath-0.3
+libdata/pkgconfig/wfmath-0.3.pc