aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authormaho <maho@FreeBSD.org>2007-01-12 20:22:50 +0800
committermaho <maho@FreeBSD.org>2007-01-12 20:22:50 +0800
commite90ad7919bd9f54fadb09dddd2f62f7156eaab70 (patch)
tree9a99e487d163fda3f3a1a71f97e2fdd6ac8de35f /math
parent42b7eab17d42076a59666016b20c5a4e38f052b4 (diff)
downloadfreebsd-ports-gnome-e90ad7919bd9f54fadb09dddd2f62f7156eaab70.tar.gz
freebsd-ports-gnome-e90ad7919bd9f54fadb09dddd2f62f7156eaab70.tar.zst
freebsd-ports-gnome-e90ad7919bd9f54fadb09dddd2f62f7156eaab70.zip
* Migrate to gfortran.
* Bump port revision. Approved by: portmgr(kris)
Diffstat (limited to 'math')
-rw-r--r--math/octave/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/math/octave/Makefile b/math/octave/Makefile
index 5c70e710f3f7..293617d00d84 100644
--- a/math/octave/Makefile
+++ b/math/octave/Makefile
@@ -7,7 +7,7 @@
PORTNAME= octave
PORTVERSION= 2.1.73
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= math
MASTER_SITES= ftp://ftp.octave.org/pub/octave/bleeding-edge/ \
ftp://ftp.eos.hokudai.ac.jp/pub/GNU/misc/octave/bleeding-edge/ \
@@ -34,7 +34,10 @@ OCTAVE_VERSION= ${PORTVERSION}
GNU_HOST= ${ARCH}-portbld-freebsd${OSREL}
PLIST_SUB= OCTAVE_VERSION=${OCTAVE_VERSION} GNU_HOST=${GNU_HOST}
-F77?= f77
+WANT_FORTRAN=yes #dummy but future use
+BUILD_DEPENDS+= gfortran42:${PORTSDIR}/lang/gcc42
+FC= gfortran42
+F77= gfortran42
CONFIGURE_ENV= LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib" \
CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include" \