aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorlioux <lioux@FreeBSD.org>2001-07-01 10:25:37 +0800
committerlioux <lioux@FreeBSD.org>2001-07-01 10:25:37 +0800
commitf0dadf0057bed14d227e4e00eeb79922485d538b (patch)
tree164796e45a543c457295efc8f80e1cf856a9696b /math
parent6fe04c5baf4137b1fc0b325a8d4d318b7aa09fe4 (diff)
downloadfreebsd-ports-gnome-f0dadf0057bed14d227e4e00eeb79922485d538b.tar.gz
freebsd-ports-gnome-f0dadf0057bed14d227e4e00eeb79922485d538b.tar.zst
freebsd-ports-gnome-f0dadf0057bed14d227e4e00eeb79922485d538b.zip
Install additional header files
PR: 28538 Submitted by: maintainer
Diffstat (limited to 'math')
-rw-r--r--math/concorde/Makefile12
-rw-r--r--math/concorde/pkg-plist29
2 files changed, 39 insertions, 2 deletions
diff --git a/math/concorde/Makefile b/math/concorde/Makefile
index 2acbc30a28ce..ab62afda4e0b 100644
--- a/math/concorde/Makefile
+++ b/math/concorde/Makefile
@@ -18,8 +18,18 @@ WRKSRC= ${WRKDIR}/concorde
GNU_CONFIGURE= yes
+INCFILES= bigguy.h combs.h config.h consec1.h cut.h cuttree.h \
+ delaunay.h edgegen.h fmatch.h heldkarp.h kdtree.h \
+ linkern.h localcut.h lp.h machdefs.h macrorus.h mlinkern.h \
+ necklace.h pq.h pqsets.h profdata.h profrus.h tinytsp.h \
+ tsp.h util.h verify.h
+
do-install:
${INSTALL_DATA} ${WRKSRC}/concorde.a ${PREFIX}/lib/libconcorde.a
- ${INSTALL_DATA} ${WRKSRC}/concorde.h ${PREFIX}/include
+ ${INSTALL} -d -o ${SHAREOWN} -g ${SHAREGRP} -m 755 ${PREFIX}/include/concorde
+ ${INSTALL_DATA} ${WRKSRC}/concorde.h ${PREFIX}/include/concorde
+.for f in ${INCFILES}
+ ${INSTALL_DATA} ${WRKSRC}/INCLUDE/${f} ${PREFIX}/include/concorde
+.endfor
.include <bsd.port.mk>
diff --git a/math/concorde/pkg-plist b/math/concorde/pkg-plist
index 7646ca274eae..d9d433514d63 100644
--- a/math/concorde/pkg-plist
+++ b/math/concorde/pkg-plist
@@ -1,2 +1,29 @@
lib/libconcorde.a
-include/concorde.h
+include/concorde/bigguy.h
+include/concorde/combs.h
+include/concorde/concorde.h
+include/concorde/config.h
+include/concorde/consec1.h
+include/concorde/cut.h
+include/concorde/cuttree.h
+include/concorde/delaunay.h
+include/concorde/edgegen.h
+include/concorde/fmatch.h
+include/concorde/heldkarp.h
+include/concorde/kdtree.h
+include/concorde/linkern.h
+include/concorde/localcut.h
+include/concorde/lp.h
+include/concorde/machdefs.h
+include/concorde/macrorus.h
+include/concorde/mlinkern.h
+include/concorde/necklace.h
+include/concorde/pq.h
+include/concorde/pqsets.h
+include/concorde/profdata.h
+include/concorde/profrus.h
+include/concorde/tinytsp.h
+include/concorde/tsp.h
+include/concorde/util.h
+include/concorde/verify.h
+@dirrm include/concorde