aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2013-08-09 09:49:55 +0800
committerdanfe <danfe@FreeBSD.org>2013-08-09 09:49:55 +0800
commit0d34c42014d270b478e10045d3e573c93b9fe01d (patch)
tree533f7d7a3dfda58f8f76250a72dabeae67fa5dfb /math
parent1a5a0f68055a005b1b024f5d8e1450b2a90b652c (diff)
downloadfreebsd-ports-gnome-0d34c42014d270b478e10045d3e573c93b9fe01d.tar.gz
freebsd-ports-gnome-0d34c42014d270b478e10045d3e573c93b9fe01d.tar.zst
freebsd-ports-gnome-0d34c42014d270b478e10045d3e573c93b9fe01d.zip
Fix parallel (-jX) builds. This cuts down the build time from 1:07 down to
just 21 seconds on my quad-core o'clocked Q9550.
Diffstat (limited to 'math')
-rw-r--r--math/xblas/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/math/xblas/Makefile b/math/xblas/Makefile
index df61cf4fbf70..9f5127bfe00f 100644
--- a/math/xblas/Makefile
+++ b/math/xblas/Makefile
@@ -13,7 +13,6 @@ COMMENT= Extra Precise Basic Linear Algebra Subroutines (BLAS)
LICENSE= BSD
USE_LDCONFIG= yes
-MAKE_JOBS_UNSAFE= yes
CFLAGS+= ${MANGLING}
HDIR= include/xblas
@@ -66,6 +65,9 @@ post-patch:
@${CP} -af ${WRKSRC} ${WRKSRC}_STATIC
.endif
@${PRINTF} "\nCFLAGS+=\t${PICFLAG}\n" >> ${WRKSRC}/make.inc
+# Fix parallel (-jX) builds
+ @${FIND} ${WRKSRC} -name Makefile | ${XARGS} ${REINPLACE_CMD} \
+ -E 's/cd (.+) && (\$$\(MAKE\))/\2 -C \1/'
do-build: build-shared build-static