aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2015-09-04 22:26:05 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2015-09-04 22:26:05 +0800
commit112ead8c664ae9a2e337b1f4957e490082af2e23 (patch)
tree2e22d05e5cbf418fa457783dcc87c3d60c29619f /math
parentf110e4dcbc1e3832c3db8bf51dd534eb106d4fa3 (diff)
downloadfreebsd-ports-gnome-112ead8c664ae9a2e337b1f4957e490082af2e23.tar.gz
freebsd-ports-gnome-112ead8c664ae9a2e337b1f4957e490082af2e23.tar.zst
freebsd-ports-gnome-112ead8c664ae9a2e337b1f4957e490082af2e23.zip
- Add NO_ARCH
- Don't install empty docdirs Approved by: portmgr blanket
Diffstat (limited to 'math')
-rw-r--r--math/proofgeneral/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/math/proofgeneral/Makefile b/math/proofgeneral/Makefile
index ca851595e39b..03161df6d432 100644
--- a/math/proofgeneral/Makefile
+++ b/math/proofgeneral/Makefile
@@ -20,8 +20,9 @@ RUN_DEPENDS= ${LOCALBASE}/share/icons/hicolor/index.theme:${PORTSDIR}/misc/hicol
USE_EMACS= yes
INSTALLS_ICONS= yes
-USES= gmake perl5 shebangfix tar:tgz
+USES= gmake perl5 shebangfix tar:tgz
SHEBANG_FILES= lego/legotags coq/coqtags isar/isartags
+NO_ARCH= yes
.include <bsd.port.pre.mk>
@@ -51,8 +52,8 @@ BUILD_DEPENDS+= texi2html:${PORTSDIR}/textproc/texi2html
.endif
PORTDOCS= AUTHORS BUGS CHANGES COMPATIBILITY COPYING INSTALL \
- PG-adapting ProofGeneral README REGISTER acl2 hol98 isar lclam lego \
- pgshell phox plastic twelf
+ PG-adapting ProofGeneral README REGISTER acl2 hol98 isar lego \
+ pgshell phox twelf
post-patch:
@${REINPLACE_CMD} -e 's,%%PREFIX%%,${PREFIX},' \
@@ -74,4 +75,7 @@ pre-build:
@${RM} ${WRKSRC}/.byte-compile || ${TRUE}
#.endif
+post-install:
+ @${FIND} ${STAGEDIR}${DOCSDIR} -type d -empty -delete
+
.include <bsd.port.post.mk>