aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2018-09-22 13:30:31 +0800
committerlinimon <linimon@FreeBSD.org>2018-09-22 13:30:31 +0800
commit12ca5793be5d0b68e37dfa5a5e1f1253aed4b7a5 (patch)
treeee1202c5a5464562474562e70212261185323b7d /math
parent82b2604cbc93a294ed39ce8da691d406c1342992 (diff)
downloadfreebsd-ports-gnome-12ca5793be5d0b68e37dfa5a5e1f1253aed4b7a5.tar.gz
freebsd-ports-gnome-12ca5793be5d0b68e37dfa5a5e1f1253aed4b7a5.tar.zst
freebsd-ports-gnome-12ca5793be5d0b68e37dfa5a5e1f1253aed4b7a5.zip
Fix build on gcc-based archs by updating USES.
Tested on powerpc64 and amd64 (for no regression). While here, pet portlint. Approved by: portmgr (tier-2 blanket)
Diffstat (limited to 'math')
-rw-r--r--math/cbc/Makefile2
-rw-r--r--math/cgl/Makefile2
-rw-r--r--math/clp/Makefile4
-rw-r--r--math/clrng/Makefile9
-rw-r--r--math/gnuplot/Makefile2
5 files changed, 8 insertions, 11 deletions
diff --git a/math/cbc/Makefile b/math/cbc/Makefile
index 380dd38d9a3c..3cf77db7fbfd 100644
--- a/math/cbc/Makefile
+++ b/math/cbc/Makefile
@@ -17,7 +17,7 @@ LIB_DEPENDS= libblas.so:math/blas \
libClp.so:math/clp \
liblapack.so:math/lapack
-USES= fortran gmake libtool pkgconfig
+USES= compiler:c++11-lang fortran gmake libtool pkgconfig
USE_GITHUB= yes
GH_ACCOUNT= coin-or
GH_PROJECT= Cbc
diff --git a/math/cgl/Makefile b/math/cgl/Makefile
index 2996ca932529..42ea8d1c7fb7 100644
--- a/math/cgl/Makefile
+++ b/math/cgl/Makefile
@@ -14,7 +14,7 @@ LIB_DEPENDS= libblas.so:math/blas \
libClp.so:math/clp \
liblapack.so:math/lapack
-USES= gmake libtool pkgconfig
+USES= compiler:c++11-lang gmake libtool pkgconfig
GNU_CONFIGURE= yes
USE_GITHUB= yes
GH_ACCOUNT= coin-or
diff --git a/math/clp/Makefile b/math/clp/Makefile
index 4c1a014d72b8..04a0bdc56a19 100644
--- a/math/clp/Makefile
+++ b/math/clp/Makefile
@@ -13,9 +13,7 @@ COMMENT= Linear Programming Solver
LICENSE= EPL
-BROKEN_powerpc64= fails to compile: CoinSignal.hpp: ISO C++ forbids declaration of '__decltype' with no type
-
-USES= blaslapack fortran libtool tar:tgz pathfix
+USES= blaslapack compiler:c++11-lang fortran libtool pathfix tar:tgz
CXXFLAGS+= -ffast-math
GNU_CONFIGURE= yes
diff --git a/math/clrng/Makefile b/math/clrng/Makefile
index fcfddc0d909b..04409fd4e18c 100644
--- a/math/clrng/Makefile
+++ b/math/clrng/Makefile
@@ -12,20 +12,19 @@ COMMENT= Library for uniform random number generation in OpenCL
LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
+ONLY_FOR_ARCHS= amd64 i386 powerpc powerpc64
+ONLY_FOR_ARCHS_REASON= this code has only been tested on x86 and powerpc platforms
+
BUILD_DEPENDS= opencl>=0:devel/opencl
LIB_DEPENDS= libOpenCL.so:devel/ocl-icd
RUN_DEPENDS= opencl>=0:devel/opencl
-ONLY_FOR_ARCHS= amd64 i386 powerpc powerpc64
-ONLY_FOR_ARCHS_REASON= this code has only been tested on x86 and powerpc platforms
-BROKEN_powerpc64= fails to compile: cc1: error: unrecognized command line option -std=c11
-
USE_GITHUB= yes
GH_ACCOUNT= clMathLibraries
GH_PROJECT= clRNG
+USES= cmake compiler:c++11-lang
USE_LDCONFIG= yes
-USES= cmake
CMAKE_ARGS+= -DBUILD_CLIENT=OFF \
-DBUILD_TEST=OFF \
diff --git a/math/gnuplot/Makefile b/math/gnuplot/Makefile
index fd20181d33b7..c2bfd1a968f5 100644
--- a/math/gnuplot/Makefile
+++ b/math/gnuplot/Makefile
@@ -15,7 +15,7 @@ LICENSE_PERMS= dist-mirror pkg-mirror auto-accept
CONFLICTS_INSTALL?= gnuplot-lite-[0-9]*
-USES+= groff iconv pkgconfig readline
+USES+= compiler:c++11-lang groff iconv pkgconfig readline
GNU_CONFIGURE= yes
LDFLAGS+= -L${LOCALBASE}/lib ${ICONV_LIB}
CONFIGURE_ARGS+=--with-readline=gnu \