aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2004-04-18 18:48:23 +0800
committerpav <pav@FreeBSD.org>2004-04-18 18:48:23 +0800
commit18b4dee53633778530f7c98a84b05fec28c63d82 (patch)
tree941166c7f98c77532cdf7b6e251d86ca028ebce3 /math
parent96f4b7d95ad8bf02d03c18c4f7490d45c0b6837a (diff)
downloadfreebsd-ports-gnome-18b4dee53633778530f7c98a84b05fec28c63d82.tar.gz
freebsd-ports-gnome-18b4dee53633778530f7c98a84b05fec28c63d82.tar.zst
freebsd-ports-gnome-18b4dee53633778530f7c98a84b05fec28c63d82.zip
After repocopy from math/fftw, add fftw 3.0.1, a fast C library for computing
Discrete Fourier Transform. Version 3.x is API incompatible with fftw 2.x PR: ports/65559 Submitted by: michael johnson <ahze@ahze.net>
Diffstat (limited to 'math')
-rw-r--r--math/Makefile1
-rw-r--r--math/fftw3/Makefile41
-rw-r--r--math/fftw3/distinfo4
-rw-r--r--math/fftw3/files/patch-configure10
-rw-r--r--math/fftw3/files/patch-doc::fftw.texi13
-rw-r--r--math/fftw3/pkg-plist21
6 files changed, 37 insertions, 53 deletions
diff --git a/math/Makefile b/math/Makefile
index 32ba9fcee9a8..502e3e24f8f7 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -42,6 +42,7 @@
SUBDIR += femlab
SUBDIR += fftpack
SUBDIR += fftw
+ SUBDIR += fftw3
SUBDIR += freefem
SUBDIR += freefem++
SUBDIR += fudgit
diff --git a/math/fftw3/Makefile b/math/fftw3/Makefile
index b0932029fea0..1c568e3223a0 100644
--- a/math/fftw3/Makefile
+++ b/math/fftw3/Makefile
@@ -5,38 +5,49 @@
# $FreeBSD$
#
-PORTNAME= fftw
-PORTVERSION= 2.1.5
-PORTREVISION= 2
+PORTNAME= fftw3
+PORTVERSION= 3.0.1
CATEGORIES= math
MASTER_SITES= ftp://ftp.fftw.org/pub/fftw/ \
ftp://ftp.fftw.org/pub/fftw/old/ \
ftp://theory.lcs.mit.edu/pub/fftw/ \
ftp://pm.cse.rmit.edu.au/pub/dsp/fftw/
+DISTNAME= fftw-${PORTVERSION}
-MAINTAINER= Lars.Koeller@Uni-Bielefeld.DE
+MAINTAINER= ahze@ahze.net
COMMENT= Fast C routines to compute the Discrete Fourier Transform
USE_GMAKE= yes
USE_LIBTOOL_VER=13
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ENV= MAKEINFO="makeinfo --no-split"
-CONFIGURE_ARGS= --enable-shared
+USE_GNOME= gnomehack gnomeprefix gnometarget lthack pkgconfig
INSTALLS_SHLIB= yes
+MAN1= fftw-wisdom-to-conf.1 fftw-wisdom.1
+INFO= fftw3
+
+CONFIGURE_ARGS= --enable-shared
+CONFIGURE_ENV= CFLAGS="${CFLAGS} ${PTHREAD_CFLAGS}" \
+ LDFLAGS="${LDFLAGS} ${PTHREAD_LIBS}"
+
+OPTIONS= OPTIMIZED_CFLAGS "Enable optimized CFLAGS" off \
+ OPTIMIZED_ATHLON "Enable AMD K7(Athlon) optimizations" off \
+ SMP_THREADS "Enable FFTW SMP threads library" off
+
.include <bsd.port.pre.mk>
-.if ${ARCH} == "i386"
-CONFIGURE_ARGS+= --enable-i386-hacks
+.if defined(WITH_OPTIMIZED_CFLAGS) && !defined(WITH_OPTIMIZED_ATHLON)
+CONFIGURE_ENV+= CFLAGS="${CFLAGS} -O2 -ffast-math -fomit-frame-pointer"
.endif
-post-extract:
- @${RM} ${WRKSRC}/doc/fftw.info*
+.if defined(WITH_OPTIMIZED_ATHLON)
+CONFIGURE_ARGS+=--enable-k7
+CONFIGURE_ENV+= CFLAGS="${CFLAGS} -O3 -fomit-frame-pointer -fno-schedule-insns \
+ -malign-double -fstrict-aliasing -mpreferred-stack-boundary=4 \
+ -ffast-math"
+.endif
-post-install:
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/doc/fftw.ps ${DOCSDIR}
+.if defined(WITH_SMP_THREADS)
+CONFIGURE_ARGS+=--enable-threads
.endif
.include <bsd.port.post.mk>
diff --git a/math/fftw3/distinfo b/math/fftw3/distinfo
index e07ea116498e..6a029c9b04aa 100644
--- a/math/fftw3/distinfo
+++ b/math/fftw3/distinfo
@@ -1,2 +1,2 @@
-MD5 (fftw-2.1.5.tar.gz) = 8d16a84f3ca02a785ef9eb36249ba433
-SIZE (fftw-2.1.5.tar.gz) = 1256888
+MD5 (fftw-3.0.1.tar.gz) = 76cd21ecc9a7bed6343566c473c36477
+SIZE (fftw-3.0.1.tar.gz) = 1946361
diff --git a/math/fftw3/files/patch-configure b/math/fftw3/files/patch-configure
deleted file mode 100644
index 18bde56854e2..000000000000
--- a/math/fftw3/files/patch-configure
+++ /dev/null
@@ -1,10 +0,0 @@
---- configure.orig Mon Mar 24 16:09:56 2003
-+++ configure Fri Jul 25 10:52:07 2003
-@@ -8217,6 +8217,7 @@
-
- # This can be used to rebuild libtool when needed
- LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
-+$ac_aux_dir/ltconfig $LIBTOOL_DEPS
-
- # Always use our own libtool.
- LIBTOOL='$(SHELL) $(top_builddir)/libtool'
diff --git a/math/fftw3/files/patch-doc::fftw.texi b/math/fftw3/files/patch-doc::fftw.texi
deleted file mode 100644
index dcf37f7ea431..000000000000
--- a/math/fftw3/files/patch-doc::fftw.texi
+++ /dev/null
@@ -1,13 +0,0 @@
---- doc/fftw.texi.orig Mon Mar 17 08:43:18 2003
-+++ doc/fftw.texi Fri Jul 25 11:26:48 2003
-@@ -3,6 +3,10 @@
- @c %**start of header
- @setfilename fftw.info
- @settitle FFTW
-+@dircategory Libraries
-+@direntry
-+* FFTW: (fftw). Fast fourier transform library
-+@end direntry
- @c %**end of header
-
- @include version.texi
diff --git a/math/fftw3/pkg-plist b/math/fftw3/pkg-plist
index d019bd7f4cc0..fb557031a211 100644
--- a/math/fftw3/pkg-plist
+++ b/math/fftw3/pkg-plist
@@ -1,13 +1,8 @@
-include/fftw.h
-include/rfftw.h
-@unexec install-info --delete %D/info/fftw.info %D/info/dir
-info/fftw.info
-@exec install-info %D/info/fftw.info %D/info/dir
-lib/libfftw.a
-lib/libfftw.so
-lib/libfftw.so.2
-lib/librfftw.a
-lib/librfftw.so
-lib/librfftw.so.2
-%%PORTDOCS%%%%DOCSDIR%%/fftw.ps
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
+bin/fftw-wisdom
+bin/fftw-wisdom-to-conf
+include/fftw3.f
+include/fftw3.h
+lib/libfftw3.a
+lib/libfftw3.so
+lib/libfftw3.so.3
+libdata/pkgconfig/fftw3.pc