aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authortobik <tobik@FreeBSD.org>2018-11-06 06:07:08 +0800
committertobik <tobik@FreeBSD.org>2018-11-06 06:07:08 +0800
commit19cae68eb2f2f8b9ca106fbde0924557f649757c (patch)
treee42e75483bdb562b63d3deba8b6ba4d4b159af82 /math
parent68ec1957faa0d055bd8a453fe24e187be47a3570 (diff)
downloadfreebsd-ports-gnome-19cae68eb2f2f8b9ca106fbde0924557f649757c.tar.gz
freebsd-ports-gnome-19cae68eb2f2f8b9ca106fbde0924557f649757c.tar.zst
freebsd-ports-gnome-19cae68eb2f2f8b9ca106fbde0924557f649757c.zip
math/qtoctave: Unbreak build with Clang 6
qtoctave/src/generate_menu.cpp:282:64: error: cannot initialize return object of type 'MenuExtCallBack *' with an rvalue of type 'bool' if (!file.open(QIODevice::ReadOnly | QIODevice::Text)) return false; ^~~~~ http://beefy3.nyi.freebsd.org/data/112amd64-quarterly/482201/logs/qtoctave-0.10.1_4.log PR: 232985 Submitted by: w.schwarzenfeld@utanet.at
Diffstat (limited to 'math')
-rw-r--r--math/qtoctave/Makefile2
-rw-r--r--math/qtoctave/files/patch-qtoctave__src-generate_menu.cpp11
2 files changed, 11 insertions, 2 deletions
diff --git a/math/qtoctave/Makefile b/math/qtoctave/Makefile
index 539f0d9fc2e4..6d1308e2bcc5 100644
--- a/math/qtoctave/Makefile
+++ b/math/qtoctave/Makefile
@@ -9,8 +9,6 @@ MASTER_SITES= http://forja.rediris.es/frs/download.php/2054/
MAINTAINER= ports@FreeBSD.org
COMMENT= Qt 4 frontend for Octave
-BROKEN= fails to build
-
RUN_DEPENDS= octave:math/octave
USE_QT= designer gui network script svg xml \
diff --git a/math/qtoctave/files/patch-qtoctave__src-generate_menu.cpp b/math/qtoctave/files/patch-qtoctave__src-generate_menu.cpp
new file mode 100644
index 000000000000..db4433dcba24
--- /dev/null
+++ b/math/qtoctave/files/patch-qtoctave__src-generate_menu.cpp
@@ -0,0 +1,11 @@
+--- qtoctave/src/generate_menu.cpp.orig 2018-11-05 13:09:19 UTC
++++ qtoctave/src/generate_menu.cpp
+@@ -279,7 +279,7 @@ bool GenerateMenu::process_menu_file(QSt
+ MenuExtCallBack *GenerateMenu::process_menu_file(QString _file)
+ {
+ QFile file(_file);
+- if (!file.open(QIODevice::ReadOnly | QIODevice::Text)) return false;
++ if (!file.open(QIODevice::ReadOnly | QIODevice::Text)) return NULL;
+
+ QString label;
+ MenuExtCallBack *wizard=new MenuExtCallBack();