aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorgahr <gahr@FreeBSD.org>2016-03-04 23:13:16 +0800
committergahr <gahr@FreeBSD.org>2016-03-04 23:13:16 +0800
commit35cd20eadfb98267c6c8689b6e142d9d1f9f13f5 (patch)
treeb278850226d8122957ca084f2c52c87f0e7bb885 /math
parent7f786c89abcf4e4c5c170e027aa612e164133f91 (diff)
downloadfreebsd-ports-gnome-35cd20eadfb98267c6c8689b6e142d9d1f9f13f5.tar.gz
freebsd-ports-gnome-35cd20eadfb98267c6c8689b6e142d9d1f9f13f5.tar.zst
freebsd-ports-gnome-35cd20eadfb98267c6c8689b6e142d9d1f9f13f5.zip
math/yacas: unbreak on 9. w/ gcc
Diffstat (limited to 'math')
-rw-r--r--math/yacas/Makefile4
-rw-r--r--math/yacas/files/patch-src_mathcommands.cpp10
-rw-r--r--math/yacas/files/patch-src_yacasmain.cpp10
3 files changed, 22 insertions, 2 deletions
diff --git a/math/yacas/Makefile b/math/yacas/Makefile
index c03b28dd86d1..1735947f49dc 100644
--- a/math/yacas/Makefile
+++ b/math/yacas/Makefile
@@ -3,8 +3,8 @@
PORTNAME= yacas
PORTVERSION= 1.4.0
-CATEGORIES= math
DISTVERSIONPREFIX= v
+CATEGORIES= math
MAINTAINER= gahr@FreeBSD.org
COMMENT= Yet Another Computer Algebra System
@@ -22,7 +22,7 @@ GH_ACCOUNT= grzegorzmazur
.include <bsd.port.pre.mk>
.if ${CHOSEN_COMPILER_TYPE} == "gcc"
-CPPFLAGS+= -D_GLIBCXX_USE_C99
+CXXFLAGS+= -D_GLIBCXX_USE_C99
.endif
post-patch:
diff --git a/math/yacas/files/patch-src_mathcommands.cpp b/math/yacas/files/patch-src_mathcommands.cpp
new file mode 100644
index 000000000000..caf0c481bc4d
--- /dev/null
+++ b/math/yacas/files/patch-src_mathcommands.cpp
@@ -0,0 +1,10 @@
+--- src/mathcommands.cpp.orig 2016-02-04 14:54:05 UTC
++++ src/mathcommands.cpp
+@@ -23,6 +23,7 @@
+ #include "yacas/arggetter.h"
+ #include "yacas/string_utils.h"
+
++#include <string>
+ #include <cstring>
+ #include <limits.h>
+ #include <stdlib.h>
diff --git a/math/yacas/files/patch-src_yacasmain.cpp b/math/yacas/files/patch-src_yacasmain.cpp
new file mode 100644
index 000000000000..6cf8bbea68f8
--- /dev/null
+++ b/math/yacas/files/patch-src_yacasmain.cpp
@@ -0,0 +1,10 @@
+--- src/yacasmain.cpp.orig 2016-03-04 15:08:05 UTC
++++ src/yacasmain.cpp
+@@ -72,6 +72,7 @@
+ #if defined (__FreeBSD__) || defined (__DragonFly__)
+ #include <stddef.h>
+ #include <unistd.h>
++#include <sys/syslimits.h>
+ #include <sys/types.h>
+ #include <sys/sysctl.h>
+ #endif