aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authormaho <maho@FreeBSD.org>2016-04-18 19:28:17 +0800
committermaho <maho@FreeBSD.org>2016-04-18 19:28:17 +0800
commit37187e401a1fa0201dd25f5f74e4ff076590b151 (patch)
treee4d96abb7da8fa9289f63ac31db0946d39c9c989 /math
parent722cd9b3839c7540369d5b75601f6870b129d4f4 (diff)
downloadfreebsd-ports-gnome-37187e401a1fa0201dd25f5f74e4ff076590b151.tar.gz
freebsd-ports-gnome-37187e401a1fa0201dd25f5f74e4ff076590b151.tar.zst
freebsd-ports-gnome-37187e401a1fa0201dd25f5f74e4ff076590b151.zip
Cosmetic updates
- Clean up a malloc() call to get rid of some warnings. - Pet portlint by using "makepatch" for the patches, added the license, changed a tab after the WWW line. PR: 208295 Submitted by: pfg@
Diffstat (limited to 'math')
-rw-r--r--math/spooles/Makefile5
-rw-r--r--math/spooles/files/patch-ETree+src+makeGlobalLib6
-rw-r--r--math/spooles/files/patch-I2Ohash-large-input10
-rw-r--r--math/spooles/files/patch-IVL+src+makeGlobalLib6
-rw-r--r--math/spooles/files/patch-MPI+makefile4
-rw-r--r--math/spooles/files/patch-MPI+src+makeGlobalLib6
-rw-r--r--math/spooles/files/patch-MT+drivers+AllInOneMT.c6
-rw-r--r--math/spooles/files/patch-MT+makefile4
-rw-r--r--math/spooles/files/patch-Make.inc4
-rw-r--r--math/spooles/files/patch-Tree+src+makeGlobalLib6
-rw-r--r--math/spooles/files/patch-Utilities+MM.h28
-rw-r--r--math/spooles/files/patch-Utilities+src+makeGlobalLib6
-rw-r--r--math/spooles/files/patch-makefile4
-rw-r--r--math/spooles/pkg-descr2
14 files changed, 64 insertions, 33 deletions
diff --git a/math/spooles/Makefile b/math/spooles/Makefile
index 755372729346..42697eeac2c2 100644
--- a/math/spooles/Makefile
+++ b/math/spooles/Makefile
@@ -5,7 +5,8 @@ PORTNAME= spooles
PORTVERSION= 2.2
PORTREVISION= 12
CATEGORIES= math
-MASTER_SITES= http://www.netlib.org/linalg/spooles/
+MASTER_SITES= ${MASTER_SITE_NETLIB}
+MASTER_SITE_SUBDIR=linalg/spooles
.ifdef WITH_MPI
PKGNAMESUFFIX= -mpich
.endif
@@ -16,6 +17,8 @@ EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= maho@FreeBSD.org
COMMENT= SParse Object Oriented Linear Equations Solver
+LICENSE= PD
+
.if defined(WITH_MPI)
BUILD_DEPENDS= ${LOCALBASE}/lib/libmpich.a:net/mpich2
.endif
diff --git a/math/spooles/files/patch-ETree+src+makeGlobalLib b/math/spooles/files/patch-ETree+src+makeGlobalLib
index 9a59a1c908af..1ea258c1dc35 100644
--- a/math/spooles/files/patch-ETree+src+makeGlobalLib
+++ b/math/spooles/files/patch-ETree+src+makeGlobalLib
@@ -1,6 +1,6 @@
---- ETree/src/makeGlobalLib~ Fri Sep 18 04:25:01 1998
-+++ ETree/src/makeGlobalLib Tue Jan 9 16:20:19 2007
-@@ -8,6 +8,7 @@
+--- ETree/src/makeGlobalLib.orig 1998-09-17 19:25:01 UTC
++++ ETree/src/makeGlobalLib
+@@ -8,6 +8,7 @@ SRC = IO.c \
basics.c \
compress.c \
init.c \
diff --git a/math/spooles/files/patch-I2Ohash-large-input b/math/spooles/files/patch-I2Ohash-large-input
index a57bf2daedd1..2d4d467668f1 100644
--- a/math/spooles/files/patch-I2Ohash-large-input
+++ b/math/spooles/files/patch-I2Ohash-large-input
@@ -1,6 +1,6 @@
---- I2Ohash/src/util.c 1998-05-31 07:45:12.000000000 +0900
-+++ I2Ohash/src/util.c 2013-03-06 14:59:43.000000000 +0900
-@@ -39,7 +39,9 @@
+--- I2Ohash/src/util.c.orig 1998-05-30 22:45:12 UTC
++++ I2Ohash/src/util.c
+@@ -39,7 +39,9 @@ fflush(stdout) ;
*/
loc1 = (key1 + 1) % hashtable->nlist ;
loc2 = (key2 + 1) % hashtable->nlist ;
@@ -11,7 +11,7 @@
#if MYDEBUG > 0
fprintf(stdout, "\n loc1 = %d, loc2 = %d, loc3 = %d", loc1, loc2, loc) ;
fflush(stdout) ;
-@@ -158,7 +160,9 @@
+@@ -158,7 +160,9 @@ fflush(stdout) ;
#endif
loc1 = (key1 + 1) % hashtable->nlist ;
loc2 = (key2 + 1) % hashtable->nlist ;
@@ -22,7 +22,7 @@
#if MYDEBUG > 0
fprintf(stdout, "\n loc1 = %d, loc2 = %d, loc3 = %d", loc1, loc2, loc) ;
fflush(stdout) ;
-@@ -229,7 +233,9 @@
+@@ -229,7 +233,9 @@ if ( hashtable == NULL || pvalue == NULL
}
loc1 = (key1 + 1) % hashtable->nlist ;
loc2 = (key2 + 1) % hashtable->nlist ;
diff --git a/math/spooles/files/patch-IVL+src+makeGlobalLib b/math/spooles/files/patch-IVL+src+makeGlobalLib
index 4c248674618c..263f29912ae0 100644
--- a/math/spooles/files/patch-IVL+src+makeGlobalLib
+++ b/math/spooles/files/patch-IVL+src+makeGlobalLib
@@ -1,6 +1,6 @@
---- IVL/src/makeGlobalLib~ Fri Sep 18 04:25:30 1998
-+++ IVL/src/makeGlobalLib Tue Jan 9 16:26:55 2007
-@@ -9,6 +9,7 @@
+--- IVL/src/makeGlobalLib.orig 1998-09-17 19:25:30 UTC
++++ IVL/src/makeGlobalLib
+@@ -9,6 +9,7 @@ SRC = IO.c \
init.c \
instance.c \
listmanip.c \
diff --git a/math/spooles/files/patch-MPI+makefile b/math/spooles/files/patch-MPI+makefile
index c55261ee0afb..fddf5f8fc8af 100644
--- a/math/spooles/files/patch-MPI+makefile
+++ b/math/spooles/files/patch-MPI+makefile
@@ -1,5 +1,5 @@
---- MPI/makefile.orig Mon Feb 20 16:41:10 2006
-+++ MPI/makefile Mon Feb 20 16:42:02 2006
+--- MPI/makefile.orig 1998-12-17 15:47:44 UTC
++++ MPI/makefile
@@ -1,8 +1,8 @@
all_drivers :
- cd drivers ; make drivers
diff --git a/math/spooles/files/patch-MPI+src+makeGlobalLib b/math/spooles/files/patch-MPI+src+makeGlobalLib
index 05a4292e571c..fc6a5346a8db 100644
--- a/math/spooles/files/patch-MPI+src+makeGlobalLib
+++ b/math/spooles/files/patch-MPI+src+makeGlobalLib
@@ -1,6 +1,6 @@
---- MPI/src/makeGlobalLib.orig Sat Nov 21 23:52:01 1998
-+++ MPI/src/makeGlobalLib Fri Oct 1 00:17:01 2004
-@@ -29,7 +29,7 @@
+--- MPI/src/makeGlobalLib.orig 1998-11-21 22:52:01 UTC
++++ MPI/src/makeGlobalLib
+@@ -29,7 +29,7 @@ SRC = aggListMPI.c \
utilities.c
OBJ_FILES = ${SRC:.c=.o}
diff --git a/math/spooles/files/patch-MT+drivers+AllInOneMT.c b/math/spooles/files/patch-MT+drivers+AllInOneMT.c
index 0553491c9a48..932be8e26c12 100644
--- a/math/spooles/files/patch-MT+drivers+AllInOneMT.c
+++ b/math/spooles/files/patch-MT+drivers+AllInOneMT.c
@@ -1,6 +1,6 @@
---- MT/drivers/allInOneMT.c.orig Sat Aug 9 14:06:19 2003
-+++ MT/drivers/allInOneMT.c Sat Aug 9 14:13:07 2003
-@@ -35,7 +35,7 @@
+--- MT/drivers/allInOneMT.c.orig 1999-01-21 16:51:22 UTC
++++ MT/drivers/allInOneMT.c
+@@ -35,7 +35,7 @@ DenseMtx *mtxY, *mtxX ;
Chv *rootchv ;
ChvManager *chvmanager ;
double droptol = 0.0, tau = 100. ;
diff --git a/math/spooles/files/patch-MT+makefile b/math/spooles/files/patch-MT+makefile
index 511f6740990f..a134e95b5670 100644
--- a/math/spooles/files/patch-MT+makefile
+++ b/math/spooles/files/patch-MT+makefile
@@ -1,5 +1,5 @@
---- MT/makefile.orig Mon Feb 20 16:39:12 2006
-+++ MT/makefile Mon Feb 20 16:43:07 2006
+--- MT/makefile.orig 1998-12-17 15:47:48 UTC
++++ MT/makefile
@@ -1,8 +1,8 @@
all_drivers :
- cd drivers ; make drivers
diff --git a/math/spooles/files/patch-Make.inc b/math/spooles/files/patch-Make.inc
index 8bece8f33248..2713fc8d269f 100644
--- a/math/spooles/files/patch-Make.inc
+++ b/math/spooles/files/patch-Make.inc
@@ -1,5 +1,5 @@
---- Make.inc.orig Tue Jan 19 06:48:55 1999
-+++ Make.inc Tue Jan 9 12:57:18 2007
+--- Make.inc.orig 1999-01-18 21:48:55 UTC
++++ Make.inc
@@ -12,7 +12,7 @@
# for solaris
#
diff --git a/math/spooles/files/patch-Tree+src+makeGlobalLib b/math/spooles/files/patch-Tree+src+makeGlobalLib
index 37a9c12bbd97..46a714196e77 100644
--- a/math/spooles/files/patch-Tree+src+makeGlobalLib
+++ b/math/spooles/files/patch-Tree+src+makeGlobalLib
@@ -1,6 +1,6 @@
---- Tree/src/makeGlobalLib.orig Fri Sep 18 04:26:35 1998
-+++ Tree/src/makeGlobalLib Mon May 5 08:30:58 2003
-@@ -6,7 +6,8 @@
+--- Tree/src/makeGlobalLib.orig 1998-09-17 19:26:35 UTC
++++ Tree/src/makeGlobalLib
+@@ -6,7 +6,8 @@ OBJ = Tree
SRC = basics.c \
compress.c \
diff --git a/math/spooles/files/patch-Utilities+MM.h b/math/spooles/files/patch-Utilities+MM.h
new file mode 100644
index 000000000000..68989c02135b
--- /dev/null
+++ b/math/spooles/files/patch-Utilities+MM.h
@@ -0,0 +1,28 @@
+--- Utilities/MM.h.orig 1998-05-30 22:45:00 UTC
++++ Utilities/MM.h
+@@ -30,21 +30,21 @@
+ */
+ #define ALLOCATE(ptr, type, count) \
+ if ( (count) > 0 ) { \
+- if ( (ptr = (type *)malloc((unsigned long)((count)*sizeof(type)))) \
++ if ( (ptr = malloc((unsigned long)(count)*sizeof(type))) \
+ == NULL ) {\
+ fprintf(stderr, \
+- "\n ALLOCATE failure : bytes %d, line %d, file %s", \
++ "\n ALLOCATE failure : bytes %lu, line %d, file %s", \
+ (count)*sizeof(type), __LINE__, __FILE__) ; \
+ exit(-1) ; } \
+ else if ( MEMORY_DEBUG > 0 ) { \
+ fprintf(stderr, \
+- "\n ALLOCATE : address %p, bytes %d, line %d, file %s", \
++ "\n ALLOCATE : address %p, bytes %lu, line %d, file %s", \
+ ptr, (count)*sizeof(type), __LINE__, __FILE__) ; } } \
+ else if ( (count) == 0 ) { \
+ ptr = NULL ; } \
+ else { \
+ fprintf(stderr, \
+- "\n ALLOCATE error : bytes %d, line %d, file %s", \
++ "\n ALLOCATE error : bytes %lu, line %d, file %s", \
+ (count)*sizeof(type), __LINE__, __FILE__) ; \
+ exit(-1) ; }
+ /*
diff --git a/math/spooles/files/patch-Utilities+src+makeGlobalLib b/math/spooles/files/patch-Utilities+src+makeGlobalLib
index a39cbf0812b7..1c210dec77dc 100644
--- a/math/spooles/files/patch-Utilities+src+makeGlobalLib
+++ b/math/spooles/files/patch-Utilities+src+makeGlobalLib
@@ -1,6 +1,6 @@
---- Utilities/src/makeGlobalLib.orig Thu Sep 17 21:26:39 1998
-+++ Utilities/src/makeGlobalLib Thu Sep 30 23:34:16 2004
-@@ -14,6 +14,7 @@
+--- Utilities/src/makeGlobalLib.orig 1998-09-17 19:26:39 UTC
++++ Utilities/src/makeGlobalLib
+@@ -14,6 +14,7 @@ SRC = CV.c \
PIV.c \
IP.c \
I2OP.c \
diff --git a/math/spooles/files/patch-makefile b/math/spooles/files/patch-makefile
index e61342cc3600..971f0bde1d8d 100644
--- a/math/spooles/files/patch-makefile
+++ b/math/spooles/files/patch-makefile
@@ -1,5 +1,5 @@
---- makefile.orig Tue Jan 26 05:39:39 1999
-+++ makefile Mon May 5 08:30:58 2003
+--- makefile.orig 1999-01-25 20:39:39 UTC
++++ makefile
@@ -1,169 +1,169 @@
drivers :
- cd A2 ; make all_drivers
diff --git a/math/spooles/pkg-descr b/math/spooles/pkg-descr
index 1f5ea0d03e46..109641369c88 100644
--- a/math/spooles/pkg-descr
+++ b/math/spooles/pkg-descr
@@ -17,4 +17,4 @@
methods. The preconditioner is a drop tolerance factorization,
with or without pivoting for stability.
-WWW: http://www.netlib.org/linalg/spooles/spooles.2.2.html
+WWW: http://www.netlib.org/linalg/spooles/spooles.2.2.html