aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorstephen <stephen@FreeBSD.org>2014-01-01 12:00:22 +0800
committerstephen <stephen@FreeBSD.org>2014-01-01 12:00:22 +0800
commit3e555daad912643384ab8bdd66b3a65ccc5f9051 (patch)
tree52887d674a86c1a187b1a0d377f36e419ac5e94b /math
parent054e805fa08d776aa6cf2c51d80c8808ce1cf244 (diff)
downloadfreebsd-ports-gnome-3e555daad912643384ab8bdd66b3a65ccc5f9051.tar.gz
freebsd-ports-gnome-3e555daad912643384ab8bdd66b3a65ccc5f9051.tar.zst
freebsd-ports-gnome-3e555daad912643384ab8bdd66b3a65ccc5f9051.zip
- New port math/octave-forge-mvn.
The octave-forge package is the result of The GNU Octave Repositry project, which is intended to be a central location for custom scripts, functions and extensions for GNU Octave. contains the source for all the functions plus build and install scripts.
Diffstat (limited to 'math')
-rw-r--r--math/Makefile1
-rw-r--r--math/octave-forge-mvn/Makefile25
-rw-r--r--math/octave-forge-mvn/distinfo2
-rw-r--r--math/octave-forge-mvn/pkg-descr10
-rw-r--r--math/octave-forge-mvn/pkg-plist1
5 files changed, 39 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 040f1d1ec013..e50e73dad20d 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -316,6 +316,7 @@
SUBDIR += octave-forge-missing-functions
SUBDIR += octave-forge-msh
SUBDIR += octave-forge-multicore
+ SUBDIR += octave-forge-mvn
SUBDIR += octave-forge-nan
SUBDIR += octave-forge-ncarray
SUBDIR += octave-forge-netcdf
diff --git a/math/octave-forge-mvn/Makefile b/math/octave-forge-mvn/Makefile
new file mode 100644
index 000000000000..1b10bf0485b4
--- /dev/null
+++ b/math/octave-forge-mvn/Makefile
@@ -0,0 +1,25 @@
+# Created by: Stephen Montgomery-Smith <stephen@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= octave-forge-mvn
+PORTVERSION= 1.1.0
+CATEGORIES= math
+
+MAINTAINER= stephen@FreeBSD.org
+COMMENT= Octave-forge package ${OCTAVE_PKGNAME}
+
+# OCTSRC is the name of the directory of the package.
+# It is usually ${OCTAVE_PKGNAME} or ${DISTNAME}.
+OCTSRC= ${OCTAVE_PKGNAME}
+
+NO_STAGE= yes
+.include "${.CURDIR}/../../Mk/bsd.octave.mk"
+
+do-build:
+ @${DO_NADA}
+
+post-build:
+ ${RM} -f ${WRKSRC}/Makefile ${WRKSRC}/configure
+ cd ${WRKDIR} && ${TAR} cfz ${DISTNAME}.tar.gz ${OCTSRC}
+
+.include <bsd.port.mk>
diff --git a/math/octave-forge-mvn/distinfo b/math/octave-forge-mvn/distinfo
new file mode 100644
index 000000000000..a6a76be1bdd8
--- /dev/null
+++ b/math/octave-forge-mvn/distinfo
@@ -0,0 +1,2 @@
+SHA256 (octave-forge/mvn-1.1.0.tar.gz) = af5a16b91cb6b83ef05ba62321fc1b8a90c8fe7ee79a4fc819b5618b3b4c8603
+SIZE (octave-forge/mvn-1.1.0.tar.gz) = 20623
diff --git a/math/octave-forge-mvn/pkg-descr b/math/octave-forge-mvn/pkg-descr
new file mode 100644
index 000000000000..91a5e1f928ef
--- /dev/null
+++ b/math/octave-forge-mvn/pkg-descr
@@ -0,0 +1,10 @@
+The octave-forge package is the result of The GNU Octave Repositry project,
+which is intended to be a central location for custom scripts, functions and
+extensions for GNU Octave. contains the source for all the functions plus
+build and install scripts.
+
+This is mvn.
+
+ Multivariate normal distribution clustering and utility functions.
+
+WWW: http://octave.sourceforge.net/
diff --git a/math/octave-forge-mvn/pkg-plist b/math/octave-forge-mvn/pkg-plist
new file mode 100644
index 000000000000..a999ec86c07e
--- /dev/null
+++ b/math/octave-forge-mvn/pkg-plist
@@ -0,0 +1 @@
+@comment This file intentionally left empty