aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2004-11-03 22:33:46 +0800
committerkrion <krion@FreeBSD.org>2004-11-03 22:33:46 +0800
commit3fb480f74d6da65b48497e67a28c8fd40e94dea0 (patch)
treef4f09daf83d56bee65e31990c6d4b391750d26e0 /math
parenteafa8bb79abf8b5993960725dfe6bc0d29f0dd28 (diff)
downloadfreebsd-ports-gnome-3fb480f74d6da65b48497e67a28c8fd40e94dea0.tar.gz
freebsd-ports-gnome-3fb480f74d6da65b48497e67a28c8fd40e94dea0.tar.zst
freebsd-ports-gnome-3fb480f74d6da65b48497e67a28c8fd40e94dea0.zip
Add e-0.02718, a tiny expression evaluator.
PR: ports/73454 Submitted by: Nicholas Stallard <snowy@netphile.de>
Diffstat (limited to 'math')
-rw-r--r--math/Makefile1
-rw-r--r--math/e/Makefile36
-rw-r--r--math/e/distinfo2
-rw-r--r--math/e/pkg-descr6
-rw-r--r--math/e/pkg-plist5
5 files changed, 50 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 78dafd9e0caa..01751e901697 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -34,6 +34,7 @@
SUBDIR += diehard
SUBDIR += djbfft
SUBDIR += drgeo
+ SUBDIR += e
SUBDIR += eispack
SUBDIR += emc2
SUBDIR += entropy
diff --git a/math/e/Makefile b/math/e/Makefile
new file mode 100644
index 000000000000..80fc42676eb3
--- /dev/null
+++ b/math/e/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: e
+# Date created: 3 November 2004
+# Whom: snowy
+#
+# $FreeBSD$
+#
+
+PORTNAME= e
+PORTVERSION= 0.02718
+CATEGORIES= math
+MASTER_SITES= http://www.softnet.tuc.gr/~apdim/projects/e/
+
+MAINTAINER= snowy@netphile.de
+COMMENT= A tiny expression evaluator
+
+MAKEFILE= makefile
+ALL_TARGET= e
+USE_REINPLACE= yes
+
+post-patch:
+ @${RM} ${WRKSRC}/${PORTNAME}
+ @${REINPLACE_CMD} -e 's|gcc|${CC}|g ; \
+ s|-O2|${CFLAGS}|g' ${WRKSRC}/makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for i in EXAMPLES GRAMMAR README
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/math/e/distinfo b/math/e/distinfo
new file mode 100644
index 000000000000..091450e492cb
--- /dev/null
+++ b/math/e/distinfo
@@ -0,0 +1,2 @@
+MD5 (e-0.02718.tar.gz) = 04b0b7415dd26551a88c1c70ca7bf514
+SIZE (e-0.02718.tar.gz) = 13926
diff --git a/math/e/pkg-descr b/math/e/pkg-descr
new file mode 100644
index 000000000000..63a94b98e53a
--- /dev/null
+++ b/math/e/pkg-descr
@@ -0,0 +1,6 @@
+This is the port of e, a tiny expression evaluator.
+
+WWW: http://www.softnet.tuc.gr/~apdim/projects/e/
+
+- Nicholas
+snowy@netphile.de
diff --git a/math/e/pkg-plist b/math/e/pkg-plist
new file mode 100644
index 000000000000..265aa26bb4b0
--- /dev/null
+++ b/math/e/pkg-plist
@@ -0,0 +1,5 @@
+bin/e
+%%PORTDOCS%%%%DOCSDIR%%/EXAMPLES
+%%PORTDOCS%%%%DOCSDIR%%/GRAMMAR
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%@dirrm %%DOCSDIR%%